Picom transparency setting not saved after reboot (24.04 LTS)

New day a new minor issue.

Been doing multiple reinstalls of 24.04 LTS for various reasons. noticed on every install Picom transparency is not auto turning on upon rebooting. Require clicking on picom application shortcut to activate transparency for it then to not be remembered on fresh boot.
It shows in the startup lxqt session settings correctly.

Please screenshot the session settings where you see it listed correctly.

1 Like

What about the “Basic Settings” pane specifically under “LXQt Modules?”

1
2

thats a fresh install of the os and updates and switching default monitor from left to right. Then switching to opengl and activating picom, logging off & on to see it working.

After rebooting pc transparency has gone. screen shot images are identical after a reboot.

1 Like

Ok, right. I was remembering incorrectly that picom had an LXQt Module. So the good news is you don’t have two different picom instances trying to start simultaneously, which can be a cause for failures.

I would start diagnosing this by seeing if you get any useful messages from picom. Unfortunately, it logs to stderr by default, so the only way to reasonably do this is to open a terminal and restart it:

killall picom
picom

You can also increase the level of detail by running it with different log levels. You’ll get increasing amounts of detail by using the following:

picom --log-level ERROR
picom --log-level WARN
picom --log-level INFO
picom --log-level DEBUG
picom --log-level TRACE

Those last two will give you quite a spew, so be careful.

Post any relevant information here.

Also, when you say you switch to OpenGL, you mean the rendering engine in picom? I assume you’re setting this with the Picom Configuration tool (picom-conf)?

It may be useful to have information about your graphics hardware and driver used. Could you run lspci -nnk and post here the parts that are relevant to your graphics hardware?

1 Like

Hi, yes you are correct OpenGL setting was set via the Picom Configuration tool.

Screen shots include the DEBUG & TRACE pictures taken externally by phone as they both completely crashed locking up computer forcing power off and on

The errors 161 & 146 seem to be from moving the mouse and clicking between the terminal adn areas of the desktop.





reboot.


Screenshots aren’t very useful, especially for the output from picom and absolutely from the DEBUG/TRACE input. In case it wasn’t clear, I was suggesting that you include here the relevant information, not just anything and everything. Also, I wasn’t suggesting that you run all of the different log levels, but start with the basic one, look at the results, and move to the next one if and only if nothing seems relevant.

Please try again and if you can’t just copy and paste the text (say, because you’re posting on a different machine than the one with the issue), please use pastebinit.

For example, you could run lspci -nnk > foo to output the information to a text file named foo. Then edit the file so only the relevant sections about your graphics hardware is included. Then do pastebinit foo and it will give you a URL where your paste is included. I would still urge you to actually copy and paste the information here because those pastebins do not last forever.

If you do plan on using the DEBUG/TRACE log levels (again, do this if and only if necessary because there’s nothing obvious from the other ones), I would do something like this:

timeout 5 picom --log-level DEBUG 2> foo

What that does is run picom for 5 seconds while outputting stderr to a text file named foo.

1 Like