PCManFM-qt showing wrong partition size


My KDE Partition Manager shows a partition on an external HDD as 2.73 TB.
My PCManFM-qt shows the same partition as 730.8 GB.


Attempted troubleshoot:

  • Formatted the entire drive, recreated new ext4 partitions.

Lenovo Ideapad Slim 3.

Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04
Codename: jammy

External drive in question:
Bus 004 Device 016: ID 0411:01f1 BUFFALO INC. (formerly MelCo., Inc.) SATA Adapter [HD-LBU3]


I wonder if it’s related to this decade old issue of using external disk enclosures with outdated firmware ?
Anyhow, here are some other ways of getting the disk size.

1 Like

That is really weird since I know it has been working perfectly well under MacOS as a 3TB drive. Now suddenly it doesn’t. Interesting though about the enclosure. Maybe I’ll take the disk out of the enclosure and try with an open enclosure. Thank you.

If the partition manager is recognizing the full size, that suggests to me that the whole disk is being recognized. Where is PCManFM-Qt misrecognizing the size? Could you share that screenshot too?

PCManFM-Qt is misrecognizing the size everywhere within that drive; in root path and elsewhere. I don’t have the drive with me now, but I haven’t been able to solve the issue. Haven’t tried open enclosure. I think I will give the drive to my partner so he can use it on Windows probably without issues.

Update: the drive won’t boot up anymore; as if it’s not drawing power from its power source (power cable). There’s been a past instance where something like this happened and after removing the drive from its enclosure it worked without issues. When I get a chance, I will try that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.