Partitioning error in installer

On to the next glitch! So I tried a real simple install: Erase disk. Make one big partition for the system. And the Installer gave me this error:

The installer failed to create a partition table on ST3160023AS.

========================================================================================== Create a new partition table (type: msdos) on ‘/dev/sda’ ========================================================================================== ========================================================================================== Job: Create new partition table on device ‘/dev/sda’ ========================================================================================== ========================================================================================== Command: sfdisk /dev/sda ==========================================================================================

I tried doing it manually in the KDE partitioner. No problem there. It reported success. No UEFI. Yes, used an MS-DOS partition. (No, not the original hard drive that came with the PC. It’s only 150G. The original hard drive was 500G.) Will report more when I have more.

Successfully installed Lubuntu 20.04! Ran through the install process 3 times. 1st time was with “Erase disk”, resulting in the failure to create a partition table I posted about above. 2nd time, I created a partition table manually, gave it one partition, then ran the installer, telling it to use an existing partition. It all seemed to work, but the PC would not boot the hard drive, kept falling back to the network boot. I booted the flash drive again, ran the install for the 3rd time, that time telling it to use the existing partition, and not delete any files. That worked.

I suppose it’s buggy BIOS that was giving me problems. Seems that for that computer, powering off really matters. Can’t do a soft reboot and expect things to work.

This looks like the following issue to me

I’d suggest you have a look at it, click ‘it affects me too’, and if you’re doing QA-testing on our tracker, provide the bug ID there (http://iso.qa.ubuntu.com/qatracker/milestones/408/builds)

If you don’t believe that is your issue, i would encourage you to submit your own bug with ubuntu-bug calamares using your install media (at a terminal).

Thank you for helping make Lubuntu better.

@bzipitidoo

Two things:

  1. Did you skip the image check at the beginning of the install?
  2. Do you find the same issue with 19.10?