"Operation system not found" message after installation


I tried to install Lubuntu 20.04.2 on my laptop from a bootable USB stick.

I launched a live session. Then I started the Lubuntu installer. I selected my location, keyboard, etc. Everything worked perfectly well. When the installation process finished, I switched off my computer, and when I started it again, I got this message :
Operation system not found

When I press “Enter” button, I have this message during 2 seconds (then I switch automatically to the boot settings) :

I tried to modify the boot settings (UEFI, legacy, etc.) but it did not work.

I have already searched how to fix this, but I did not found the solution yet :disappointed_relieved:

Any idea where to start ? I hope someone will be able to help me !

Start the live-medium, open a terminal and post the complete output of

sudo parted --list
sudo efibootmgr -v

Maybe you have to install efibootmgr first:

sudo apt install efibootmgr

thanks @apt-ghetto

I am trying this right now and come back in a few minutes

Ok. Here I post the results. Firts I installed efibootmgr ; my understanding is that it did not work.

lubuntu@lubuntu:~$ sudo apt install efibootmgr

Lecture des listes de paquets... Fait

Construction de l'arbre des dépendances       

Lecture des informations d'état... Fait

efibootmgr est déjà la version la plus récente (17-1).

0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

lubuntu@lubuntu:~$ sudo efibootmgr -v

EFI variables are not supported on this system.

lubuntu@lubuntu:~$ sudo efibootmgr --version

version 17

lubuntu@lubuntu:~$ sudo parted --list

Model: ATA ST500LT012-9WS14 (scsi)

Disk /dev/sda: 500GB

Sector size (logical/physical): 512B/4096B

Partition Table: msdos

Disk Flags: 

Number  Start   End    Size   Type     File system  Flags

 1      1049kB  500GB  500GB  primary  ext4

Warning: The driver descriptor says the physical block size is 2048 bytes, but

Linux says it is 512 bytes.

Ignore/Cancel? i                                                          

Model: SMI USB DISK (scsi)

Disk /dev/sdb: 32,3GB

Sector size (logical/physical): 2048B/512B

Partition Table: mac

Disk Flags: 

Number  Start   End     Size    File system  Name   Flags

 1      2048B   6143B   4096B                Apple

 2      1811MB  1815MB  4096kB               EFI

Model: Unknown (unknown)

Disk /dev/zram3: 497MB

Sector size (logical/physical): 4096B/4096B

Partition Table: loop

Disk Flags: 

Number  Start  End    Size   File system     Flags

 1      0,00B  497MB  497MB  linux-swap(v1)

Model: Unknown (unknown)

Disk /dev/zram1: 497MB

Sector size (logical/physical): 4096B/4096B

Partition Table: loop

Disk Flags: 

Number  Start  End    Size   File system     Flags

 1      0,00B  497MB  497MB  linux-swap(v1)

Model: Unknown (unknown)

Disk /dev/zram2: 497MB

Sector size (logical/physical): 4096B/4096B

Partition Table: loop

Disk Flags: 

Number  Start  End    Size   File system     Flags

 1      0,00B  497MB  497MB  linux-swap(v1)

Model: Unknown (unknown)

Disk /dev/zram0: 497MB

Sector size (logical/physical): 4096B/4096B

Partition Table: loop

Disk Flags: 

Number  Start  End    Size   File system     Flags

 1      0,00B  497MB  497MB  linux-swap(v1)


It was working. I have all informations I needed.

You have installed your Lubuntu in BIOS mode.
Go into your firmware settings and disable UEFI (enable legacy). Then set your disk at the first position in the boot order and your Lubuntu should start.

1 Like

@apt-ghetto, thank you for your help.

I did what you told:

But it still does not work. I still get the message “Operation System not found” :woozy_face:

I am missing something.

This looks similar to what I’m dealing with. I’m going to monitor this thread closely.

Hey, can I ask how you did the install? Did you let the installer do the partitioning or did you manually partition during the installation?

The screen should’ve looked like this:

If I am understanding correctly, I see that the hard drive only has one partition. Even when installing with legacy BIOS enabled, there should usually be another partition for the boot loader (usually grub).

The reason I ask how you did the partition section during the install is because I suspect that the boot partition wasn’t created for some reason. I really doubt the install would even succeed and I assume the installer has some kind of built-in protection against installing without one but I cannot test this right now.

Anyway, as far as I can tell, the reason the BIOS cannot find Lubuntu on the HDD is because there is no boot loader for it to find apparently. You need a boot partition so that GRUB can start Linux up.

Sorry that this doesn’t help much. I would take a look at the manual and try again following any advice there. I wanted to post a link here but I keep getting the manual for 21.04. Sorry! :sweat_smile:

1 Like

Hi @That_Random_Guy,
Thank you for your help.
I am pretty sure that I selected the “Erase disk” option when I did the install.
I will try another installation with my live USB, paying close attention to this step, and let you guys know.

Well… I did not make any progress :expressionless:

  • First I checked the firmare settings again : UEFI is disabled and Legacy enabled ;

  • I launched Lubuntu with my USB-live stick, entered the live session, then launched the installer ;

  • In “Partitions”, I picked “Erase disk” :

  • In “Summary”, I got this screen ;

  • The installation process worked fine. In the end, I got the “All done” confirmation message, inviting me to restart in my new system. I clicked on “done”.

  • I got the final message : “Please remove the installation medium, then press ENTER”. That’s what I did. Immediatly I got the “Operation System not found” message again :slightly_frowning_face:

Another information (I don’t know if it is relevant or not) : before trying to install Lubuntu, my PC used to run with Bodhi Linux.

Help ! :exploding_head:

1 Like

Very interesting… I need to do my research then 'cause my initial statement could’ve been wrong.

Before I start digging around… is there anything else you remember changing in the BIOS aside from UEFI/Legacy mode?

Interesting indeed. I tried same setup in VM and the installed system boots fine.

Few things to check.

  1. There is warning message saying physical and logical block sizes not matching. I don’t know what it means though.
  2. parted reports your drive model as ST500LT012-9WS14 where as the picture reads ATA ST500LT012-9WS142 with a 2 at the end. Not sure if the command trimmed the output or these are two different drives.
  3. There is ‘+’ beside ‘Hard Drive:’ and ‘Network:’. Do they expand? Is there any further selection available?
  4. Is first entry, ‘Boot Priority Order’ selectable?

No, one partition for the system is enough for old legacy installations. The bootloader is installed into the first sector of the hard disk.

Good point!

We can try to install the bootloader manually. Start the live-medium, open a terminal and execute line by line:

sudo mount /dev/sda1 /mnt
sudo mount -o bind /dev /mnt/dev
sudo mount -o bind /sys /mnt/sys
sudo mount -t proc /proc /mnt/proc
sudo chroot /mnt /bin/bash
grub-install /dev/sda

Please post every input and output again.
After that, please reboot.


Thank you, guys, for trying to help me :facepunch:

In UEFI mode, I remember having tried to enable and disable the “Secure Boot” option. Not a big deal I guess.

I don’t know either.

I don’t know. See 3. below, maybe.

Yes, it expands. There is only one entry : ST500LT012-9WS142. Maybe it answers point 2.


Here you go:

lubuntu@lubuntu:~$ sudo mount /dev/sda1 /mnt
lubuntu@lubuntu:~$ sudo mount -o bind /dev /mnt/dev
lubuntu@lubuntu:~$ sudo mount -o bind /sys /mnt/sys
lubuntu@lubuntu:~$ sudo mount -t proc /proc /mnt/proc
lubuntu@lubuntu:~$ sudo chroot /mnt /bin/bash
root@lubuntu:/# grub-install /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.
root@lubuntu:/# exit

After that, as recommended, I rebooted and… nothing changed.
I still have this “Operation System not found” message.

1 Like

NOTE: I do not have any expertise regarding the issue we are discussing. Just passing info from what I could get from online search.

It is possible there is issue with your hard drive. I checked online with ‘device descriptor’ error and found some information that may be of use to you.

  1. https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1708881
  2. https://askubuntu.com/a/915821/520965

While they were discussing USB stick not HDD like in your case, I think it may still be useful to you. If you are OK with experimenting (as it is only HDD on your PC), try

sudo wipefs --all /dev/sda

assuming your HDD is sda as per previous post.

You may have to be patient as it may take quite some time since your drive is 500G. Once done, you can try to reinstall Lubuntu and hopefully your issue will be fixed. If the problem still persists, could it be your USB? Wrong way iso image was copied to USB, may be?


From the “Lubuntu point of view” should everything work. The bootloader is installed into the first sector (MBR).

In my opinion, it looks like a wrong setting in the UEFI setup.

You could try to enable UEFI and disable the Legacy options, and install Lubuntu in UEFI mode.
On the “Partitions” screen of the installer, you should see “UEFI” instead of “BIOS” on the upper left side.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.