Oops. Grub and Windows Boot loader both working

I was running a dual boot Wind 7 / Ubuntu 14 on a 32bit netbook and decided to try the latest version of Lubuntu. So I just installed over the old Ubuntu.

Everything worked except I forgot that I had been using the free version of EasyBCD to manage the Windows Boot loader entries. Originally when I set this up with Ubuntu 14, I believe I did not install Grub. I just used easy BCD. But now I have a machine that boots into Grub and then if I select Windows it boots into the Windows Boot loader asking me to choose Windows or Lubuntu.

For various reasons I’d like to stay with the Windows Boot loader. Can I just delete Grub? And if so what’s the best way to do that?


Hey! You just need to re install windows bootmgr. It will delete grub during the process. To do that you will need a windows 7 installation usb or cd. Once you have an installation usb or cd ready follow following steps:

  • Boot using the installation media.
  • Select language if prompted and press continue.
  • On the following screen, select ‘Repair you computer’
  • This will initiate a scan of windows installations on your computer. Select your installation that we have to repair.
  • Once you reach ‘System recovery options’ screen, select ‘command prompt’.
  • Now type the following commands one by one:
    • bootrec /FixMbr
    • bootrec /FixBoot
    • bootrec /RebuildBCD
    • bootrec /ScanOS
  • The last command will scan for all operating systems and prompt an option to add lubuntu to boot options. Select yes. This should fix your problem.
  • reboot if prompted.

Let us know here if you face any issues.

That worked. Thanks.