Onboard virtual keyboard crashes on lubuntu 24.04

Onboard virtual keyboard is crashing on 24.04. You can start it but as soon as you try to click the icon in the taskbar to show the keyboard it crashes and disappears. This does not happen on 22.04 version.

What virtual keyboard are you referring to where?

I can confirm that there are problems with onboard. There are lots of warnings when installing it in a live Lubuntu 24.04 LTS via

sudo apt install onboard

so I was warned that things might not work.

Anyway, I tested with the default keyboard ‘us’

onboard

The keyboard showed up, but when moving the cursor onto it, the whole window with the keyboard disappeared with a message

Segmentation fault (core dumped)

in the terminal window from where is was started.

Edit:

See for example Onboard in Launchpad where there are links to some bug reports, ‘Latest bugs reports’.

1 Like

Oh, THAT onboard virtual keyboard. Yeah, unfortunately, that’s a bug to be reported and followed up with the onboard folks. Sadly, I see several other bugs with the same description that have been untouched for years, so that’s not likely a worthwhile endeavor.

I can’t necessarily recommend an alternative but other virtual keyboard options do exist in the archives. I think at one point qtvirtualkeyboard was something we encountered getting bundled with sddm. That might be worth a try.

2 Likes

I did test it and got it to work. There are two steps:

  1. Install the qtvirtualkeyboard-plugin package
  2. Set QT_IM_MODULE to qtvirtualkeyboard in lxqt-config-session, which you can see in the screenshot below, showing it in action.

2 Likes

I failed to make it work in Lubuntu 24.04 LTS live. After installation and tweaking and logout it was there at the login screen, but I could not activate it when logged in. How should I do that? What is necessary (further commands and/or tweaks beyond what is described in post #5)?

Look carefully and you’ll see that screenshot was taken of a live environment (in 24.04 the live environment has only one desktop and no desktop pager).

Specifically what I did:

  1. Boot 24.04 live
  2. At installer-prompt, click “Try Lubuntu”
  3. Follow the steps above
  4. Logout
  5. Login (the virtual keyboard popped up for this)
  6. At installer-prompt, click “Try Lubuntu”
  7. Open session settings to the the right panel
  8. Open Featherpad (virtual keyboard pops up)
  9. Take screenshot

I may have had to click in the input area to activate the virtual keyboard, but I don’t think so.

2 Likes

One thing to note that I didn’t explore further: it did not pop up for qterminal.

2 Likes

Thanks, now I see. I tried (only) with the terminal window qterminal, where it fails for you too. It does work for me with featherpad :slight_smile:

I cannot make it work with firefox and not with lowriter. So this qtvirtualkeyboard-plugin is rather limited unless we can make it work more generally with applications that expect input from keyboard.

1 Like

Well, I tried. I have even less experience with any other options, so I can’t really offer any other recommendations.

Well, let us hope that the onboard developers/maintainers will squash the bugs that affect 24.04 LTS.

Anyway, I added some heat to

by “affects me too”. We can all do that …

1 Like