Old Lubuntu 14.04 ISOs

Hi! Now that Ubuntu 14.04 is supported till 2024 I wanted to try out Lubuntu 14.04 with a very old machine, because I tried installing more current editions without success.
My guessing is drivers have been deprecated since. Its a Lenovo NC20 that uses somewhat exotic VIA Nano processor with Chrome9 graphics.
I plan to try if 14.04 allows me to install it, from there trying to upgrade.
I’d need both 32 and 64-bit ISO because, while the CPU is 64-bit, I have strong indication the capability is turned-off in laptop’s firmware for some reason.
Thank you in advance. I really appreciate your support

I believe your processor is fine for old and modern Linux. 32-bit Linux is probably preferred for this hardware just to minimize memory usage. If you have 4G of memory or more then use 64-bit Linux.

The issue will be the Chrome9 video hardware which Linux support has been poor and even broken over the years. Anyway you’ll need a non-composting X11 window manager ( LXDE, Xfce , IceWM, Openbox etc) as there is no 3D hardware acceleration support. You will definitely want the OpenChrome 0.4.0 DDX Driver from 2016…see the last link.

Some references:

3 Likes

Thank you. I expect 14.04 to have some support. Of course Lubuntu employs Openbox so should be ok. Where may I find the ISOs? They are no longer available in Ubuntu’s servers.

Lubuntu 14.04 LTS reached end of life in 2017-April; three years after it was released.

Ubuntu 14.04 LTS Desktop, Server had 5 years of supported life which could be extended using ESM which has been written about many places, but Lubuntu is not involved, and we do not support it. Maybe this notice will be useful.

We don’t support it, however I just checked, an old LXDE-Lubuntu web page still has a link to the ISOs, including i386, powerpc, amd64 including primary & alternate ISOs, but I won’t provide direct link as they are not supported releases for Lubuntu. You’ll have to search & find it, , but no they are not found on Ubuntu servers as they aren’t supported by Ubuntu any longer (whilst flavor support was 3 years, Ubuntu support was 5 years which ended 2019-April for 14.04).

Our last EOL notice is here where you’ll note it clearly states

After July 14th, the only supported releases of Lubuntu will be 20.04 and 22.04. All other releases of Lubuntu will be considered unsupported, and will no longer receive any further updates from the Lubuntu team.

2 Likes

See my update above especially the last link. You will want 2016 or later distribution with the OpenChrome 0.4.0 DDX Driver. I would suggest you start with the 18.04 Lubuntu , but please note Lubuntu 18.04 is soon no longer supported so the official folks here will likely not help you with an unsupported version. Note Ubuntu 18.04 is not End of Life until April 2028 so you can get some but very limited updates.

I will make an honest attempt to answer your questions if you have additional issues, but I don’t expect you to be happy with the results.
https://cdimage.ubuntu.com/lubuntu/releases/18.04/release/lubuntu-18.04.5-desktop-i386.iso

Honestly to set reasonable expectations what do you expect to do with this machine? If for simple programing, email, remote terminal / X client then above 18.04 Lubuntu might be OK.

You will not be able to run much modern software (restricted to 32-bit / 1 or 2G memory / old 18.04 repositories ). I hate to say this but Windows XP (NOT connected to internet) might be more useful.

1 Like

I’ll quickly add a link to Lubuntu 18.04 LTS End of Life (30-April-2021) where I talked a little about using a EOL release (specifically Lubuntu 18.04 LTS in that case) but whilst still before EOSS (end of standard support which 18.04 is).

We don’t know what the final position of what 18.04 will be come EOSS, particularly with recent blogs from Canonical, but don’t forget to consider the past releases and what happened, ie. for some packages the upgrades came only if you converted the initially supplied deb packages with snap packages. ESM/UA/Pro support isn’t identical to Standard Support so be aware of those differences, with 18.04 EOSS April 2023.

ps & fyi: at this time my ibm thinkpad t43 used in example in 7th post on that thread still has 18.04 on it; but I expect that system will be replaced by Debian when EOSS is reached

2 Likes

Personally I’d just try installing Debian 32-bit on this machine. It will be actively supported and should work well enough if you use a desktop environment like LXDE.

If you really want Lubuntu 14.04, I can probably get a download link for you out of the Internet Archive, but it’s very much not recommended.

3 Likes

I do agree with ArrayBolt3. Debian 11 32-bit is probably your best option. Dealing with all the oddities and frustrations of an old unsupported distribution are not something any user wants.

I have an ancient ThinkPad T40 (from 2001) with Debian 11 32-bit and runs OK with LXDE as a remote terminal / X Client. It’s just unable to handle the memory load of a modern browser.

3 Likes

Thank you all for your overwhelming support. I did not post earlier because I’ve been trying out several options. Unsuccesfull so far, but it was very close!
First problem is just access the intaller. Any 20.04, 22.04 (of any Ubuntu flavor) or Debian 11 ISO result in ‘Kernel pannic- address offset’ that led me to think was related to 64-bit, but its not the case. 64-bit is fine.
Then there’s the peculiar Chrome9 GPU. Thanks to inxi utility I found drivers install in 16.04 and previous releases but seems deprecated afterwards. It wasn’t posible to install them trough Synaptic either (unsolvable depency conflicts) so great thanks to ‘thetick’ because it linked the solution to that.
The goal is installing whatever I can, then upgrade to supported LTS (20.04, as I learned as well). Both Xubuntu and Lubuntu 18.04 upgraded without errors. But reboot failed … This along the ‘kernel panic’ could be strong indication that modern Linux kernel is at fault here. Not very reassuring …
But I’ll keep investigating (takes long installing / upgrading entire OSes in such humble machine).
I’ll update post.

Hi, @dm29 :slight_smile:

You’ve mentioned “Lenovo NC20” in your post, but I believe that you intended to write “Samsung NC20” instead. Am I right?

2 Likes

It’s the Lenovo IdeaPad S12, which is pretty identical. I mismatched terms 8-).

2 Likes

So. I was able to pinpoint the issue. Is not about 32 or 64-bit, init system (I tried Devuan), package base (openSUSE fared no better) or anything but kernel version. 5.4 LTS works. But anything above and I can’t even make it to the installer due that ‘kernel - panic: not syncing. Interrupt fatal error’. BUT, this means Lubuntu 20.04.1 should work. Its supposed to be available in Ubuntu’s own servers but link points to 20.04.5 whose kernel is more modern. Could anybody provide 20.04.1 ISO?
I would settle there for now. Perhaps future LTS kernels will work at some point but great having get to this far.
Thank you so much for your help.

1 Like

You can find a 3rd party link at LXDE-lubuntu/Alternate_ISO - Community Help Wiki which will provide the ISO you’re looking for.

You’ll note elsewhere on this forum where old i386 IBM Thinkpad owners with specific video graphics could only use kernels up to 5.3 (19.10 or eoan but no media ever existed for that release in i386) or 18.04.4 using the HWE kernel stack, but switching to the older GA kernel stack returned systems back to 4.15 kernel, and that site was where I pointed people too if they needed it (though post install you can add the additional stack if the machine is stable, OR if you have both stacks installed before release-upgrade then both stacks will exist post-upgrade meaning you’ll have the older most-stable stack & latest-stable stack both available at grub on first boot, as covered elsewhere on this site too; I didn’t mention that on this thread as 18.04 to 20.04 upgrades are not supported by Lubuntu due to switch of desktop).

2 Likes