No sound with lubuntu installation on Toshiba Chromebook 2 (CB30-B-103)

Hi all,

I’m new to Lubuntu and wanted to evaluate it on a live USB stick to use as a lighter alternative to the full Ubuntu distro. I’m using a Toshiba Chromebook 2 (Toshiba CB30-B-103) and wanted to evaluate lubuntu before installing to make sure everything worked as it should.

Everything seems to work fine from the live USB with one exception - unfortunately, I’m getting no sound! I can’t get any sound from the onboard speakers, nor if I plug in an external speaker.

I did the usual thing and search online, and whilst I did find some relevant articles, all the information I could find was at least 3-4 years old. Things move quickly, and I just wanted to make sure I am getting the most up-to-date advice to resolve the issue.

Hoping someone here can help - and full disclosure, I am a linux beginner!

My live USB lubuntu version is: 19.04 Disco Dingo (LXQt).

Thanks in advance,
Jack

Welcome to Lubuntu.

I don’t know your box/chromebook, but I’d get details of your sound hardware (ie. chipset used), using

sudo lshw -C sound

which is list-hardware (lshw) of class=sound (-C sound). That will provide details that you can explore online (far more usefully than the toshiba model number), and let you see if it’s recognized & what driver has been assigned (if any, the driver= bit). It’s also useful information for people here to try and help you with.

Hi guiverc,

Thanks for this! I have enclosed the details below:

lubuntu@lubuntu:~$ sudo lshw -C sound
  *-multimedia              
       description: Audio device
       product: Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 0e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:91 memory:d0914000-d0917fff

I’ll see if a search using this information reveals anything more…

Once again thank you for any advice you can offer!

Thanks,
Jack

Sounds was recognized as intel with driver chosen. As stated I don’t know your hardware so don’t know that that is accurate but I’ll assume it is.

At the menu type pav (you’ll see it shows Pulse Audio Volume Control which is my go-to for sound issues). Press to run pavucontrol.

I would expect here it can be fixed (unless it reports as dummy output). I don’t know what you’d change, but look in Playback, Output Devices, and Configuration tabs. You may have to toggle something off mute, switch port to value (or switch port/profile off & back on). See if you can work it out from there :slight_smile:

Hi again @guiverc!

Unfortunately, whilst running pav the only Output Device which displays is a ‘Dummy Output’ which cannot be configured.

Interestingly, in the configuration tab I can see a number of ‘Built-in Audio Profiles’ which are all HDMI based, and all show as unavailable and unplugged (unsurprisingly, as nothing was plugged in to the HDMI port).

I did in-fact try plugging in a HDMI monitor and managed to get sound running through that, which is great, but at this point my only option is to have sound running is through an external HDMI device.

I will continue my search…

Thanks again for your continued help,
Jack

EDIT: I forgot to mention, I did also try connecting an external speaker and some earphones via the aux port, but neither of these showed up in pav.

have you look at the audio config UI? Las tab let’s you decide which output to use.

The one thing about lshw that stinks is it doesn’t give the PCI ID and I find this is super useful to do searches for information on since it’s unambiguous. Also, if you play your cards right you can see not only the kernel driver being used but all the kernel modules available. Try lspci -nnk | grep -A 3 Audio.