My internal hdd are not begin detecting


I’m facing the same issue with other distros like puppy Linux and antiX along side with Lubuntu.

lubuntu@lubuntu:~/Downloads$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04.4 LTS
Release:        22.04
Codename:       jammy
lubuntu@lubuntu:~/Downloads$ lsblk
loop0    7:0    0   2.7G  1 loop /rofs
loop1    7:1    0     4K  1 loop /snap/bare/5
loop2    7:2    0  74.2M  1 loop /snap/core22/1122
loop3    7:3    0 262.5M  1 loop /snap/firefox/3779
loop4    7:4    0   497M  1 loop /snap/gnome-42-2204/141
loop5    7:5    0  91.7M  1 loop /snap/gtk-common-themes/1535
loop6    7:6    0  40.4M  1 loop /snap/snapd/20671
sda      8:0    1  14.6G  0 disk 
├─sda1   8:1    1  14.6G  0 part /media/lubuntu/WINSETUP
└─sda4   8:4    1   2.9G  0 part /cdrom
zram0  251:0    0   1.4G  0 disk [SWAP]

My issue is I cannot proceed to install Lubuntu because the HDD are not being detected by the system. I have some old distros and I can install them without facing the HDD detect issue (e.g xubuntu-19_10-desktop-amd64). I’ll be looking for your guidelines and answers.

Thanks you!

You’re trying to boot/install an older release of Lubuntu (ie. four releases ago) or the 2022-April software stack. I’d likely have tried booting the most recent release (ie. Lubuntu 23.10) to see if the newer software stack does any better. Even your mentioned Xubuntu example is from 2019. Puppy (as far as I’m aware) is also an older software stack; as is AntiX. If the drive is new, you’ve not tried newish software as far as I can tell.

Does your machine firmware detect the drive? Generally, if the machine hardware/firmware itself doesn’t detect a drive, you can’t expect software on that device to perform better than the hardware itself can.

Is your drive functional?? Have you explored health using SMART? using the drive’s electronics?

I have downloaded this release especially because Lubuntu was saying, “Recommended for most users. Supported until April 2025.”

Actually, my machine works normally without any issues, and I have several OS installed. I started encountering this issue when I started downloading newer updated distros. At first, I thought the error was from my HDD, but after some tests, it turned out that the OS was the issue.

Yes, my drive is functional and working without any issues. Last time I checked the drive health, it was at 98%.

Tbh, I wouldn’t have posted in this forum if I had already tested the latest Lubuntu release and encountered the same issue. The reason I’m reaching out here is to seek a solution that doesn’t involve re-downloading the entire system.

1 Like

Lubuntu 22.04.4 LTS installs will use the HWE kernel stack, which is the 6.5 Linux kernel.

That maybe (I wonder) explain why you tried 19.10 or an older stack (5.3 kernel).

Ubuntu 22.04 LTS has the 5.4 as it’s older (GA) kernel stack option; if it’s easy to try, you could download Ubuntu 22.04 LTS (link of 22.04.1 of Ubuntu Desktop here as the Lubuntu ISO isn’t as easy to find as Canonical don’t archive older flavor ISOs) but given you had failure with 5.3, I suspect it may not see it either, but at least the 5.4 kernel on the 22.04 is still security patched, thus an option if it works; [manifest or what’s on ISO here]( if interested).

If you wanted to confirm older ISOs, you should be able to find 20.04 or focal ISOs from the aforementioned details pretty easily, but we don’t support 20.04 (kernels used by 20.04 were 5.4, 5.8, 5.11, 5.13 & 5.4 thus older options).

What is your machine?
What is the actual drive?

Your details now make me think your machine is old, and I can’t recall any circumstance (at least currently) where I’ve been unable to read disks except as a result of user (intended or accidental) behavior; eg. calamares or the installer we use can ignore drive if busy for example; such as if the drive has a swap partition the live system has started using (usually this is the result of a user doing something to cause it; ie. my intended/accidental ref). The installer ignores that drive during to it being used; the fix for which is to umount or swapoff before starting calamares (the installer).


Sorry for late respond …

This older image were already existed in my other HDD and that was before long time. I have started trying these images once I start encountering the HDD detect issue with the new updated distros.

I have serval old images stored in my HDD, and one thing I have notice about linux distros, the more they get updated the more they become larger and slower.

I can run the old images without getting much performance issues, but I the only reason why I stopped using these old distros is that their package mirrors are no longer working.

Here’s my device specs:

System Model: Precision M4400
Processor: Intel(R) Core™2 Extreme CPU X9100 @ 3.06GHz, 3059 Mhz, 1 Core(s), 1 Logical Processor(s)
Installed Physical Memory (RAM): 2.00 GB
GPU: NVIDIA Quadro FX 1700M

How could I achieve that, can you please write the steps to do that?

How do you know the drive isn’t being detected?

The drivers are not shown when I go to the file explorer. Also it’s not shown when I try to mount it with gparted gui. and It’s not shown when I use lsblk -a or parted -l

That sure sounds like a hardware issue to me. Have you checked your system logs for any clues?

1 Like

Well than I doubt there will be any issue with my drive.

How could I check it ?

If mount shows the drive as mounted, that’s what’s preventing you from installing in Lubuntu.

If lshw -class disk does not show the drive, then the kernel does not detect it.

journalctl can be used to look at logs.

1 Like

The issue has been confirmed, it’s from the kernel itself which causes some incompatible issues with my device. I was able to boot and see my internal drive with the latest antiX (antix 23.1) by help of admins there and this after downgrading the kernel into 4.9.x which was the before downgrade resulting in the same behavior explained here. The question is are there any a way to change/downgrade the kernel used in Lubuntu from within the system itself?

If the answer are no then please feel free to close this thread.


I mentioned Ubuntu provides kernel stack options for the LTS releases already; the GA being the oldest and most stable option, where as HWE changes over two years to newer kernels (plus some hardware may have some other OEM kernels available too).

It’s documented here - Kernel/LTSEnablementStack - Ubuntu Wiki

To switch from HWE to GA kernel stack, search for “To downgrade from HWE/OEM to GA kernel” which gives the command(s) to do it.

Also note the wording in the doc, it suggests testing the change BEFORE you remove the unwanted stack… ie. you can decide to never remove the unwanted stack and thus have multiple kernel stacks installed; which will use a little more disk space, more bandwidth for kernel upgrades (as they’ll all get upgrades), and you can select at boot (ie. grub) which you’ll boot into. Also note some closed-source kernel modules (eg. some Nvidia) can prevent multiple stacks co-existing, but that’s not an issue if using open-source code.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.