My external monitor freezes

Since today my external monitor freezes every 10 minutes. I have searched and found that it happened to many other people using Ubuntu (see here and here).
It is really strange because it never happened to me before today, and I don’t remember changing significant things in the middle.

Could you help me diagnose the problem?

The first link is a person that is using Fedora and not Ubuntu.

Can you share what version of Lubuntu you have?

Have you tried to boot using an older kernel? If not, can you try? Maybe that will show a different result.

Also, what kind of computer are you using? What monitors?

Thanks for your reply.

Can you share what version of Lubuntu you have?

I’m using Ubuntu 22.04.3 LTS (jammy).
Here is more information (output of inxi -F):

user@user-myPC:~$ inxi -F
  Host: user-myPC Kernel: 6.2.0-35-generic x86_64 bits: 64
    Desktop: LXQt 0.17.1 Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
  Type: Laptop System: Micro-Star product: Vector GP68HX 12VH v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-15M1 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: E15M1IMS.506 date: 04/13/2023
  ID-1: BAT1 charge: 85.0 Wh (96.4%) condition: 88.2/87.4 Wh (101.0%)
  Info: 16-core (8-mt/8-st) model: 12th Gen Intel Core i9-12900HX bits: 64
    type: MST AMCP cache: L2: 14 MiB
  Speed (MHz): avg: 2145 min/max: 800/4900:5000:3600 cores: 1: 800 2: 2500
    3: 800 4: 2500 5: 2500 6: 2500 7: 2500 8: 2500 9: 800 10: 2500 11: 800
    12: 2500 13: 800 14: 2500 15: 2500 16: 2500 17: 2500 18: 2500 19: 2500
    20: 2500 21: 2500 22: 2500 23: 2500 24: 2500
  Device-1: Intel driver: i915 v: kernel
  Device-2: NVIDIA driver: nvidia v: 535.113.01
  Device-3: Acer HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    resolution: 1: 1920x1080~75Hz 2: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (ADL-S GT1)
    v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1
  Device-1: Intel driver: sof-audio-pci-intel-tgl
  Device-2: NVIDIA driver: snd_hda_intel
  Sound Server-1: ALSA v: k6.2.0-35-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel driver: iwlwifi
  IF: wlo1 state: down mac: 08:9d:f4:2d:10:4f
  Device-2: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp58s0 state: up speed: 1000 Mbps duplex: full
    mac: 04:7c:16:a7:9f:b0
  Device-1: Intel type: USB driver: btusb
  Report: hciconfig ID: hci0 state: up address: 08:9D:F4:2D:10:53
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 1.84 TiB used: 830.29 GiB (44.0%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2400 MTFDKBA1T0QFM
    size: 953.87 GiB
  ID-2: /dev/nvme1n1 vendor: Crucial model: CT1000P3PSSD8 size: 931.51 GiB
  ID-1: / size: 937.53 GiB used: 12.43 GiB (1.3%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 6.1 MiB (2.0%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 484 Uptime: 14m Memory: 62.49 GiB used: 3.72 GiB (6.0%)
  Shell: Bash inxi: 3.3.13

Have you tried to boot using an older kernel? If not, can you try? Maybe that will show a different result.

I haven’t, and I don’t really know how to do it. Could you provide a link or explanation?

Also, what kind of computer are you using? What monitors?

The computer is an MSI Vector GP68HX 12VH laptop. The first monitor is that of the laptop computer.
The second monitor is an external one: LG 24MP 400-B (nothing special really)

This is quite strange and may well be due to a recent update (that is why it will be a good idea to revert to a previous kernel and try). It never happened before and now I can only use the 2nd monitor for a few minutes before it freezes. When that happens, I can avoid forced restarting by setting Lubuntu back to one monitor. I have reinstalled Lubuntu because I thought I had touched something and messed up, but now I have the “standard” installation and it happens again.

So, I will research how to revert to a previous kernel.
Any information/help on that will be useful.

1 Like

For what I have read so far, this is very likely to be caused by a) NVIDIA drivers, b) Linux kernel, or c) a combination of a+b.

If I revert to previous kernel, does anything else stay the same?

OK, confirmed, it is a driver issue. I’ll have to take this up with NVIDIA people, no point in continuing this thread here.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.