Multibyte String Functions Not Available on WordPress Server

Preface: I know how to install PHP and do minor troubleshooting.

I run our intranet site on Lubuntu 20.04 (just upgraded) with WordPress 5.5.2 and PHP 7.4.11. I’ve never had an issue with any plugins. We’re looking to improve the search so I purchased searchwp. It would not index. In troubleshooting the issue with the developer he realized that multibyte string extension/functions were not installed.

When I try to install (php7.4-mbstring) it returns:
Some packages could not be installed. This means that you have requested an impossible situation or if you are using an unstable distribution that some required packages have not yet been v=created or moved out of incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php7.4-mbstring : Depends: php7.4-common (-7.4.3-4ubuntu2.4) but 7.4.11-1+ubuntu18.04.1+deb.sury.org+1 is to be installedE: unable to correct problems, you have ha;d broken packages.

Can someone tell me what I need to do?

Lubuntu is not a server distribution. Lubuntu is a desktop system and therefore is normally used as a client system.
And most of the users in this forum, are using Lubuntu as a client system, so you might not find the necessary help here.

Even if you find an appropriate forum for your questions (I guess you are a crossposter => PHPhelp), you should provide infos and the complete terminal output (not only what you think could be useful).

It looks like you have installed PHP from a PPA and that there is a conflict with dependencies.

Good luck!

2 Likes

Thanks for your reply. As you can see I know just enough to be dangerous. Apologies for the bad nomenclature- I am aware it’s not a server distribution. We are a very small organization and the desktop distro was much easier to setup and has worked flawlesly for our intranet site.

Apologies also for crossposting- I did not realize the two sites were related. I had not received a single reposnse on PHPhelp, so I found this forum and posted my question. I also realize that it’s more a php issue but curious as to why it started only after upgrading to Lubuntu 20.04.

I am not aware of what infos are (general information or specific files). Could tell me how to get them or where I can find instructions to do so? I’ll post the terminal output here.

I understand the difference between repositories and PPAs but have no idea how I would have pulled from a PPA. I have always used the default repositories that the distro already has available.

image

Try sudo apt install --fix-broken whenever you see the old “you have held broken packages” problem. It usually fixes things up.

Regarding PPAs, grep -Rv '^#' /etc/apt | grep 'ppa.launchpad.net' should show you all of the ones you have enabled.

You can see all outside repos with something like grep -Rv '^#' /etc/apt | grep http | egrep -v '(ubuntu.com/canonical.com)'.

2 Likes

Fix broken:
image

PPA:
image

You’re using an unsupported PHP repo it seems.

I never saw this error until recently I upgraded to Lubuntu 20. Any idea how/why that would have put me on/added me to an unsupported PHP repo? That’s what I find so strange.

It wouldn’t have. You already had it set up that way. However, there’s nothing to say that the maintainer of that repo didn’t cause problems with the packaging they provided. You would need to contact them. There’s a place to file bugs and such listed on the repository info page:

I’ll also add that it does seem that’s set up to use the Bionic (18.04) version, so that’s kind of problematic, too.