LXQT desktop has changed in gnome after the last update!

Hi to Everybody,
this morning I’ve updated several machines, all with Lubuntu 22.04.
So, as usual, I’ve checked one of those computers and it has happened a very strange thing (at least to me): the Grub and Lubuntu logo were as usual, but then it has loaded… a Gnome desktop!!
Now, I’m using right now a Gnome desktop instead of the LXQT one: I didn’t find something similar to my case on the web, anyone can help me? Now, I’m frightened to test the other machines.
Obviously, it doesn’t change if I try other kernels.
When I shutdown the session, the Lubuntu logo reappear, also in the Grub there is Lubuntu.
Also the gnome session is not the “Ubuntu standard” one, but is seems more a “vanilla” version…
All the machines are in dual boot with Debian 11 (or 12).
Help me!!!

This is very interesting.

Do you recall if you had installed any kind of software recently?

Something might have pulled in Gnome when you added it to your Lubuntu system… but how Gnome wound up getting put as default over LXQt doesn’t add up to me. Then again, never tried it.

Another thing would be to see if you can actually switch to LXQt before logging in.

Hi That_Random_Guy,

first of all, thanks for your reply.

No, that machine is quite stable, since it is above all used for playing to Minetest and web browsing.

Unfortunately, I can’t switch to other desktops before to log in, there isn’t any option.

I’ve never used a “default” Ubuntu, only some other flavours in the past like Xubuntu, Kubuntu etc., but from the images I found on the web it’s not the default Ubuntu Gnome version, it’s more similar to a vanilla version as I wrote in my previous post.

I’ve done only the usual, classical and normal update activities: sudo apt update and then sudo apt full-upgrade. Nothing more, as I always do… it is very strange, isn’t it?

Hi Andrea,

Can you please login and open a terminal and copy/paste the resulting text that returns after running these commands from the command line:


cat /etc/X11/default-display-manager

I just booted up the LIVE image that I had for 22.04.2 and I’m wondering if it will show the same text as mine or where it may be different.

If you can also provide a screenshot for what you see at the login screen before logging in, that would also help us see what you’re seeing now.

ciao John,


zambo@zambo-hptatini:~$ echo $XDG_CURRENT_DESKTOP


zambo@zambo-hptatini:~$ cat /etc/X11/default-display-manager

Now I will reboot and with my phone I try to make some images…

Other notes:

→ in this strange gnome desktop there are no default applications, so in order to do anything I’m installing the minimum to survive through Xterm;

→ my Chrome account is ok, I didn’t have to login;

→ all my installed games are still there;

→ the display server is now Wayland…

Ok, let’s go to take some pictures!


Here I am with the pictures: please, consider that the screen of my notebook has some defects in the low part, infact once booted into the OS I use another monitor. So, it’s normal to see those bad lines in the low part of the screen.

boot screen

while booting

login screen

Thanks in advance

Could be useful if I post the content of history.log file in /var/log/apt?

Sure, I can take a look at that. :slightly_smiling_face:

Ciao John!

Well, here is the last history.log file: history.log

I understand that the best thing is to reinstall Lubuntu, all my datas seem safe so it’s the easiest option though, but I would like also to understand why this problem has happened… a malware maybe?

Another strange thing: I have checked today (yesterday I was sad to do this…) 4 machines that I have update yesterday. Well, two are ok, but the other two notebooks didn’t have anymore the GUI!! This morning I had to install lubuntu-desktop on them… Do I have some ghosts in my notebooks? :joy:

The ‘desktop-broken’ computers are notebook of 2019, so not so old…

Thanks in advance!

This is very odd indeed. My understanding of how the updates work is… it really shouldn’t pull anything down that you haven’t already added yourself or that didn’t already come with the install. At least, something like Gnome as a DE itself seems like a really odd thing to include as an upgrade unless something else that was added to the system somehow required it or something that needed Gnome to run.

I would not rush to label this as malware… unless you know of something you may have added to your system that was very experimental and or not very trustworthy. Too soon and too little info to go on, so I wouldn’t worry about that for now.

What makes this odd is that you have other PCs where (I’m assuming) they are also running the same Lubuntu and their updates have not caused the same behavior/result.

As a short-term workaround, you might be able to try something I found from here:


2. Run command to reconfigure the default manager:

sudo dpkg-reconfigure gdm3

3.) It will bring up the package configuration screen, if you have more than one display managers installed:

4.) Hit enter in the previous screen, then press Up / Down arrow keys to switch the display manager and hit Enter.

*The one you will want to choose is SDDM and not gdm3

The change will be applied in next boot. Enjoy!

Looking through the apt history you shared… I see that a lot of Gnome stuff got added and some LXQt stuff got removed for the first full upgrade. Not sure what this means. It might help to see some of the archived history files that should be in the same folder with .gz extension.

You can share again via same method or you can use pastebin.


1 Like

It is probably caused by Bug #2025462 “Apt deletes ubuntu-desktop during dist-upgrade” : Bugs : apt package : Ubuntu

Does sudo apt install lubuntu-desktop fix the issue?


Ciao Apt-Ghetto!

Yes, on the two machines with the lack of the GUI at the login, installing lubuntu-desktop has solved the problem: thanks for having showed to me that I’m not alone :slight_smile: (although it is related to gnome, but it has happened to my notebooks with Lubuntu 22.04).

The very odd fact is the change in one HP notebook from Lubuntu 22.04 to Gnome…

1 Like

Ciao John!

Now I will test the short-term solution you have indicated.

In the meanwhile:

→ Yes, all the machines run with Lubuntu 22.04 (one with gnome in this moment :joy:)

→ now I post the history.log.2.gz (the previous one I have posted was history.log.1.gz): history.2

→ here the history.log.3.gz: history.3

→ the last one, history.log.4.gz: history.4

I’ve however noticed that the problems on all those machines have begun with the installation of Minetest… could be it related in some way? I’ve got a lot of problems in running this game due to the graphic cards… now I’m looking for a culprit at all costs :sweat_smile:

1 Like

Ciao John!

No, it seems that I’ve only one display manager installed, no more SDDM… the command didn’t show me any alternative.

Do I have to reinstall lubuntu-desktop packages?

Thanks in advance.

I think that would be the next best thing at this point unless @apt-ghetto maybe has another idea. :grin:

Once that is installed, and if it brings back Gnome still as default after rebooting, you can try what I shared again about changing the display manager from gdm3 to sddm.

I don’t see any Minetest bugs that look related to this problem but I can keep looking.

1 Like

Ciao John!

Well, I’ve just installed lubuntu-desktop packages and… LXQT has come again on my screen!

Yes, this solution has solved the situation and now I can even choose at login to try Gnome on Wayland if Lubuntu should annoy me :rofl:

Jokes apart, I consider what has happened very strange anyway, but I’m also happy to have solved: in your opinion could be safer if I reinstall the OS or - if you were me - you would continue with this situation?

Thanks again, maybe on the next update I will find Xubuntu at login (it’s a long time I don’t use it :grin:).


Ok, maybe the problem is solved: however, the mystery remains as to how this could have happened.

I will not reinstall and I see if something else happens (I hope not :slight_smile: )

Thanks John and Apt-Ghetto anyway for your help.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.