Lubuntu won't boot after upgrade via Muon Package Manager

I was faced with a blue screen just displaying “lubuntu” centre bottom of screen - no mouse response to touch pad, no response to any keys except power off.

I tried powering off and on again with shift to get to GRUB . That worked but none of the grub options got me back to a bootable machine. I took the noob’s way out and reinstalled lububtu from a USB stick.
Back to normal now but I’d like to know what happened so i can avoid it happening again. Should I avoid using Muon? Any suggestions for a noob friendly article or tutorial on using grub recovery tools?

Since we can’t really get back to the previous install, we can’t really say for sure without being able to at least investigate the logs for clues. Not sure what Lubuntu release you installed but you can also try to boot the live USB to troubleshoot next time (assuming you did an unencrypted install). Also, when booting and when the Lubuntu logo shows up, you can hit the esc key on your keyboard to show the boot process text. This is usually accessible and can show important info for booting hiccups.

Do you maybe remember what grub options you tried to use to get the booting to work? Usually you have older kernels in your /boot so that if a newer kernel causes you problems, you can just boot using an older kernel that’s been proven to work for you. This is something you can usually see from grub.

I am not so sure about the Muon question… I haven’t seen many issues reported here so I can’t really speak to that. I personally haven’t had issues with it on my install so we would only be able to provide input if we had the chance to see what the logs said if anything.

1 Like