Lubuntu UEFI install


I am trying to install lubuntu 22.04 on DELL Optiplex 7060 (tiny) PC. The Optiplex 7060 accept Legacy boot (MBR) only for external device such as USB but does not accept Legacy/MBR for internal device such as internal HDD. To install Lubuntu on this computer i must use UEFI.

The standard Lubuntu install soft creates a MBR Partition out of the box. So i switch to “manual partitioning” during the install.

I made two partitions :

  • 1 FAT 32 partition with 512 Mo and with flag “boot” and mountpoint /boot/efi
  • 1 ext4 partition with flag “root” and mountpoint /

After install I started the BIOS and I added this new boot option in Boot sequence/UEFI.

After that the boot fails : no bootable partition was found.

Could you please tell me how to perform this partitioning to be compliant with UEFI ?

Thanks !

I just yanked the latest available image for 22.04 and I ran through the install in a VM.

I didn’t go through the install completely but I wasn’t entirely sure if the mount point needed to be /boot/efi after all but it does seem like that checks out.

The only thing I can think of is perhaps secure boot being enabled?

I can’t imagine that it took the boot mount point and it didn’t actually put everything under GPT.

I looked up Dell’s site and found this link:

It might not entirely apply to Lubuntu but the BIOS config parts probably still apply.

It might help to see screenshots for what you see from the installer when you boot from the USB.

Many thanks for your reply and for your support. I tried enabling and disabling secure boot but i get the same result in both case.

I think this issue could be du to the partitioning itself or to the setup of the boot sequence/ UEFI in the BIOS. The drive appears in the BIOS after installing with an UEFI partition. I added a mountpoint (not sure if /boot/efi is correct) but i didn’t find the file mentioned on the dell website you shared. Perhaps is it the key to fix that issue ?


Have you tried converting the drive to mbr instead?
Does your pc support uefi?

1 Like

Please start the live cd, open a terminal, install efibootmgr

sudo apt update && sudo apt install efibootmgr

and show the output of

sudo efibootmgr --verbose
sudo parted --list

yes i tried but the BIOS does not allow to boot on internal device with MBR.

For the EFI partition, maybe you also need the esp flag as well as the boot flag ?

Or perhaps you could try a GPT table instead of an MBR ?

1 Like

I recently installed two OSes on the following device which maybe rather similar to yours

dell [optiplex] 7050 (i5-6500, 16gb, intel hd530/i915)

I wrote the Lubuntu ISO as I normally do (I use mkusb & usually clone it to the thumb-drive) and installed both Lubuntu lunar and Lubuntu jammy in dual boot.

I know the Lubuntu installer will create either a

  • MBR install (single partition with no ESP) OR
  • uEFI install (ESP created)

depending on how the machine is booted. It’s normally a uefi/BIOS firmware setting that controls this, however some machines can be tricked to work one way according to how the ISO is written to installation media forcing an BIOS boot, or uEFI boot, thus how the ISO is written to your thumb-drive matters.

I’ll provide a link to this old answer on creating a ESP manually (partitioning - Lubuntu Installer Giving Error after Partition creation "YOUR SYSTEM MAY OR MAY NOT BOOT " - Ask Ubuntu), but how the it shows on screen varies on the version of calamares being used (22.04 & 22.04.1 have different versions) & that answer was for a much older version so adjust accordingly.

This is mostly FYI, but both jammy (22.04) & lunar (23.04) installed without issue for me on my dell 7050 using what I consider default options (I used the installs as QA-test installs, my lunar notes can be found here, jammy here)

1 Like

Thanks for you support !

Here is the result of sudo efibootmgt --verbose :

EFI variables are not supported on this system.

And the result of parted --list :

lubuntu@lubuntu:~$ sudo parted --list
Model: ATA Micron 1100 SATA (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
2 1049kB 53.5MB 52.4MB boot, esp
1 53.5MB 256GB 256GB ext4

Model: SA04G (scsi)
Disk /dev/sdb: 4010MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 4129kB 4010MB 4006MB primary fat32 lba

Model: Unknown (unknown)
Disk /dev/zram0: 4062MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0.00B 4062MB 4062MB linux-swap(v1)

I already installed lubuntu on DELL 7050 and DELL 7040 without any issue. The specific characterictics of the DELL 7060 is that this machine does not support Legacy / MBR for internal device. As i result i must install as EFI but my EFI install seems not correct.
The install wizard of lubuntu is more MBR oriented. EFI install seems more complicated.

Lubuntu install wizard recommands to flag as bios-grub. I tried flagging EFI part as boot and as bios-grub but it doesn’t work.

MBR is not supported for internal device on DELL 7060. Only EFI is allowed

The live cd was not booted in UEFI mode, so Lubuntu is not installed in UEFI mode. The solution is to boot the live cd in UEFI mode.

In the UEFI setup, disable in the “Advanced Boot Options” the option “Enable Legacy Option ROMs”.


It works ! Many thanks @apt-ghetto :grinning:

I didn’t know that it was not possible to install in UEFI when live system were started in legacy mode.
As i was booting from pxe (network boot) in legacy it was not working. I tried with an usb key in UEFI mode and the issue is fixed.
Do you know if booting from pxe/network in UEFI is possible ?

1 Like

I would not say that it is not possible. But it is easier to simply boot in the desired mode.

I never used PXE, but it should be possible to deliver the binaries according to the needs:

1 Like

I think i have to setup my lubuntu server to allow UEFI boot. Thanks for all your support.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.