Lubuntu / lxqt backspace key does ^H after stty erase ^H

Hi, I did search the forums and didn’t find anything.

I am running either Ubuntu with lxqt or Lubuntu, both in VirtualBox.

I have a problem where randomly, the backspace key will start printing ^H

I have run stty erase ^H many times (using the backspace key), but the problem keeps coming back

I have tried to create an .inputrc to set the backspace key but this doesn’t work.

I am surprised I can’t find any information on this, I can’t be the only one with this problem, in fact my co-worker has also seen this problem in VMWare.

Thanks for any help to fix this, we are creating a VM for a large online class and want to use Lubuntu with lxqt!

I pretty much exclusively test Lubuntu in VirtualBox and have never enountered this. Is this only within terminal or what?

Yes only within a terminal

In all terminal emulators? What about in virtual terminals?

so far I’ve only tried qterminal, you want me to see if I can recreate this in an xterm?

Well, there’s a lot of questions, really.

What version of (L)ubuntu? What version of the terminal? Do you see this on multiple terminals or only one (I’d personally try as many as possible)? What about virtual terminals? Work hard to eliminate as many variables as possible.

Most importantly, how can one reproduce this? Random events cannot really be reproduced and, as such can’t really be solved. Look for common conditions that occur right before the issue.

Thank you!

I don’t get what you mean by virtual terminal, I can’t Ctrl-Alt-F1 in VirtualBox if that’s what you mean.

OK I’ll try to reproduce this more regularly, I appreciate the help

It’s the 20.04.1 download, qterminal --version reports 0.14.1
I see it in multiple terminals but not at the same time, necessarily.
It seems to be related to use of Ctrl-V or using New Window from File menu in qterminal.

I’ll run some xterms and see if I can reproduce here.

Bottom line, if it’s not something you’ve seen, it’s nearly impossible to track down, I understand, and thanks again for the help.

Host Key+F1 is how you do it in VBox.

It seems to be related to use of Ctrl-V or using New Window from File menu in qterminal.

Keep working on that to see if you can’t reproduce it reliably. Ideally, work with a fresh copy of the installed system or boot from a live system so that it can be reliably reproduced on our end.