Lubuntu Jammy - Weird artifacts on display, choose older kernel version to boot with

Since today I see frequently some weird artifacts showing up on my display, just for a fraction of a second.

I want to make sure that it is not the display which is damaged, so I wanted to choose another kernel version, the one before the latest installed.

On boot process I could not halt the booting to choose a kernel version, like I know it from Ubuntu.
How to do that with Lubuntu?

I tried to hold the shift key on boot process, but this didn’t show me the advanced options for Lubuntu at the grub bootloader screen.

The current version is

uname -a                                                                                                                                                         
Linux MYCOMPUTER 5.15.0-17-generic #17-Ubuntu SMP Thu Jan 13 16:27:23 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Because everything was OK until yesterday, I assume firstly that maybe one of the updates yesterday are causing the trouble. But I don’t know what was updated yestersday… because this is a development version of Lubuntu, frequently updates are done, sometimes more than once on a single day.
That’s why I assume it would maybe be enough to just choose the kernel version before the current one installed.

It doesn’t make a difference if I choose LXQt or Lubuntu desktop on login, but I prefer LXQt.

I have a mini pc with Intel Celeron J4105 with integrated graphics unit Intel UHD Graphics 600.
Maybe something is wrong with the graphics drivers in the currently installed kernel version.

I see a message on boot process, don’t know since when this appears, if this maybe is the reason
0.292394 ] x86/cpu: SGX disabled by BIOS.

I also recognize that sometimes the mouse pointer looks not correct, somehow not sharply displayed, the borders look frayed or dotted or so, but after a while OK again.

You do realize that Jammy is still in beta, right? You had to seek it out deliberately. Using it has both consequences and responsibilities.

Anyhow, updating an installed Jammy was a bit weird yesterday. Can you post the complete output of:

sudo apt update && sudo apt upgrade -y

At this moment, that’s the only thing I can think of.

I know that Jammy is in beta, the betas before worked very well, this time I wanted to wait a bit longer until upgrade to Jammy beta, but because the web browsers reacted weird with Hirsute Hippo (21.10) (couldn’t open most of the sites, error like DNS something with HTTPS). After the upgrade to Jammy the web browsers worked much better, less of those site errors.

Here is your desired output (still the artifacts appear)

sudo apt update && sudo apt upgrade -y                                                                                                                           
[sudo] password for me:                                                                                                                                                        
Get:1 jammy InRelease [270 kB]                                                                                                                    
Hit:2 jammy-updates InRelease                                                                                                                     
Hit:3 jammy-security InRelease                                                                                                                    
Hit:4 jammy-backports InRelease                                                                                                                   
Get:5 jammy/main amd64 Packages [1.407 kB]                                                                                                        
Get:6 jammy/main i386 Packages [1.046 kB]                                                                                                         
Get:7 jammy/universe i386 Packages [7.598 kB]                                                                                                     
Get:8 jammy/universe amd64 Packages [13,8 MB]                                                                                                     
Get:9 jammy/universe amd64 c-n-f Metadata [282 kB]                                                                                                
Fetched 24,4 MB in 7s (3.489 kB/s)                                                                                                                                                 
Reading package lists... Done                                                                                                                                                      
Building dependency tree... Done                                                                                                                                                   
Reading state information... Done                                                                                                                                                  
3 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libmarkdown2 libpci3 pciutils
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 131 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 jammy/main amd64 pciutils amd64 1:3.7.0-6 [63,6 kB]
Get:2 jammy/main amd64 libpci3 amd64 1:3.7.0-6 [28,9 kB]
Get:3 jammy/main amd64 libmarkdown2 amd64 2.2.7-2 [38,3 kB]
Fetched 131 kB in 0s (368 kB/s)         
(Reading database ... 312679 files and directories currently installed.)
Preparing to unpack .../pciutils_1%3a3.7.0-6_amd64.deb ...
Unpacking pciutils (1:3.7.0-6) over (1:3.7.0-5ubuntu3) ...
Preparing to unpack .../libpci3_1%3a3.7.0-6_amd64.deb ...
Unpacking libpci3:amd64 (1:3.7.0-6) over (1:3.7.0-5ubuntu3) ...
Preparing to unpack .../libmarkdown2_2.2.7-2_amd64.deb ...
Unpacking libmarkdown2:amd64 (2.2.7-2) over (2.2.6-1ubuntu2) ...
Setting up libpci3:amd64 (1:3.7.0-6) ...
Setting up libmarkdown2:amd64 (2.2.7-2) ...
Setting up pciutils (1:3.7.0-6) ...
Processing triggers for man-db (2.9.4-4) ...
Processing triggers for libc-bin (2.34-0ubuntu3) ...

me@MYCOMPUTER:~$ sudo apt autoremove
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 Like

Thanks for the output. It doesn’t contain what I was looking for. When I updated my installed beta yesterday, it had a bunch of packages that wouldn’t install and I had to install them manually.

As for beta’s working great - I’d expect this is a temporary thing. I’d report this as a bug.

I keep an updated beta installed and just run updates daily and there was a bit of complexity yesterday. Something like, ‘the following packages have been skipped’ and I had to install them with an additional command.


Sometimes I have to use Discover to install some updates which somehow were not installed via apt. But Discover doesn’t show any updates now.

1 Like

Yeah, unless someone comes along and suggests otherwise, I’d go ahead and report it as a bug. The process looks laborious, but it’s not that bad. It’s even faster when you’ve done it a few times.

And, yeah, beta’s run great - until they don’t.

I was able to confirm that the shift button accesses the advanced menu - here. It’s a bit tricky with the timing, but it works here.


When do I have to press the shift key?

When I power on my mini pc it starts the boot process, I already press the shift key and keep it pressed the whole time, but boot process moves through until the login screen.

1 Like

Lubuntu jammy is still in alpha, having not reached the beta stage. Beta is still some way into the future

I did see a filed report (Ubuntu Desktop) which your initial post reminded me of, looking back though I see only reports related to Wayland which won’t impact Lubuntu.

If you’re having trouble dealing with grub as it’s too quick; I’d slow the delay so it remains on screen longer (I tend to do that on some boxes as my reactions just aren’t fast enough & needing to enter the encryption key puts me at a disadvantage). You can edit defaults at /etc/default/grub then just run update-grub so it takes effect.


The weird artifacts are in fact the open windows, which seem to be misplaced from their position to another position for a fraction of a second and then back to their original position. Looks like also the size is changed too for that short time.

It looks like twitch.

1 Like

In /etc/default/grub I see the following lines


which means there is no delay at all.
This must be some kind of default configuration by Lubuntu team, but 0 seconds doesn’t make much sense.

Also the grub menu would be hidden with this configuration, even if a delay > 0 seconds is configured. But pressing shift key would show it, OK.

1 Like

I can’t remember what change I made (I tend to grab a box that has a ~clean QA-test install on & just do what I’d do and reply from that).

My box now has


for those two lines, so I’ll assume I added the “#” on the first line & made it a comment (ie. it’ll be ignored), and added a “1” in front of the 0 as it was easy & 10 secs felt reasonable to me.

I’ve assumed you’re asking me for confirmation; what I’ve just described is what I did to confirm my reply on a box that thankfully was handy & suitable for the role. I rebooted to test & grub happily showed for me as expected.

If the system is detected as a dual-boot; then it does show & a reasonable delay is selected (I can’t recall what it is sorry & I’m too tired to go & find it).

If however you were commenting in on what we (Lubuntu) do for a single-OS install; yes personally I’d prefer to see grub & would like a few seconds of delay; but I’m also aware that would really annoy a lot a Lubuntu users who’d prefer what we do currently (ie. fastest boot possible without extra delays). For people like me I don’t mind that I have to change it; however this issue may impact me more (and I worry it’ll impact & annoy some users, but for now it’s a watch & see).

1 Like

I switched to the former kernel version

uname -a
Linux MYCOMPUTER 5.13.0-22-generic #22-Ubuntu SMP Fri Nov 5 13:21:36 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

No artifacts so far.
What can it be? When was the latest kernel updated (Linux MYCOMPUTER 5.15.0-17-generic #17-Ubuntu SMP Thu Jan 13 16:27:23 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux)?

It says Thu Jan 13 16:27:23 UTC, my problems started Jan 19, when I started this thread. There are about 5 to 6 days inbetween, is the kernel version the problem or something updated on Jan 18.


I’d file a bug report as David or @KGIII already suggested & provide what you’ve said here (maybe even a link to this thread where you’ve discussed it with others).

The other report yours reminded me of (in a prior post/comment I made) was likewise when a jammy user/tester upgraded to the 5.15 kernel.

Kernels of course mean upgrading the kernel modules, and the far more common name for kernel modules is drivers

I don’t get too bogged down with dates (if I can help it) but I’d provide whatever detail, as accurately as you can in bug reports.

You mention 19 Jan, though if you look here you’ll see the kernel was published 18 Jan, but even after it goes to the main archive you may have downloaded it after that time, or used a different (country etc) mirror which got it later…

(FYI: the 13 Jan date relates to the changelog entry, which of course will be source code before it’s built etc)


Do you happen to have picom enabled? Enabling compositing sometimes solves the strange window rendering issues.


picom doesn’t show up in htop. I can see an entry in Accessories menu, but when I click picom nothing happens as of my understanding.

When I select compton from Accessories menu, then window effects are rendered, but I don’t want that behavior. Neither picom nor compton are running in htop, so it can’t be related to those, assumingly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.