Lubuntu installer doesn´t detect W10 partition

Iḿ trying to install Lubuntu 22.04 (fresh install) alongside with W10 but Lubuntu installer doesn´t detect W10 partition.

My desktop computer specifications are:
-Desktop computer:
-Model: Acer extensa
-Intel core I5-4460 cpu 3.20 Ghz
-4 gb ram
-Hard disk: Ata 1 Tb (Seagate)
-Bios: Legacy (no UEFI)
-Partition: MBR

On this computer I have installed previously successfully in dual boot:
Lubuntu 18.04 + W10 with no problem.
Lubuntu 20.04 + W10 with no problem.

Now, Iḿ trying to update from Lubuntu 20.04 + W10 (dual boot) to Lubuntu 22.04 + W10 (dual boot).

I have done the same steps as previous installations (first I tried keeping the same partitions as I have with Lubuntu 20.04+W10 and It failed (no GRUB menu) so I have tried again erasing all disk and installing first W10 and the Lubuntu):
i) Disable secure boot on bios.
ii) Install W10. (erasing all disk) and getting three partitions:
Sda1: NTFS 50 Mb
Sda2: NTFS 150 GB (System C:)
Sda3: NTFS 521 Mb
and leaving a no located size of 781 GB where later I will create the Lubuntu partitions (swap, / boot, / and /Home).
iii) On W10 disable fast boot.
iv) Create (with Rufus) a Lubuntu live usb (parameters: MBR, Bios)
v) Shutdown W10.
vi) Boot with the Lubuntu live usb.
vii) Select Try or Install Lubuntu.
viii) When Iḿ at the partitions screen, I see that Lubuntu installer doesn´t detect W10 partition:

ix) In spite of viii) I set the partitions in the unlocated space:
I create a logical partition with four subpartitions:
Sda4: Swap 4GB
Sda5: ext2 1 GB \boot
Sda6: ext4 35 GB
Sda7: ext4 740,95 GB \Home

x) I let the installation go, but at the end when I shutdown the computer and reboot, there is no GRUB menu and I only get a Lubuntu boot menu:

and then the logging screen, but after that I can not boot on W10 only in Lubuntu.

I have tried some solutions:
a) Boot with Lubuntu live usb and install boot repair:
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair
sudo boot-repair
b) Boot with Lubuntu and change GRUB settings (root mode) in /etc/default/grub
My original GRUB settings:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

I have tried change GRUB_TIMEOUT=0 to “10” or
add GRUB_DISABLE_OS_PROBER=false BUT it is useless, I don´t get GRUB menu on boot or Lubuntu installer detect W10 neither.

Any help will be welcome.


I think if you update the grub file, you have to run the command update-grub, otherwise whatever changes you make there will not apply. You will need sudo for this command.

Given how you installed this on a PC, you should also be able to trigger grub during boot:

Menu will appear if you press and hold Shift during loading Grub, if you boot using BIOS. When your system boots using UEFI, press Esc.

My hunch is that the reason your Windows partition is not being recognized is exactly what you updated for in the grub config, os-prober. Not sure when that “patch” landed but that would be my guess. As far as the installer goes, I thought the live images had os-prober on by default… so I’m not entirely sure. It might be something with Calamares since it looks like it recognizes something. I’m assuming that’s the Lubuntu installation and not the Windows install?

1 Like

Start the Lubuntu start disc and have an internet connection.
Install gparted
sudo apt install gparted

Start Gparted and create partitions for Install Lubuntu using :
an EXT2 partition for /boot
another partition for Lubuntu / (root)

1 Like


Thank you to both.
I have erased all the disk and I have installed W10 again and created a Linux Mint live usb.
Then I have tried first with the Lubuntu live Usb and the installer hasn´t detected W10, second I have tried the Linux Mint live usb and the installer has detected W10, so I think that the problem is the Lubuntu installer.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.