Lubuntu in USB drive does not detect SSD


I am trying to install Lubuntu on a new Acer laptop from a USB drive. However, Lubuntu is unable to detect the SSD drive. In fact, in Gparted only the USB drive is displayed. I did this before and after installling a different operating system (Windows 10).

The Acer model is an Aspire A315-54.

Best regards,

Which release of Lubuntu? (if using the long-term-support release provide full detail, eg 18.04, 18.04.1, … 18.04.4 etc).

Did you ensure windows 10 has hibernate (inc. fast-boot which uses hibernate) disabled or turned-off?

Please check in the UEFI settings, that the disk is not in any RAID mode (maybe it is called “RST with Optane”.


Thanks for your replies. Sata mode is “Optane without RAID”. Fast boot is disabled, hibernate is disabled as well. This happened using Lubuntu 19.10. However, this seems to be an issue in common with other Linux OS’s, I tried a different Linux distro (Linux Mint) and the same thing happened.


Let’s try the soft method first:

  1. Boot the live system
  2. Open a terminal
  3. Execute sudo apt purge dmraid
  4. Check, if the disk is recognised: sudo parted --list

If this does not help (and I guess, it does not help), then go into the UEFI settings and try to change the SATA mode from “Optane without RAID” to something else like “AHCI”. (I am guessing the labels, because I do not have an Acer device)
Then boot into the live system and check, if the disk appears, but don’t install. If the disk appears, you should check, that Windows is still booting with the new setting.

1 Like


Many thanks, it worked. The problem was switching from Optane without Raid to AHCI, the option was not displaying in the BIOS. It turns out you have to press Ctrl+S in the Main tab for the option to appear.

Best regards


Thanks for sharing the solution. You have a special kind of “sophisticated” firmware, where you need to press several keys first, before you are allowed to change the settings of your own machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.