Lubuntu fails on dual-boot install with legacy bios boot loader (not EFI)

Hi, I’m trying to install Lubuntu on a large empty partition on my older windows 10 laptop that does not have an EFI bootloader. Everything goes great until the very end when it tries to install an EFI bootloader onto my non-EFI partition and errors.

Here is a screen shot of the error message:

Would appreciate any help! Thanks in advance.

adding screen shots- of partition screen

1 Like

I tried following the suggestions in this link:

and I created a /boot/efi partition of 302mb and an ext4 partition of the remaining 300gb to install on to. I got a different error message this time!

Here is a screen shot of the windows 10 disk partition screen-
I think what may have happened here is the computer is capable of UEFI booting but because of the Windows upgrade path (OEM was Win7 Home, fairly early on) think this has always been booting using a legacy BIOS bootloader. I’d rather not reinstall windows to switch to UEFI. But it seems it is EFI capable since the USB boot seems to boot into EFI mode, which then tries to install Lubuntu in UEFI mode and that doesn’t work.

Hi – still haven’t solved this but I did try rebooting forcing the BIOS into MBA only mode. Here is the output from sudo parted --list and efibootmgr -v.

xubuntu@xubuntu:~$ sudo parted --list 
Model: ATA WDC WD5000BEVT-3 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system  Flags
 1      1049kB  107MB  106MB   primary   ntfs         boot
 2      107MB   161GB  161GB   primary   ntfs
 3      161GB   479GB  318GB   extended               lba
 5      161GB   161GB  317MB   logical   fat32        lba
 6      161GB   479GB  318GB   logical   ext4
 4      479GB   500GB  20.9GB  primary   ntfs         diag


Model: Specific STORAGE DEVICE (scsi)
Disk /dev/sdb: 62.9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  62.9GB  62.9GB  primary  fat32        boot, lba


xubuntu@xubuntu:~$  sudo efibootmgr -v
EFI variables are not supported on this system.

On a separate note I was able to successfully install on an old macbook. Nearly everything is working great on that!

Lubuntu releases up to and including impish (what will be 21.10 on release) do not need a ESP or EFI System Partition, though some installs will require one, ie.

  • if your box is uEFI it’ll require one to boot
  • if your partition table is GPT you’ll may require one (this maybe firmware dependent, so I suspect some boxes won’t require it & will treat disk as legacy as the GPT layout still allows for legacy booting by design, but some boxes firmware prevent this from occurring)

My primary box does not have an ESP partition; it’s dual boot currently running impish and focal.

I upgrade installs on other boxes I regularly use that do not have ESP partitions at least weekly without issue.

Most install selections though will result in a creation of an ESP partition, including on boxes that predate uEFI/ESP by years; but if you use Manual Partitioning it’s not necessary; you’ll just get the warning like that mentioned in the askubuntu question I’ve written an answer to.

I don’t get boost.python errors like you’ve originally posted (but I’ve seen it before; I just can’t currently recall where or why). I wonder if you’re booting in uEFI mode thus the ESP is required leading to this issue (when I don’t have a ESP or EFI system partition my boxes are booted in BIOS/MBR/legacy mode or don’t have any EFI capability).

You’ll need windows & Lubuntu to be both installed in the same modes; so if windows is installed with ESP you’ll need one with Lubuntu as well I believe (or failure to boot will result). I’m no expert on windows 10 though, nor upgrades to windows 10 - which may have introduced complications.

Windows is choosing the partition table depending on the boot mode. If Windows is installed in UEFI mode, it uses GPT and if Windows is installed in BIOS mode it uses MBR.

Most Linux distributions do not have these limitations. But Ubuntu and every flavour, which use Ubiquity as installer, are creating an ESP (EFI System Partition). If you use Xubuntu to install the system, then you will have an ESP, even when it is technically not needed.

Lubuntu is using Calamares as an installer and creates an ESP only, if the system is installed in UEFI mode.

The output of parted --list shows, that you have an extended partition, which contains two logical partitions. The first logical partition has FAT as filesystem, but I doubt, that it is correctly setup as ESP. I do not expect, that an ESP in a logical partition is working properly.

So far some explanations. If you do not understand them, it is not a big problem. Your Windows is installed in BIOS mode and to obtain a dual boot, you have to install Lubuntu also in BIOS mode.

To do that, you need to boot your Lubuntu installation medium into BIOS mode (you can see it in the partitions screen on the upper left side => “BIOS” is correct, but “EFI” is wrong).

If your system is booted in the “BIOS” mode, you can then delete the two logical partitions (maybe you need to choose “Manual partitioning”, surely @guiverc can give you better details about the workflow). The free/unallocated disk space can then be used to correctly install Lubuntu.

I hope this helps to get you on the correct path for a successful installation. If not, please let us know.

And to prevent any other problems, please make sure, that you disable Fast Boot in Windows.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Not in my experience. I can’t recall when the change was made, but a full disk install on a MBR only box (2007 box that came with w/xp) results in an ESP being created on it (and has for a few cycles now).

My boxes with no ESP are old installs where I’ve upgraded the installed system; or re-installed using Manual Partitioning, or no-format of partitions (an Erase and install would result in ESP creation)

I don’t have a BIOS only box currently where I can look at what it’s got after a clean Lubuntu install; but I’d expect a normal install to pretty much match the aforementioned askubuntu post. The calamaresyour system may or may not boot’ warning started appearing I think about that time if I remember correctly.

Note: I’ll endeavor to return & correct these details if on next QA-test install anything differs on a Erase disk and install on a BIOS only box; but I’m pretty certain I won’t need to. It won’t be today.

@hansgilead if you have any questions, feel free to ask. I can’t currently re-read & provide more due to lack of time sorry.

1 Like

Thanks for all the help! I was able to get this working by modifying the bios settings of the computer to dis-allow booting in UEFI mode then rebooting using the Lubuntu USB drive installer & reinstalling.

My Samsung laptop from 2011 originally had Windows 7 installed on it in MBR mode. I subsequently upgraded to Windows 10 using the built-in Windows update mechanisms which never changed the boot-loader type from MBR.

But since this computer is EFI capable, when I booted from the USB drive with the Lubuntu Live Installer it booted in EFI mode, and so the installer attempted to install to my hard drive in EFI mode. This correctly failed and did not damage my MBR.

To force the USB Live to boot in legacy compatibility mode I had to disable UEFI in the BIOS settings, reboot from the USB drive, and reinstall.

It is now working! Thanks for the tips & guidance.

3 Likes

I gotta eat my words on a QA-test install of impish today…

Post install I see only a single partition of type ext4.

Either I’ve gotten confused with my facts – or we have different outcomes for different releases (software stacks). This fits with what was on the box when I wrote the last reply; but it’s not what I’ve seen I’m convinced most of this cycle

I don’t intend install a hirsute or focal to confirm though; I will if requested, but suggest it be done post-impish install which is my current focus

1 Like

Don’t worry. It is a good thing to double check. It is possible that I miss new “features” of Calamares.

You don’t need to install hirsute or focal for this test.

Thanks for your time.

4 Likes