Lubuntu desktop fail on 20.04, on a horrible raspberry PI 3B

I’ve google everything I can find , but on boot up I have to manually login and startx

ubuntu@ubuntu:~$ systemctl status sddm
● sddm.service - Simple Desktop Display Manager
Loaded: loaded (/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2020-06-04 19:06:43 UTC; 11min ago
Docs: man:sddm(1)
Process: 1492 ExecStartPre=/bin/sh -c [ “$(cat /etc/X11/default-display-manager 2>/dev/null)” = “/usr/bin/sddm” ] (code=exited, status=0/SUCCESS)
Main PID: 1495 (sddm)
Tasks: 2 (limit: 966)
CGroup: /system.slice/sddm.service
└─1495 /usr/bin/sddm

Jun 04 19:06:43 ubuntu systemd[1]: Starting Simple Desktop Display Manager…
Jun 04 19:06:43 ubuntu systemd[1]: Started Simple Desktop Display Manager.
Jun 04 19:06:43 ubuntu sddm[1495]: Initializing…
Jun 04 19:06:43 ubuntu sddm[1495]: Starting…
Jun 04 19:06:43 ubuntu sddm[1495]: Logind interface found

sorry about formatting </> doesn’t seem to be a code entry

Xorg.0.log shows

 [   135.773] (II) XINPUT: Adding extended input device "Logitech Wireless Keyboard PID:4023" (type: KEYBOARD, id 8)

[ 135.773] () Option “xkb_model” “pc105”
[ 135.773] (
) Option “xkb_layout” “us”
[ 2340.860] () Option “fd” “18”
[ 2340.895] (
) Option “fd” “21”
[ 2340.895] (II) event1 - Logitech Wireless Mouse: device removed
[ 2340.897] (**) Option “fd” “18”
[ 2340.897] (II) event0 - Logitech Wireless Keyboard PID:4023: device removed
[ 2340.939] (II) UnloadModule: “libinput”
[ 2340.939] (II) systemd-logind: not releasing fd for 13:64, still in use
[ 2340.939] (II) UnloadModule: “libinput”
[ 2340.939] (II) systemd-logind: releasing fd for 13:65
[ 2341.416] (II) UnloadModule: “libinput”
[ 2341.416] (II) systemd-logind: releasing fd for 13:64
[ 2341.832] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[ 2341.832] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[ 2341.832] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[ 2341.853] (II) Server terminated successfully (0). Closing log file.

has anyone got a clue as to why the display is not starting
I only want this thing as a test bed, so worst case I can put up with manually logging in and starting X.
But I prefer it to work, thanks

Sorry I have no experience on 20.04 on pi’s (nor have a pi 3/4), but how did you get to where you are?

I’d opt for desktopify to change the Ubuntu Server image into a desktop on a pi (

That project was only recently created online (by Martin Wimpress; Ubuntu-MATE head & Canonical Ubuntu Desktop staffer; for part 1) and it’s where I’d look for clues (if you don’t want to watch the video, just go the github & get the results or the code!)

If you used desktopify, then a bug report may be useful so it can be tested & corrected, but if you didn’t use it - that would be where I would look for clues/fix.

1 Like

Thanks for the reply
how I got there was to follow the ubuntu tutorial on how to install ubuntu on a RPi
If I install the MATE desktop , or the gnome desktop tey start from boot
GDM3 on a RPI is a no go, it uses to much of the resources,
type a line on the CLI and a minute later the text appears I’m only using the RPI as a test bed for some software I package.
The reason I followed the tutorial to the letter was , I only borrowed the RPI3B to check my software package, the power supply lent at the same time was only 200mA , and I found one of the contacts in the SD Card connector was bent, so very intermittant.
I replaced the SDcard connector on the board, a real pig to change, not advised !
but the new connector although working is not as pretty as the original one, so I ended up replacing the RPI3 with a RPI4 and changing the PSU
So where as I’d normally install ad lib, I followed the “words of ubuntu”
a pain to have to install the server , then install the desktop. I’ve been using linux since
before ubuntu existed, when the kernel series was at zero and you had to compile your own kernel.
I suspect there may be a bug with sddm on arm64, there have been lots of problems with it on Arch, which always uses the most up to date version , and ubuntu20.04 is very new as well.
I’ll read the blob and see if I’ve missed any thing.

abit more
I’ve tried the git link, downloaded the directory
he’s made a mistake with how to run it
he 's written
sudo ./desktopify -de ubuntu-mate
that wont work as its actually
sudo desktopify/desktopify -de ubuntu-mate
or for lubuntu
sudo desktopify/desktopify -de lubuntu
It loaded another couple of files, but rebooting afterwards just give the same result,
it boots in to CLI and the start the desktop its ALT F2 then startx
looks like sddm is broken on arm64, lightdm and gdm3 work OK, and as the desktop starts OK with “startx” that would suggest that Xorg is OK
oh what fun !

I have worked on Pi’s 3 and 4 and installed Lubuntu, in both cases Lubuntu Rocks!!!, I haven’t used that desktopify thing, I like to keep it simple, I just followed the instructions on the Ubuntu site and worked like a charm.

My installation uses GDM3 and no issues (by the way the Pi’s I own are Canakit) the only instance when I had a little bit of a video issue was when I got a non-Canakit Pi 4, the same SDCard works but the video after a little while flickers and then disconnects but, the Pi is still running, however, running Raspian makes the video problem disappear. In terms of performance, both are fast (Pi 3 and Pi 4) however the 4 is better since it has 4 GB RAM and the Pi 3 only has one.

I’m just sharing my experience with Lubuntu and the Pi, and I have to say I’m happy.

1 Like

Hi EriK
I found that GDM3 on mine slowed it down to an unusable state, ubuntu 20.04 server, 64 bit was loaded first, I’m finding the lxqt desktop is only availabe with the sddm display manager,
I’ve tried lightdm but that only puts up a gnome desktop.
I use ubuntu mate on my hardkernel odroids , C1+,C2 and XU4, and that use lightdm, but they are still running 18.04 .abosolutely rock stable
you didn’t say which version you are running 18,19 or 20., or 32 or 64 bit
I use linuxMint19.3 on both laptop and computer, with a cinnamon desktop, that would never run on a RPi, not enough grunt . the lxqt desktop is a similar layout which is useful.
I’ve installed on several SDcards unbuntuserver first then lubuntu-desktop next.
I get the same thing every time sddm fails to bring up the desktop
Is it something I’m doing wrong or is sddm broken

I’m running 20.04 64 Bit. and lubuntu-desktop

During the installation you have 2 choices, sddm and gdm3, I selected the latter.

Let me add this, the Pi 3 is running 19.10, gdm3, lubuntu-desktop and it’s sweet, I haven’t installed 20.04 on it just because it only has 1GB of RAM.

Hi Erik
Well I can confirm that 20.04 is very cruel to a RPI3B, for CLI use its fine , I can compile the package I want to test.
only two desktops are useable XFCE4 and LXQT, SDDM does not function, GDM3 is too greedy
lightdm with Mate is tolerable, I couldn’t get LXQT to work with lighttdm
I’ve isolated the desktop and disabled SDDM
so it just boots up to CLI, if I want the desktop , LXQT, just run startx.
I suspect the RPI4B with the higher amont of RAM will work OK
Thanks for the input Erik

1 Like

Hope you are still watching Erik
I updated the kernel on ubuntu20 on the rpi3B , really crippled it speed wise.
So I loaded on another SD Card 18.04 with the Mate desktop, really sluggish
took a long time to compile the app and no matter waht I try all incoming ports are closed
even with ufw removed .
You say your RPI3 flys with lubuntu 19
where did you down load that from ? I’d like to give it a try.
I have to compile my program on 18 or 19 as glibc is a later version on 20 ,
so it will be one version for RPI4 with lubuntu 20 and another with eith 18 or 19 for RPI3

Hi Richard,

The Ubuntu Server 19.10 image for the RPI3 can be found HERE

If I have some free time, I’ll install Lubuntu 20.04 on my RPI3 and see what happens, I will let you know.

If I may ask; why don’t you stick with raspbian?
Are there functions that raspbian does not offer?

Your building a big motor into a small sized car!

very simple Raspbian or as it is now Rapberry PI OS is BROKEN
it is like Monty Pythons Parrot, It should be consigned to the scap heap.All because of a stupid out dated policy that no propietary software can be included.
Like the driver for the Broadcom GPU
Go and read the Debian Handbook
I had hoped that with the change of name of the OS they would see sence. BUT NO
The dinosaurs were stuck in their ways, so no more dinosaurs

Then why don’t you consider to buy a secondhad mini computer like this one?
You’ll have full power and your RPI will not be overloaded anymore.

very simple
I compile the binaries for linux for those who are unable or unwilling to complie there own
of a piece of software used by Radio Amateurs.
I do use proper computers for what I do and as far as I’m concermed SBCs should be used
for mundane control purposes, not to replace a desktop.
So the only reason I’ve done anything with a RPI is to help others

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.