Lubuntu 23.10 (Mantic Minotaur) - External disks (NTFS) not mounted

I posted the problem in July / August 2023 with the daily build version


To rule out that it was related to the development version of Lubuntu 23.10 I switched back to Lubuntu 23.04 and had no problems with external hard disk (mounted automatically and accessible in PCManFM-Qt), was waiting until yesterday to install the final official Lubuntu 23.10.

But with the final official Lubuntu 23.10 the problem is still there, so can’t be anything related to the development version of 23.10.
The problem exists also from USB stick.

To rule out that it was Lubuntu 23.10 related, I tried Xubuntu 23.10 from USB stick, but same problem.

How to deal with it? Must be something changed from 23.04 to 23.10.

I switched back again to Lubuntu 23.04 just to be able to use my external hard disk.
I have data on my external hard disk, so can’t simply format it to something else different from NTFS.


Interesting, for the last week or so I’ve had problems in my openSUSE systems where adding an external usb drive would cause grub to be “disordered” in the multi-boot listing of the 7 linux systems . . . .

didn’t exactly figure out the “why” of it, but it might relate to something in 6.5 kernels?? I’m not in my Mantic install right now, so I can’t check it . . . other problem I seem to have in Mantic is when I’m booted, the forum doesn’t seem to show up . . . . I’m in Leap 15.6 and the forum is working to type this out.

Probably you have hit something to file a bug report about . . . basic function issues, etc.

You could download the ISO of 23.10 and create a bootable USB stick, then launch 23.10 from USB stick, so you can see how your external hard disk behave.

In PCManFM-Qt my external NTFS hard disk is listed as device, but when I click on it I get the error message dialog.

The problem is there, it doesn’t matter if 23.10 is launched and used from bootable USB stick or from regular installation on internal hard disk (SSD).

Booting does involve grub handling . . . as mentioned there have been some grub issues in the openSUSE realm . . . don’t know if those issues would bleed over to the ubuntu realm. But, something about plugging in an ext drive seemed to disorder “sdX” locations and boot some systems to ER mode, etc.

Can somebody point out where at Launchpad I should file this problem? Please a link.

This seems do be across different Linux distros the case, not related only to Lubuntu, recently I tried Fedora LXQt 39 from USB stick too, same problem.

It works with older versions, like Lubuntu or Xubuntu 23.04, but changing to newer version 23.10, which probably involves a new kernel, it becomes a problem.

1 Like

Are you able to mount manually ?
mkdir tempdir
sudo mount /dev/sdXY tempdir
ls tempdir
mount | grep tempdir

I tried your recommendation, executed commands

sudo mkdir /mnt/myexternaldisk
sudo mount /dev/sda1 /mnt/myexternaldisk
ls /mnt/myexternaldisk

and the context of the external hard disk was listed, I could navigate the external hard disk and open documents.
So manual mount works.

Your last command mount | grep tempdir I didn’t try, up to this the external hard disk is already mounted, so what for is this command?

Do I have to do that kind of mounting every time I boot Lubuntu?

Still the question remains, why it isn’t mounted automatically as it was with versions before 23.10?

I need to see the output of that last command to see the type of mount listed. I have a theory as to what happened but I can’t verify it.

1 Like

When I execute the command

mount | grep myexternaldisk

the output is

/dev/sda1 on /mnt/myexternaldisk type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

My theory is that your ntfs drive has a dirty volume.

There is still a hole in my theory in that the timing of your symptoms looks off by one version.
I would expect your problem at the start of 23.04.
Anyway, here goes…

When you do a manual mount (like in a terminal shell),
it uses the mount command directly and defaults to type ntfs-3g (fuseblk).
sudo mount /dev/sdb1 /mnt/sdb1

pcmanfm-qt however, goes through a helper i.e udisks2, which has it’s own defaults. It looks for ntfs3 first (before ntfs/ntfs-3g).
ntfs3 won’t mount if it detects the volume as ‘dirty’.

It could be that your ext ntfs drive has the dirty-bit set
because it was not unmounted properly.

If indeed you do have a dirty volume, here are some options;

A) Try to remove the dirty-bit
ntfsfix -d /dev/sdXY
which attempts to turn off the dirty-bit but is not guaranteed.
(disclaimer - use at your own risk!).
Use Windows CHKDSK (which really checks it)
chkdsk /f /r <drive>:


B) Tell udisks2 to ‘only’ use ntfs (which is nowadays linked to ntfs-3g) instead of ntfs3.
Create this file;


and reload udev;
sudo udevadm control -R

If this works for you, I can provide an explanation in another post.


I decided to try B) and it works, thanks!

If I can plug it into a Windows system somtime I might check the CHKDSK option.

There were no problems with 23.04., it started when I tried the daily build of 23.10. a few months ago, when it was still in development. Therefore had to switch back to 23.04., as I described.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.