Lubuntu 22.04.3 LTS does not work after install

Hi, i’m trying to install Lubuntu 22.04.3 LTS on my main system.

i’ve made a bootable flash drive with rufus for lubuntu-22.04.3-desktop-amd64.iso. trying to boot from it and selecting the first option listed at the grub menu gives a never ending black screen, however, it does boot to desktop if i select safe graphics mode instead.

it’s from here that i proceed to install to an internal drive using the graphical tool, completing the process with no issue. now if i try to boot from the drive and select the first option, i’m greeted with the same issue: black screen and nothing else. to make it worse, the installed lubuntu menu doesn’t have a safe graphics mode option, so i’m stuck with a non-functional lubuntu, and no clear way to fix it.

my system specifications:

  • Ryzen 7 5700X
  • NVIDIA RTX 3060 (LHR)

since it will be likely be asked:

  • i have verified the integrity of the iso image i downloaded
  • i have used a known-good flash drive
  • i’m not interested in making a persistent usb image

thanks in advance

The safe graphics option at install adds a nomodeset to the linux kernel line, which makes the kernel use a very safe (low resolution) graphics mode.

You can add that parameter to any boot; just hit and edit the boot line of your installed system, it’s even touched in in the manual

To add a boot option press the e key and then type the boot parameter you want to add to the end of the line. The nomodeset option will try to load things for graphic compatibility if for example you get a black screen without proprietary drivers.

Your alternative (and what I’d likely confirm anyway; to ensure your system is working correctly as I suspect it is, alas without graphics drivers (kernel module) useful for your graphics hardware) is to switch to text terminal, login and explore the system using the command line, eg. I’d use CtrlAltF4 to switch to that terminal, login & check out the system… then reboot & try adding the nomodeset.

The next step (and this can be done equally well at terminal, or with a low-graphics/nomodeset gui login) is to try adding extra drivers, also found in the manual as follows

(including minor reference in page I provided earlier). If drivers are found that will help your hardware, they’ll be installed, so you can reboot & try them out.

To provide further help, we’ll probably need more details about your GPU or video hardware, myself I like the following command (sudo lshw -C display) as I find it’s easy to remember; list.hardware of class display; and you’ll find it works if you use video or another series of words too. Once you’ve found what hardware you are working with, you’ll find search engines can provide help pretty easily (and it doesn’t need to be Lubuntu specific here, Lubuntu is still a Ubuntu system so GraphicsTroubleshootingProcedure - Community Help Wiki etc apply), but I’m really hoping the ubuntu-drivers autoinstall command (or GUI tool as per manual) will fix your issue.


running the “ubuntu-drivers autoinstall” command from another tty instance fixed the issue and makes lubuntu boot without changed flags, however, i would like to be able to boot first into the desktop before having to rely on the proprietary drivers or this whole process.

the forum prevents me from uploading to you all the screenshots (“An error occurred: Sorry, new users can only put one embedded media item in a post.”), so i will put them on a separate cloud drive and reference each by their number:

if i try to boot removing the “quiet splash” options, it hangs on this screen, also hanging the whole system, preventing me to switch to any other tty: (image 1)

however, if i remove “quiet splash” and put “nomodeset” in their place, it continues for a bit more but eventually gets stuck on another screen, but i can switch to other tty: (image 2)

i ran the command you suggested and here is the output: (image 3)

also i want to point out that, despite the graphical installer working without issue, after shutting down the live environment, it hangs on this screen, having to manually reboot the system. it might be unrelated to my issue, i don’t know: (image 4)

is there something i can do to boot without nvidia proprietary graphics?
thank you for your help

The quiet doesn’t alter boot, except to prevent kernel messages from appearing. These messages often scare newbies; windows hides them by default, with splash referring to the plymouth splash screen that is used to show something during what is usually system boot messages. Doing this often provides clues as to problems; though most problems occur after the final message, but knowing what succeeded often provides clues.

Providing that output via paste (as text) is far easier to read.

You have a Nvidia GeForce RTX 3060 that is unclaimed; with the unclaimed being the reason for problems. That detail is what you can search online; I wonder are you using secure-boot & you enrolled your MOK keys? (if you haven’t, it’ll work when secure-boot is disabled, or after you enroll key mostly); as updated key(s) have rolled out in the last twelve months.

This isn’t a problem; the I/O errors are there no doubt as you removed the thumb-drive as you were instructed on screen; normally up to four messages appear then the machine reboots, meaning almost no-one notices the message(s) & its not a problem. If you don’t want to see any; you can delay pulling out the thumb-drive until after you’ve pressed ENTER and before you system starts booting, but I’d ignore these. On some hardware (which I suspect you have) the live system will hang during reboot & thus messages just scroll for awhile, even endlessly. At worst, what you’re seeing maybe a minuscule chance you may experience the same issue post-install with reboot/shutdown, but that’s only ~1% of the very few machines that hung during reboot of the live system (in my experience).

This is the real issue… (I’ve replied out of order I know…) If ubuntu-drivers autoinstall is run on a live system it won’t survive reboot; however on an installed system it should!

Are you using secure-boot? Have you updated your MOK key when instructed? If this is the issue, disabling secure-boot for a test should resolve the problem, with it only re-appearing when secure-boot is re-enabled as the MOK key will needed to be updated for it to work there, but this is guess & could be off the mark.

yes, i removed the quiet and splash options precisely so any error message could be seen, regardless of having those two options or not, the system hangs out of the box. but i don’t have a clue with what’s failing so that’s why i posted the output in case someone else has idea.

i’m not running any kind of secure boot, as i have it disabled, nor i intend to enable it. what i don’t really get is why the live system works with safe graphics but the installed one does not using the same option as well.

I suspect that’s not the case; can you please confirm that the system is functional, ie. by switching to text terminal using CtrlAltF4 and logging in for example, where I’d expect you can login normally & explore. My guess is only the GUI is not functional due to kernel module (aka driver) issue with your video card, not the system itself.

I don’t know your card; and (at least for now) don’t know what could fix it. My thoughts are

  • change drivers; eg. Nvidia driver install on Ubuntu 22.04.3 TLS - Unix & Linux Stack Exchange but whilst many like those 3rd party drivers, they’ll get in the way when you get to release-upgrade time… so I don’t like this solution, and don’t know if it’ll help you
  • a safer choice is always changing kernel stack; 22.04.3 installs using the HWE kernel stack (currently 6.2 kernel; 6.5 in January); switching to GA (5.15) may help, alas not knowing your card I don’t know if this is helpful, but its fully supported by Ubuntu, and won’t leave issues you’ll trip on in the future like first option
  • normally I suggest booting live systems to try different kernels, alas the 22.04.3 live system using 6.2 worked, so I’m missing something here (maybe its just updates since media was released near 4+ months ago, but I don’t know), and sorry I don’t know what it is
  • another option is try the newer 6.5 kernel (I mentioned earlier; expected to appear in upgrades next month!), but again I have no idea if it’ll be any better; but maybe worth trying.
linux-image-generic-hwe-22.04 | | jammy-security  | amd64, arm64, armhf, ppc64el, s390x
linux-image-generic-hwe-22.04-edge |  | jammy-security  | amd64, arm64, armhf, ppc64el, s390x

Please note: I’ve just provided my thoughts; I’m not recommending any; as I don’t know your video card & thus have no clues as to what is the best approach.

when i said on my previous post “also hanging the whole system, preventing me to switch to any other tty”, i was referring to switching to a text terminal using the ctrl + alt + F4/F5/F6 combination. the system is not responsive after trying each key combination, even after waiting a long time, so that’s why i concluded that the system does hangs out of the box. only i could switch to a different tty with “nomodeset”, but that’s not out of the box configuration, as i had to manually configure that. i also think it’s crashing entirely because of a kernel video driver, which fails to do proper error handling, instead, crapping your whole system. do you happen to know if the default driver loaded is nouveau?

as to your proposed solutions, do you know where can i find instructions to switch to the 5.15 and 6.5 kernels? the GRUB menu only has options for kernel version 6.2. i’m not experienced so i don’t know what’s the standard procedure to change the kernel version in lubuntu or in linux in general.

thank you

Sorry, I probably missed that. My usual test for a locked system is whether or not I get responses from the kernel to commands (ie. SysRq commands), but yes text terminal can give a clue unless it’s the GPU that’s locked up, I can often detect box itself responding to SysRq commands…

linux-image-generic-hwe-22.04      |  | jammy-proposed  | amd64, arm64, armhf, ppc64el, s390x

For the 6.5 kernel, I provided that detail in my earlier post, ie.

where I provided some details from a CLI enquiry run on my own system, you can install that with

sudo apt install linux-image-generic-hwe-22.04-edge

You’ll need a functional system to do that though. It’s also in jammy-proposed, so you can install it by adding -proposed too, but I didn’t paste that detail in my prior paste, as I usually use that is an indicator of when a package is coming (when it appears there I know how close it is, I’m watching that hits, as when it his ISOs I’ll start QA of 22.04.4 more heavily as release is getting close).

If interested; the output I copy/paste from is from rmadison linux-image-generic-hwe-22.04-edge linux-image-generic-hwe-22.04; which tells me packages in other releases beyond just my own (as I’m on the development release, most support isn’t my own release).

For the 5.15 or GA kernel stack, the best documentation is Kernel/LTSEnablementStack - Ubuntu Wiki with switching from HWE (or OEM) to GA found in the bit starting “To downgrade from HWE/OEM to GA kernel:”. If you don’t have certain closed-source drivers installed, multiple stacks can co-exist on the machine; which is why the documentation says to test, and only remove the unwanted stack when you’re happy (ie. there is no requirement to remove the unwanted stack). Alas some nvidia & closed-source kernel modules/drivers can prevent multiple stacks co-existing on an install.

Do note Lubuntu and other flavor media copy the standard of Ubuntu Desktop 18.04 LTS, and not Ubuntu 20.04 LTS & later… ie. our 22.04 & 22.04.1 media had the GA kernel stack (5.15) installed by default; with 22.04.2 & later using and installing the HWE kernel stack (5.19 at 22.04.2, 6.2 at 22.04.3, & soon 6.5 at 22.04.4). You however reported the 22.04.3 live system worked; only having trouble with the installed version. Did the installed system boot that first time? ie. the issue wasn’t something you did post-install? (in my experience I’ve rarely had issues on that first install where no internet is used; thus no updates occur where the live media didn’t give issues).

i have tested various kernel versions and it seems that 5.15.0 and 5.19.0 work perfectly fine, while 6.2.0 and 6.5.0 can’t get to the desktop as they are provided. what i found is that the nouveau driver is loaded by default, and replacing it with the nvidia proprietary driver always fixes the issue regardless of kernel version. they must have changed something with their driver around after 6.0 kernel release, which is the culprit of all of these issues.

i’m good with this and i can call my problem as solved, since i can just install the 5.19.0 kernel (which has the properly working driver), or just use the 22.04.2 ISO, while i wait for 24.04 LTS to hopefully see the issue fixed there.

however, one question remains: on installed lubuntu, if i disable nouveau following the steps on this procedure, or boot using the nomodeset option, as i previously explained, the operating system no longer boots into the desktop, only text terminals work. shouldn’t xorg just boot with the generic, safe graphics drivers? am i missing any step that involves re-configuring xorg, or is something else going on?

Lubuntu 22.04 & 22.04.1 media installed the GA kernel stack, meaning you remain on the supported and patched 5.15 kernel for the life of the product.

The 5.19 kernel is EOL, thus has been unpatched for security flaws since Ubuntu 22.10 reached EOL , so using 5.19 would be unwise if you’re using your machine on-line. The GA kernel stack (5.15) is the far safer choice.

If you blacklist a kernel module (driver), then its unavailable to the OS if required, and thus you can get a black screen and no GUI/UI.

The nouveau kernel module is the safe generic driver for NVIDIA cards (NVIDIA help maintain it) & you disabled it; thus you can’t use the generic safe driver as you commanded that.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.