Lubuntu 22.04.3 and USB Wifi Adapter

Hello Lubuntu Community,

I have installed 22.04.3 LTS on an old notebook, and the installation went smooth. The notebook has no built-in Wifi, so I tried using an USB adapter, but I cannot configure the Wifi connection. I tried with two USB adapter: Netgear and TP-Link. After searching for a solution I checked the hardware with the following commands:

Netgear WNA3100M:

$ lsusb
Bus 007 Device 004: ID 0846:9021 NetGear, Inc. WNA3100M(v1) Wireless-N 300 [Realtek RTL8192CU]
$ ip link
5: wlx2cb05d5bf4c9: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 
    link/ether 2c:b0:5d:5b:f4:c9 brd ff:ff:ff:ff:ff:ff

TP-Link TL-WN725N:

$ lsusb
Bus 007 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
$ ip link
6: wlx503eaa8d5c24: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 50:3e:aa:8d:5c:24 brd ff:ff:ff:ff:ff:ff

Do I have to install something or activate the Wifi adapter in any way? Any help would be appreciated. Thanks!

Greets, Leonardo

I have little/no experience with realtek chipsets (what you have, ie. Realtek RTL8192CU and RTL8188EUS) so I’ll provide a link that maybe useful.

Lubuntu 22.04 LTS is a Ubuntu 22.04 system, with only different packages included by default, due to the different seed we maintain.

As I’ve not used your hardware, I’ve not explored the PPA this howto relies on, but links to the source code (so you can build it yourself) are also there.

Hello @guiverc,

thanks for your answer and for the link, I’ll give it a try. So although the USB adapter is being showed in “ip link” as a network adapter the driver is missing? I ask because I’m accustomed to the behavior of Windows, where a device without a driver is only shown in the device manager as unkown device.

Greets, Leonardo

Sorry, I didn’t read your post clear enough did I.

I’m not sure I got past the lsusb which only displays a string response from a query as to what is connected; and is thus of very limited value. I missed the ip link completely sorry.

Your issue is the state being DOWN.

You could try sudo ip link set wlx2cb05d5bf4c9 up and see if we get a response.

You may need to set an IP address etc up first though. (sudo ip address add 192.168.1.5/24 dev wlx2cb05d5bf4c9, sudo ip route .. etc too)

Of course none of this may help, but it’s the stuff I’d try first (anyway).

If you’re still stuck, you can hope for clues via looking for clues in the systemd journal.

sudo journalctl -b 0 -u NetworkManager

Alas I don’t know what you’ll find there if you needed to look there, but I’d hope you find something that may lead to a next step.

Again, sorry for missing your [rather obvious] ip link.

The solution was too easy and somewhat embarrassing for me. :grimacing:

After looking up the systemd journal as you proposed I saw some reference to ‘rfkill’ I tried the command to check the status of the Wifi devices. That’s when I realized that there is a built in Wifi card in this old notebook and that there is a Wifi switch to turn it on/off. And the switch was set to the OFF position… :roll_eyes:
After turning the switch ON the Wifi connection was not grayed out any more and I could connect to my home Wifi without problems.

So I couldn’t solve the problem with the USB Wifi adapter, but it turns out I don’t need it anyway. :smile:

Thanks for your help!

Greets, Leonardo

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.