Lubuntu 21.10 hangs on Shutdown/Restart

Gets to Reached target [reboot|shutdown] then just blinking cursor, long hold of power button needed. Any help chasing down this bug would be appreciated. Surface Pro 4 with below specs:
CPU: Intel Core i5-6300U @ 4x 3GHz [40.0°C]
GPU: Mesa Intel(R) HD Graphics 520 (SKL GT2)
RAM: 2514MiB / 3849MiB

I tried to hunt this down for other Debian/Ubuntu users who might have had a similar problem. I can’t say for sure what ultimately causes this since it looks like different people have tried different things with varying results… some not always resolving the issue.

Can you see if running/installing any pending updates fixes the issue?

You can see how to update your packages via Discover here:

I think the pop up update notifier will show you a different screen but it will do the same thing.

Also, if you’re able to capture a screenshot with what’s actually displayed on the screen, this might help pinpoint what’s causing this issue. Feel free to share that here or share a link to where you can host it (e.g. Imgur).

Looks like a problem seen pretty regularly on the linux-surface 15.5 kernel so for now will keep hunting on that forum. Didn’t see this using the same kernel on Arch/Manjaro, so appears to be some kind of bad interaction with Ubuntu flavors; there was a similar post on the mainstream kernel threads about a year ago.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.