Lubuntu 20.10 is EOL - 22 July 2021

Lubuntu 20.10 was released 22 October, 2020 with nine (9) months of supported life.

Lubuntu 20.10 reaches reached end-of-life on 22 July 2021, which is only two weeks away now! :frowning:

The first warnings of its nearing the end of that 9 months of life were provided last month so this is yet another reminder, that if you’re still using Lubuntu 20.10 - please plan for your release-upgrade in the coming days.

Lubuntu 20.10 will release-upgrade to Lubuntu 21.04 :heart_eyes: , with details found in our manual on the upgrade process.

If you need help, the usual links apply. :slight_smile:

4 Likes

You can find our official blog post here.

3 Likes

Thank you all for your hard work with Lubuntu and I can’t wait to upgrade, but I still have an issue with installation from 20.10 to 21.04. My 1st gen Macbook Air still gives me (after sudo apt update && sudo apt full-upgrade -y. sudo reboot and sudo do-release-upgrade commands) a note “Due to a bug in shim, LP: #1928434, upgrades are not currenly safe for your hardware. Once that bug is resolved, you will be able to upgrade to the next release of Ubuntu.” And then the process refuses to go forward. I thought that the bug was already resolved. Is this an end of the road for me?

I don’t know what the issue is, but I’ll provide my thoughts.

  • bug 1928434 has been marked as Fix Released for hirsute so that shouldn’t be a blocker for you.

  • you mention a number of commands, but I’d read the output from apt update & validate your mirror is up-to-date, if it looks good I’d likely switch to the main archive and repeat apt update; full-upgrade & do-release-upgrade again

  • you mention the ‘-y’ in your commands; that makes me a little nervous as it should only be used when you know what the output will be, I see so many users getting themselves into problems because they used it when they shouldn’t; but it shouldn’t be a problem here; but I wonder if it caused this problem before-hand.

  • I’d check you have no holds on packages (I suspect unlikely as you’d not get the error message you report unless the hold caused the fix to not be installed); ie. apt-mark showhold

  • Have you filed a bug? If you haven’t I’d likely do it and provide the ID here so I can have a look (I may see the bug when filed, but I may also miss it so posting here is worthwhile). The most interesting attachment will likely be VarLogDistupgradeMainlog.txt which you’ll be able to find on your system already; but filing a bug (with ubuntu-bug ubuntu-release-upgrader) provides an easy way for you to upload your issue for me & others to look at. It’ll require you to have a launchpad login so see our wiki page for more details if required.

It won’t be the end of the road for you I’m sure; you have a problem we both believe you shouldn’t have, we just have to find & deal with it.

3 Likes

Thank you for your well thought answer. I went for a new go yesterday evening.

First, I checked the archive. It was http://archive.ubuntu.com/ubuntu. I did’t change that. Then, I commanded ‘apt update’ and ‘full-upgrade’, without -y, and answered yes to questions that followed.

And …it worked. It downloaded all the hirsute packages and processed them. Packages were so plenty, that it was clear, that I hadn’t been able to reach those before. After loading and processing, the system rebooted, and after that, ‘do-release-upgrade’ gave me the information, that there was no new release available (any more). I was finally running hirsute.

So, thus my problem was solved. There was no need for more actions. I have no further explanation why it finally worked, expect 1. just dropping off ‘-y’ and 2. just trying after three days more. But the trick was done, so thank you, I’m now ready for 21.04 and 16.0.

3 Likes