Lubuntu 20.10 Disable screen blanking / sleep

I have two Intel NUC’s (1x BXNUC10i3FNK2 and 1x BOXNUC8i3BEK2), both with Lubuntu 20.10
Both have the issue they blank/sleep the screen after 10 minutes.

Disabled all power settings in Lxde preferences and in the screen saver I disabled screen blanking.
I even disabled the screensaver from auto-start.

I disabled suspend etc:
sudo systemctl mask

I disabled powersavings in the BIOS and installed the lastest BIOS
Still the screen is blanking.

Does anyone know how to fix this?

Lubuntu 20.10 doesn’t use LXDE, so changes made in LXDE won’t have any impact on a Lubuntu LXQt desktop.

LXDE hasn’t been used for our last five releases of Lubuntu, no LXDE programs are installed by default as they make no sense on a modern LXQt/Qt5 system

I’ll also provide the Lubuntu manual page on xscreensaver as 10 minutes is its default

@guiverc Thank you for the quick response, you are right, it’s LXQt not LXDE…

I already set the “blank after” to 0 and in settings → advanced disabled the “Fade to black when blanking”.
I already disabled XScreensaver from autostart under Preferences → LXQt Settings → Session Settings → Autostart
I disabled “Power Management” in LXQt Settings → Session Settings → Basic settings

1 Like

Ok, think I “fixed” it.
I re-enabled the autostart of XScreensaver again and after that the screen did not blank anymore.
(Could be an update as well, but looks like all is fixed now).

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.