Lubuntu 20.04(.01) - Linux Kernel update does not boot - 5.4.0-45 and 5.4.0-47

Recently there was a linux kernel update, 5.4.0-45.
With this kernel I cannot boot into Lubuntu, it halts with a intramfs> prompt.

Today there was a linux kernel update, 5.4.0-47.
The same issue.

I have to choose 5.4.0-42 to boot into Lubuntu.

I have a notebook HP 14-0200ng (Ryzen 3) and HP EX-900 M.2 SSD PCIe NVMe.

I was thinking to make a new installation of Lubuntu 20.04. Would that solve the problem?

Also I don’t know, if a new installation only provides the latest kernel, which currently doesn’t work, or if there are a few to choose from, for example also 5.4.0-42?
But at least I thought of trying to solve the issue with a new installation, but better to ask upfront.

It must be something similar to:

Today’s kernel update 5.4.0-47 came shortly after 5.4.0-45, it looks like it was ment to solve the issue with 5.4.0-45, but it doesn’t.

My Lubuntu version is (via lsb_release -a):
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

Thanks!

1 Like

Please open a terminal and execute

{ sudo apt update && sudo apt full-upgrade && sudo apt install linux-generic; } | pastebinit

and share the URL here.

1 Like

If I execute:
{ sudo apt update && sudo apt full-upgrade && sudo apt install linux-generic } | pastebinit

it shows me a prompt “>”, nothing happens.

If I leave out the “{” and “}”, I get the following URL:
https://paste.ubuntu.com/p/fCgq9FmtHZ/

The URL shows:
Reading package lists…
Building dependency tree…
Reading state information…
linux-generic is already the newest version (5.4.0.47.50).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I booted with 5.4.0-42, why does it show the latest 5.4.0.47.50?

Sorry, I am using another shell and did not test it with bash. Seems, that I forgot a ; (I have edited the post to correct it, for other people in the same situation).

linux-generic is a metapackage, which points always to the latest available kernel and kernel header.

It seems, that you have installed the kernel correctly, which is normally a good sign.

You can rebuild the initramfs with

sudo update-initramfs -u -k all

If there are no errors, reboot and try it again with the latest kernel.

If it does not boot, than we should check the log files:

journalctl -b -1 | pastebinit
sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.4.0-47-generic
update-initramfs: Generating /boot/initrd.img-5.4.0-45-generic
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic

No errors, will try to reboot.
After reboot with 5.4.0-47 same problem, it halted, some error messages were shown:

[0.593653] ACPI BIOS ERROR (bug): Could not resolve symbol [\_SB.PCI0.GPP2.BCM5, AE_NOT_FOUND (20190816/dswload2-162)

[0.593672] ACPI ERROR : AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)

[0.818787] pci 0000:00:00.2: AMD-Vi : Unable to read/write to IOMMU perf counter.

[1.136798] tmp_crb MSFT0101:00 : can't request region for resource [mem 0x9d1^@


journalctl -b -1 | pastebinit
https://paste.ubuntu.com/p/8KSX6FDzW9/

The log file is very long and it seems, that you were able to login and work as usual.

Only with 5.4.0-42, but not with 5.4.0-45 or 5.4.0-47.

Solved it by making an upgrade to Lubuntu 20.10
Boots fine with 5.8.0-18-generic

1 Like

Good. Please mark your answer as solution.

Don’t see an option to mark it as solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.