Lubuntu 19.10 LXQT cannot change keyboard layout, shortcuts not working

Hello everyone!
I struggle changing keyboard layout. I installed Lubuntu 19.10 with LXQT (downloaded here: https://lubuntu.me/ ), and after installing I added default kbindicator widget into panel.
I then added additional language (ru) inside Keyboard and mouse window preferences, then I chose win+space shortcut to change layout and pressed apply and closed window.

The problem is that I was not able to change layout with win+space keys. So I had (and still have) to click manually with cursor kbindicator to change layout. I opened Keyboard and mouse window again and discovered that shorctut option is not even saved in the select input! I tried selecting it and saving dozen of times, I even started Keyboard and mouse window manually with sudo from terminal (maybe rights problem?), no luck! Option is not saving.

I saw a small text at Keyboard and mouse window, below “select keys to change layout” button, something about “Your keyboard settings may be controlled by another software like ibus, fcitx etc, so they may be overriden, even if you change them here”.

I did not install additional software listed in provided info, but I started checking whether I have it installed by default. It happens I have fcitx installed in the system. I’m not sure whether I installed it myself when tweaking keyboard layout settings (I made custom changes to /usr/share/X11/xkb/keycodes and /usr/share/X11/xkb/symbols, so my ctrl will be alt, so I can have like mac os layout), but it’s there.

Also I’m not sure whether fcitx actually stops Keyboard and mouse window to save shortcut setting, because when I started fcitx manually via terminal, I learned that all of my keyboard tweaks was turned off till I stopped fcitx process.

The main problem, I cannot change keyboard layout via any shortcut in the system. I would prefer to use kbindicator, because with it all of my custom tweaks (ctrl -> alt) work, and not fcitx or similar software.

Maybe I can access some kind of file via vim in terminal and write shortcut there? Or even better, maybe I have some kind of command in terminal which I can save in “Global keyboard shortcuts” window and use it to switch keyboard layouts? It would be even better because needed shortcut (left ctrl + space) is not in the list in Keyboard and mouse window.

Thanks!

Thanks for reaching out to us.
I will be honest, this is not a feature that gets a great deal of testing from the development team. I think most of us use one keyboard and one layout. Your feedback is very helpful and appreciated.
I did some preliminary testing and I may have stumbled upon a bug that is preventing you from effectively using the shortcuts. What I found was that the shortcut was only updated when a layout was either added or removed. As a workaround I changed the shortcut and then added a layout I did not intend to use. When I hit apply the shortcut setting was retained and I could then remove the layout I didn’t need.
Two things that I have left to verify (and perhaps you would be willing to help with this) 1.) Verify all of this holds true on a fresh installation of Lubuntu 19.10 (I was using my laptop that has had modifications over time) 2.) Verify the same on a fresh installation of Debian to help verify whether it is a LXQt issue or Lubuntu issue.
In the meantime we will keep looking into this issue.

2 Likes

Thanks for the answer! I tested with new approach and it’s working! Adding/removing layout solves the problem. Thank you very much! I think this can be added somewhere for 19.10 LXQT readme notes, so users will be able to use shortcuts for 2 layouts.

I will try to check fresh installation bugs within virtual machine in several days.

Could you possibly tell me, is there way to add custom keyboard shortcut? I looked for “left ctrl + space” for mac os like configuration (I have ctrl right to the left of space), but I did not find it in list.

Maybe I can write manually config somewhere? Keys to change layout.

Again, thank you very much!