Lubuntu 18.04 -- sound

Have an Atomic Pi pre-loaded Lununtu 18.04.2 Bionic LTS. It outputs video/audio via HDMI socket. I feed this to a TV set via a HDMI port. Video works fine but no audio. I have tried several help articles and researched this issue – I think I an down to no audio drivers as the last try. apt-get did not load any when I tried that.It would be really nice of someone to help me…I know a few things about Linux. Also I loaded Mint but the mouse went buggy so I reverted to Lubuntu as it appears more stable.

thx, Gene

You mention thinking audio drivers, so list what’s being used

sudo lshw -C sound

which will list-hardware of class=sound , the driver= bit will tell you what driver is being used and hopefully you’re recognize if it matches your hardware.

I usually fix issues in pavucontrol (Pulse Audio Volume Control), so if a suitable driver is being used, I’d next look there looking first in the “Output Devices” tab to see which port sound is output to, I’d also look in Configuration too (what profile is being used; it’s not OFF & trying others maybe). If you see “Dummy Output” in pavucontrol you probably do have a problem needing fix first.

I have installed pavucontrol and it shows the volume bar (that is not grayed out). when I run lshw -c sound; I get: sudo: lshw: command not found…which seems odd to me. what now??

Gene

Sorry I thought Lubuntu 18.04 included lshw by default (it exists on mine & i don’t see evidence that I manually added it), but I’d sudo apt install lshw. There are other ways of displaying the info (lspci -v), but I’m used to lshw.

apt installed just fine…this is what I got:

atomicpi@linux:~$ sudo lshw -c sound
*-usb:2
description: Audio device
product: Mayfield Audio
vendor: XMOS
physical id: 4
bus info: usb@1:4
version: 6.f4
capabilities: usb-2.00 audio-control
configuration: driver=snd-usb-audio speed=480Mbit/s

I can post the OUTPUT DEVICES if that would help.

A quick search using startpage “no sound snd-usb-audio ubuntu” found (the top two entries)

https://help.ubuntu.com/community/UbuntuStudio/UsbAudioDevices

The first contains reasons on why problems can be encountered with usb audio (last edit 2014; so is rather old so unsure if it’s the same today as pulse audio is dominant today; but it maybe useful). The askubuntu entry involves a problem where more than a single device is discovered, which I don’t think applies to you as lshw didn’t display two; but maybe worth checking. There were other blogs, but I tend to stick to official sources.

I suspect your issue is still the output, and the machine trying to put audio out through an audio jack it believes is there, and suspect the issue could be fixed within pavucontrol with the right configuration but I could be wrong.

I currently don’t have capacity (time etc) to read/look further, but hopefully this little is something will help.

Well, this has got me…I will email support at DI Loggers (that sold the AtomicPi)…I cannot believe this is so compliated…I might have to go back to Windows 10!!! yuk!!!

Gene

have you look at the audio config UI? Las tab let’s you decide which output to use.

Is the output muted?