Lubuntu 18.04.5 Bionic Beaver LTS (LXDE) on Intel Atom 32 bit ACPI-related issues

DISCLAIMER: I have searched about this issue both on the web proper and here. To no avail.

  • Hi, I have lubuntu 18.04. LTS installed and upgraded on my notebook system with: -Intel Atom N455 1.66 Ghz -2 GB RAm -250 GB HDD
  • First install - fail - apci (acpi?) error.
  • Suggested to do f6 np acpi choice.
  • Choice done.
    -Updates (sudo) done precisely as the OS suggested me to.
  • NO TWEAKS, MEDDLING.

The device was: Not able shut down. I woud boot up beautifully. But always got stuck at shut down & required to long-ress. YES I tried “poweroff” command. NO I dont have ANY hibernate&sleep function on.
As much as I gather, this acpi thing is related to power settings, and was basically a half-as*ed effort by Windows and its design is already flawed.

When I try to reinstall lubuntu from a fresh rewritten usb, I get this error written perhaps 20 times on the screen:

ACPI ERROR: AE_NOT_FOUND. While resolving a named reference package element - LNKD (20190816/dspginit-440)

in addition 10 others only with variations on LNKA, LNKB, LNKC,LNKF,LNKG.

Last error says AE_ALREADY_EXISTS
I have been suggested to:

Update Bios ( I never did it, have no idea how it’s done why it’S done where its done)
New Install (Tried multiple times.)

Now I was able to upgrade my w7 which I wasnt using for ages to windows 10 it works and I hate windows with all my guts. Bloated & user-enemy etc etc telemetry ( you know this better than me)

To all the people who love lubuntu. I loved this distro, It gave me the smoothest exprience on my dino netbook, which I do not wish to throwaway, I am forcing myself to become a more ethical user. If it works, I wont consume. I dont liike consuming, I believe big tech are on purpose trying to force legacy machine users to abandon their working devices.

Please, anyone reading this, I searched everywhere, I have been suggested to BIOS update. Is this the correct way to go?
Do I need tweaks?
Ive read eveywhere people being able to run linux on atom netbooks.

I loved your distro because of its stability, ( IVe treid antix, solus, trisquel(my future plan with open hardware) I would like to use lubuntu for my main driver on my fast pc too. But i need to solve this netbook issue. PLease help me what do I need to do?

An aside question : I also gather that problems arises a lot during writing the insallation media on the drive. I did the instructions as ubuntu says it ( as also lubuntu.me advises and redirects) But is there any way, any special program, speficially for ubuntu that would guarantee the optimum writing of the iso? Thank you.

Have you tried turning ACPI off? During the boot process, it shows a language screen. At that time, you can press F6. (I’m pretty sure it’s F6. It’s “Advanced”) and you can select a few boot parameters - like ACPI=OFF. You can try that.

Personally, I prefer to verify the downloaded .iso and then write it to USB with an application called “Balena Etcher.” There are many alternatives, but I prefer Etcher these days.

Try those things and report back. Someone smarter than I will be along shortly!

I’ll answer this part first. Ubuntu and many of the flavors (Lubuntu included) have “Startup Disk Creator” included. It doesn’t guarantee that the image will be perfectly written but it is a nice simple program that does one thing and does it well. The only way to ensure everything went well is to check that the hashes match.

Next, you have a system with an Atom N455 in it. I have a similar system and I use it often for testing Lubuntu. It is no power house system but it does ok. I haven’t encountered the issues you describe. I noticed that you downloaded the 32 bit version. That processor is 64 bit so you should be ok with the amd64 download. I actually used mine to test one of the development images a couple of days ago and that only has a 64bit version.

One final note, 18.04 is only supported for Lubuntu until April. After that time there will be no more 32bit and no more support for lxde. That is another reason why I encourage you to test the 64 bit version, it will have a longer lifespan.

2 Likes

Could you please explain what ACPI is?

Why should the user turn ACPI off, when you see errors like AE_ALREADY_EXISTS and AE_NOT_FOUND?

@Auerbach
How long did you wait when shutting down?
Please post, what hardware you are using. What model, what GPU? Are you using proprietary drivers?

And post also:

cat /proc/cmdline >> ~/lubuntu.txt
journalctl -b -p err >> ~/lubuntu.txt 

and post the content of ~/lubuntu.txt.

The best chances to fix ACPI errors you have with updating the firmware (BIOS or UEFI). The way how to do it, is vendor specific. But with a working Windows, it should not be a big problem.

And no, the firmware is not developed by Microsoft, so blaming Windows usually shows more about the competence of the user.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.