Lubuntu 18.04.03 i386 not booting on Mac Mini mid 2007

I have installed last Balena Etcher and did a USB flash install of Lubuntu lubuntu-18.04.3-desktop-i386. I also did a Debian 10 that boots normally through the same process. Why Debian works where Lubuntu don’t?

These are the screens I got. The first one don’t come when Debian is attached, it boots directly.
IMG_7039
So I order it to boot from USB flash drive…
…second image not allowed. It says…
Starting legacy loader
Using load options ‘USB’
The firmware refused to boot from the selected volume. Note that external
hard drives are not well-supported by Apple’s firmware for legacy OS booting.

  • Hit any key to continue *
    …and than hangs!

My mac mini is a mid 2007 1.83GHz with 4GB or RAM. I have two partitions: Mac OS X Lion and Windows 7 - both unsupported systems. Though will keep Windows, maybe try upgrade to 10 and install some Linux in the Mac partition.

Did you check the integrity of the image? If it’s broken in some way due to download or copy errors, it could very well be your problem.

1 Like

I’d agree with checking the ISO was downloaded correctly (https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0) and more importantly the write to your install media was flawless (https://help.ubuntu.com/community/Installation/CDIntegrityCheck)

It’s also covered in our manual

https://manual.lubuntu.me/stable/1/1.1/retrieving_the_image.html

though it uses the 20.04 image as it’s example, and no longer mentions the “Check Disc for Defects” option in text, as it was removed from the 20.04 media running automatically now, however the option I mean can still be see on https://manual.lubuntu.me/stable/1/1.3/installation.html (first image under Starting the installer). The disc being your install media, be it CD/DVD/hdd/ssd/thumb-drive/flash-card/etc

2 Likes

In this case, I would first check the hashes on the ISO itself. If that succeeds, I would personally use dd (or some other utility; not sure what to do with OS X or Windows) to do an equivalent hash check on the install media itself. Since it doesn’t seem to be booting, I don’t think they will be able to check the integrity like normal.

I have no useful information on OSX so cannot help sorry.

Etcher I see used by a main Ubuntu guide, they do a a Boot your Mac option so i’ll post that here hoping it’s useful…

2 Likes

I am now working on check the image I used to flash. But so far I tried a couple times, one using the same flash drive I used to boot Debian and no luck, the same screen. I am now downloading another version: lubuntu-16.04.2-desktop-i386, but I am hopeless, thought is some detail about the boot itself, not the Ubuntu version / flavor.

I think I have tried that tutorial, I am afraid it is for earlier Macs that are UEFI compliant. These old Mac Minis won’t see an USB bootable device in GPT table, only MBR.

But I have not drop the towel yet, thought will try to install Ubuntu somewhere else here to see what is inside those flash, what Debian got that Lubuntu got not…

I noticed that you are using rEFInd Boot manager - here is a link with some good info on how to use it - think this should help you out. Using rEFInd
Check out the section " Booting Legacy OSes".

1 Like

As far as I know, the i386 isos are not UEFI-ready.

Macs are so weird. I just looked up that Mac Mini mid-2007 and found some interesting info:

  • It was the 2nd generation of Mac Minis, the first with Intel processors. The previous generation had PPC G4s.
  • That generation also featured a server version marketed at schools and small businesses.

In any case, I would sort of caution against bothering with 32 bit because 18.04, which Lubuntu supports until April, is the last 32 bit option left for Lubuntu. I think Kubuntu will go a few years more in their 18.04, but not much more. At that point, you might as well just switch to something that will support it for the long term, like Debian, now.

However, looking at the 1.83GHz processor (Core 2 Duo T5600), it looks to me like it is 64 bit. So use the 64 bit image. That might solve your problem right there.

1 Like

Great news, this page was updated this year, it seems rEFInd is alive! Unfortunately, the page of installing Ubuntu in a Mac is outdated a lot. I will try to contact the guy, I though he needs a reward, there is a lot of stuff in his pages!

Indeed. This Mac is using hybrid partitioning to allow Windows - Mac dual boot, so I must proceed careful. As my first trial of installing Windows 7 didn’t work, I used a weird disc with all versions of Windows that uses it’s own weird boot loader… I will probably have to start over this Mac…

Anyway, my goal is to keep Windows 10 (if possible) and another Linux still supported. Lubuntu is not? Bad news… I might chose Debian or a new adventure: the upgrade to 64 bits or Mojave for 32bits. I knew a guy that claims to have switched the processor for one full 64bit. He now have true 4GB RAM, but he also had some issues with the horrible GPU Intel GMA 950. There is also a macOS Mojave made for 32bit Mac (or hackintosh) but the guy charges US$ 40 for the awesome. Though is a fair price, I just don’t have it right now.

Making old machines to work is something I like to do, makes me feel more “green”. Old Macs are interesting (not that cliché PC with standard motherboards) and well constructed - won’t just stop working after months of hard job and money!

But I am missing the point, I will try to contact the rEFInd guy and probably start over this Mac mini. Who knows if I can run a 64bit Linux version somehow…

It’s supported right now, but in April, the 18.04 will reach its End of Life. The next versions after 18.04 do not have 32 bit versions. There are 64 bit versions, though. This is why I suggested using 64 bit.

This is something true only with the Intel Core Solo processors which only happened on the 2006 models. But I’m sure looking at the specs you have a 64 bit processor.

That’s what I’m saying: your processor supports it. Use it!

Yes and no. I am in contact with the rEFInd keeper and the problem is Mac Minis of this generation have 32 bits EFI, so it’s not possible to boot a 64 bit system, got to boot through legacy BIOS and than maybe will work. I understand that all system must be 64 bits, not just the processor. I will try for sure, but every move take some time, I am now backing up all data and making some boot options, like Lubuntu 64, Debian 64 etc.

There are some, mainly cheap, systems with 64-bit hardware, but 32-bit firmware.

First the good news: It is possible to start a 64-bit system with 32-bit firmware.

The bad news: You have to replace grub-efi-amd64 with grub-efi-ia32. Searching for “ubuntu uefi 32-bit” should result in some tutorials on how to prepare the stick.

Newer Fedora releases have the grub-efi-ia32 support included. You might test it with Fedora first, if the problems are related to a 32-bit UEFI or if there are other traps.

2 Likes

As far I know, it is possible to start a 64-bit OS by legacy / BIOS mode, but thought USB the firmware have refused all attempts so far. I have the additional problem of not heaving an optical drive that should solve the issue by IDE connection. I tried even an adapter from IDE to SATA but don’t start any install CD, not even original Apple’s OS DVD.

On the other hand, this GRUB solution seems more interesting because will start trough EFI. Will be really possible jump from 32 to 64? Will give a chance looking around for this solution. It’s hard to find because this hybrid hardware is rare now, so there isn’t much people working on it.

I had a PC with Pentium 4 HT in this situation, I sold it with a nice AGP GPU, Windows 7 32-bit and Primo Cache to make use of 1GB left from 4GB of RAM installed. It was “working” but I always wanted to make a Linux machine… let’s see if I got better luck this time…