Lost Network widget from taskbar to some random right-click, how to get it back?

Hi,

Running Lubuntu 20.04 (latest patch level) inside a Virtualbox VM. I connect to network over Ethernet whenever I can, but sometimes over WLAN. As a result I keep facing Network issues when moving between networks, and I’ve some recovery procedure that doesn’t need restarting VM, which works pretty flawlessly. However, this morning when I was following that procedure, I noticed that my right-clicks were less responsive. There was delay between my mouse actions and appearance of it’s effect on the NetworkManager (or Lubuntu equivalent) widget in Taskbar from where I was trying to disable/enable networking, and due to some such mouse-click the entire widget disappeared. In such circumstance, how is one supposed to get the widget back in taskbar ?

PS> I might have got my terminology all mixed up as I work in equal measures in MSWindows and Linux. I might be referring to NetworkManager applet in systray. What I am referring to is however what if found on the bottom right corner of the default Lubuntu desktop

TIA.

The answer on this reddit link solved the problem for me.

Basically, one needs to:

$ nm-tray &
disown

I.e. start nm-tray in background from a terminal, and then type ‘disown’. Although I didn’t quite get what that ‘disown’ does, since the process is started in background, who does the ‘disown’ text in stdin go to ? Shell or nm-tray and for what ?

4 Likes

Well done for solving it.

From wikipedia disown

In the Unix shells ksh, bash, fish and zsh, the disown builtin command is used to remove jobs from the job table, or to mark jobs so that a SIGHUP signal is not sent to them if the parent shell receives it (e.g. if the user logs out).

or if you need specific details for your own system, the manual pages are always helpful.

1 Like

Silly me. Thanks for clarifying.
I had tried man disown but should’ve actually tried man bash instead.

2 Likes

I tried man disown too first :expressionless: … along with apropos disown and a few more :frowning: before I then realized it was likely an internal command (whereis confirmed) and eventually got to man bash (I just didn’t mention my misses! :slight_smile: )

2 Likes