LightDM-GTK+ removed. No cession login

Dear all.
I have an upgraded system from previously under 18.04. Quite dirty due to the change from LXDE to LXQT between those versions and without a fresh install (I only discover this point today !).
a) LightDM-GTK+ was still active with bug and message when relogging after screensaver was activated.
b) Also recently, I was not being able to relog as the system restart the loging windows again and again each time I enter my password.
c) Several software with different names to do the same job.

Due to a) & b), I searched and found recommendation given under lxqt [Wiki ubuntu-fr] . I understand the mess LWDE and LXQT and stried to follow the instructions: I removed light-locker xfce4-power-manager but also lightDM-GTK as as per my understanding it was not supposed to be used anymore, but I ensure that to add LXQT (surprisingly was not checked “installed” in Synaptic).

After installation completed (without warning as per my understanding), when I tried to restart the system remains on the nice blue screen of Lubuntu without a logging windows.

Now I’m stucked there, with only limited knowledge in Linux.

At this time, after ready several support and chat, I understand that
for b), maybe it’s coming from a lack a free space on my HD, not from the version of the greeter. This assumption would be supported by a warning on disc capacity when Thunderbird tried to “compact” the mails.

Any recommendation to recover a logging windows ?
Following the upgrade from 18.04, the performances went down (single core processor iwth 2Go RAM) probably due to the dirty upgrade. Thus my objective would be to back-up and re-installed everything clean !

Thanks in advance.

I’ve moved this to off-topic as you mention

  • Lubuntu 18.04 LTS to 20.04 LTS upgrade that is unsupported

  • you only mention unsupported releases of Lubuntu that I can see (Lubuntu 20.04 is EOL; see this post - Lubuntu 20.04 LTS is End of Life)

I upgraded many 18.04 to 20.04 systems, but even for me that was long ago I don’t recall all of what was done. On about 5 systems I had almost no issues, but on the systems that mattered to me the most I had great issues (issues varied on what you had installed, changes you’d made & more - why the team decided not to support the upgrade except via re-install). I’d have suggested following the documentation we created for that purpose, but I’m pretty sure that no longer exists (it was never officially published, but was written in hopes the upgrade would be supported; alas it was too problematic for the small team).

In our last Current Statuses post it clearly stated

After April 28th, 2023, the only supported releases of Lubuntu will be 22.04 (until April 2025), 22.10 (until July 2023), and 23.04 (until Jan. 2024). All other releases of Lubuntu will be considered unsupported, and will no longer receive any further updates (or support) from the Lubuntu team.

Ubuntu LTS can only upgrade to the next release; ie. 18.04 will go to 20.04; if you attempted to jump straight to 22.04 via upgrade (and not re-install) you also used an unsupported upgrade path, and I’d suggest a clean (or unclean) re-install of Lubuntu 22.04 LTS (ie. unclean being re-use existing partitions without format, after backing up your data first as per any install operation).

My primary PC was on that I’d performed release-upgrade from Lubuntu/LXDE to Lubuntu/LXQt (ie. the unsupported upgrade; mine being 18.04 to 18.10) but that machine died late last year, and I’m now on a newer box that was clean installed earlier this year.

My own system has both lightdm & xfce4-power-manager installed, but not light-locker. Having them installed isn’t a problem; your setup will control whether or not they’re used.

None of those would be expected on a clean install though (eg. I don’t see them on this manifest), but I’ll have them on my system as I don’t mind a bloated system & love the ability to login now & again with a different session (thus my install also has Xubuntu/Xfce installed, Ubuntu/GNOME too… with me deciding which I’ll use at login); thus the inclusion of Xubuntu packages on my system. FYI: I’m using my Lubuntu/LXQt session now as I am most of the time; but a change can be nice :slight_smile:.

If I look for lxqt you mention, I don’t see it installed

guiverc@d7050-next:~$   apt-cache policy lxqt
  Installed: (none)
  Candidate: 30ubuntu2
  Version table:
     30ubuntu2 500
        500 mantic/universe amd64 Packages

but my system was a Lubuntu install made with a lunar ISO (pre-release) and not an install that used the lxqt meta package; thus I’d not expect to have seen it anyway. (I sit in the development cycle; why lunar is now mantic)

Your system being a LXDE system upgraded, will be different to what I can now look at (since my old box is still sitting dead; in hopes I find a PSU that will fit it & I can put it back into operation for QA-test installs etc).

You created (via unsupported upgrade) a frakensystem that means you’ll get the best support I suspect, from those that also did the
same (and thus can see what’s on their systems). Most of my other unsupported upgrades were used in later QA-test (unclean) installs so those systems may no longer match yours anyway.

Check what DM you used; when you removed lightdm (if you removed it) you were asked what DM you were going to use, Lubuntu now uses sddm (what I’m using, and have been using since we switched back mid 2018) so I’m rather rusty with lightdm anyway. I cannot recall what changes were made in the (18.04) LXDE to LXQt (18.10/20.04) with regards default DM so I don’t know what exists on your system.

Long shot: at the blue screen, press ctrl+alt+F2 and it’ll drop you to a command prompt. login. then at the command line:
sudo apt-get upgrade

sudo apt-get update

sudo apt-get install lightdm light-locker slick-greeter

choose lightdm, not sddm when prompted (if prompted).

then reboot


@Gavinccc , unfortunately, it does not allow me to get the command prompt. It’s switching to the black screen with a blincking cursor on the top left position. Nothing react. Same with other F2 to F6… ctrl+alt+F1 allow me to be back to my nice blue screen.

So I started in recovery mode, enabling the network and then going to the root command prompt. (PS: recovery mode confirms that LTS 22.04.2 is installed).

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install lightdm light-locker slick-greeter (=> not prompted for a choice).

=> it works.

Thanks for the guidance. Solved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.