Keyboard layout change issue with 24.04 / MacBook Pro / Vmware fusion player 13

The LXQt keyboard layout selection is nonfunctional. The mouse/keyboard->keyboard layout settings shows proper selected keyboard layout Finnish/Finnish(Macintosh) keyboard type MacBook/MacBook Pro (intl.)
The bottom right panel keyboard widget shows US which is in effect (I.e. wrong).
Any changes done by the LXQt layout settings panel does not take effect and when closed and reopened, vanish.
pressing “use” in the settings panel result
[ 1908.448] (EE) Error loading keymap /var/lib/xkb/server-0.xkm
in the /var/log/Xorg.0.log
Fresh install of the new 24.04. open-vm-tools-deskop installed but behavior is the same, installed or not.

When X starts the logfiles has
7.366] () Option “config_info”
7.366] (II) XINPUT: Adding extended input device “Power Button” (type: KEYBOARD, id 6)
7.366] (
) Option “xkb_model” “macbook79”
7.366] () Option “xkb_layout” “fi”
7.366] (
) Option “xkb_variant” “mac”
7.381] (EE) Error loading keymap /var/lib/xkb/server-0.xkm
7.381] (EE) XKB: Failed to load keymap. Loading default keymap instead.

should have said fresh install of lubuntu 24.04 lite.

I’m really struggling to reproduce this.

Here’s some things to note:

  1. It’s possible to configure multiple keyboard layouts in lxqt-config-input.
  2. You can order these how you see fit, so that when switching between them, they go in a preferred order.
  3. Putting a particular layout first doesn’t mean you switch to that layout.
  4. The keyboard state indicator widget in lxqt-panel shows only one keyboard layout: the currently selected one.

I wonder if your issue requires VMWare and/or perhaps open-vm-tools-desktop is to blame.

1 Like

And another thing: what’s Lubuntu Lite?

Turns out that the issue is keyboard type MacBook/MacBook Pro (Intl.) does not work. Found this out when I switched to KDE neon, where Plasma showed errors on Finnish(Macintosh) variaton:

What errors?

Also, again, what is Lubuntu Lite?

With lubuntu lite I just meant the minimal install. Sorry, too many distros tried.

Indeed it seems hard to reproduce once everything works. I will redo the install later today (i’m in UTC+3).

Couldn’t copypaste the kde neon errors as the copypaste does not work in kde neon :person_facepalming:

1 Like

It looks like the issue in neon is the combination of

  • keybord device selected as Apple MacBook/MacBook Pro (Intl.)
  • layout Finnish
  • variation Finnish(Macintosh)

Testing that the KDE settings widget gives me this:

Warning: Unsupported high keycode 256 for name ignored
X11 cannot support keycodes above 255.
This warning only shows for the first high keycode.
Warning: Multiple definitions of the FOUR_LEVEL_KEYPAD key type
Earlier definition ignored
Error: No Symbols named “mac” in the include file “macintosh_vndr/fi”
Abandoning symbols file “(null)”

Debugged this more with the lxqt-config-input directly. I do not think VMWare is at play, as variations in the VMWare keyboard config all work perfectly.
It seems that the culprit is the keyboard model(s) macbook78 macbook79 and macintosh.
Here is how I reproduced
I had two terminals open and started with pc105 model and us layout.
On the 1. terminal I tracked X errors and typed what I did in between and 2. terminal lxqt-config-input .

  1. terminal:

mbplubuntu24:/var/log 09:18$ tail -0f /var/log/Xorg.0.log
added layout fi, no errors, keyboard switcher ok
switched model to MacBook/MacBook Pro (intl.), kb switcher works but shows ?? Layout Unknown Variation none as the English (US) !!
Switched fi layout as first and now kb switcher works but shows the Finnish (first again) as ??
[ 4723.168] (EE) Error loading keymap /var/lib/xkb/server-0.xkm
Added another fi keyboard with variant mac and moved it as first and deleted the fi without variant. Now X gave the error above and kb swither haa three keyboards, US FI and ??, i.e. it looks like the deletion of third failed
[ 5086.687] (EE) Error loading keymap /var/lib/xkb/server-0.xkm
Removed us layout and got the error above
the kb switcher still shows 3 different variaions
Closed the widget and restarted and it shows again the fi, us and fi&mac

  1. terminal:

mbplubuntu24:~ 09:18$ lxqt-config-input
add “us” “”
Detected “VMware VMware Virtual USB Mouse” on “/dev/input/event4”
xinput driver: “libinput”
Detected “VirtualPS/2 VMware VMMouse” on “/dev/input/event3”
xinput driver: “libinput”
Detected “VirtualPS/2 VMware VMMouse” on “/dev/input/event2”
xinput driver: “libinput”
add “fi” “”
“setxkbmap” (“-model”, “pc105”, “-layout”, “us,fi”, “-variant”, “,”)
“setxkbmap” (“-model”, “macbook79”, “-layout”, “us,fi”, “-variant”, “,”)
“setxkbmap” (“-model”, “macbook79”, “-layout”, “fi,us”, “-variant”, “,”)
add “fi” “mac”
“setxkbmap” (“-model”, “macbook79”, “-layout”, “fi,us,fi”, “-variant”, “,mac”)
“setxkbmap” (“-model”, “macbook79”, “-layout”, “fi,us”, “-variant”, “mac,”)
“setxkbmap” (“-model”, “macbook79”, “-layout”, “fi”, “-variant”, “mac”)
mbplubuntu24:~ 09:34$ lxqt-config-input
add “fi” “”
add “us” “”
add “fi” “mac”
Detected “VMware VMware Virtual USB Mouse” on “/dev/input/event4”
xinput driver: “libinput”
Detected “VirtualPS/2 VMware VMMouse” on “/dev/input/event3”
xinput driver: “libinput”
Detected “VirtualPS/2 VMware VMMouse” on “/dev/input/event2”
xinput driver: “libinput”
mbplubuntu24:~ 09:34$

Workaround is to use “apple” as keyboard model and not macintosh, nor macbook*

So looks like the issue lies within /usr/share/X11/xkb configuration files, either in rules/base or in symbols/macintosh_vndr/

There exists a somewhat related bug that offers some clues to workaround this, but I would urge you to file a bug against xkeyboard-config. Note: this is NOT a Lubuntu-specific one, but likely one that affects all of the Ubuntu ecosystem and likely Debian, too.

Thanks for pointing out the ubuntu bug report.
Looking at the xkeyboard-config package, the bug must have been there ages if not forever, meaning none of the mac* keyboard models have never worked. Kinda unbelievable.

As the last change to the package seems to be 10 years ago, filing a bug there is maybe useless.

I’ll try to figure out what is the culprit in the macintosh_vnd/ and will submit a patch if successful

Although the problem is invalid config files, I would urge lxq-config-input not to expect the config files to be perfect and issue proper error messages. Thus there should be bug filed also against that

Got slightly deeper with this. The key problem is that basically all apple* and mac* keyboard models are flawed and to my knowledge do not work with contemporary macs. The workaround is for macbooks set the keyboard model as Generic 105 key pc keyboard (pc105) and use the language layout variant as macintosh.