Kernel Panic on Lubuntu 20.04 usb boot / install on Dell Inspiron 1501

When booting an oldish Dell Inspiron 1501 (currently running Windows XP no problem) with Lubuntu 20.04 from a USB stick, the boot fails with a Kernel Panic error. The hardware passes checks, and I’ve tried various other versions (18.04 64 bit, 18.04 32bit, Puppy Linux) and they all panic.

Any ideas on how to diagnose/fix this? The existing hard disk is quite full (only 2GB free) but otherwise the hardware seems fine. It has an AMD Turion-64 processor and 1G memory.

What hardware checks have you done? In particular, have you checked your memory? Also what specific error did you get?

1 Like

Hi Walter,

Thanks for you reply. The Inspiron is running XP at the moment, and passes all the boot up checks. I’ll run the full Dell diagnostics and get back to you.

Here is a screen shot of the specific error

Your picture is really close to impossible to make anything out of because it’s so tiny, but a kernel panic is Not Good™.

Did you follow the manual’s instructions on how to check the validity of the ISO file? If the download was a bit off, or if the copy to the USB was a bit off, that could create this sort of situation. And yes, it could happen multiple times over.

Alternately, I would do an exhaustive memory check.

Hi Walter
Here’s the original JPEG of the crash.

I’m sorry about the quality - I’m trying to help a friend outdown the other end of the country so I am not next to the laptop.

So far I’ve tried

  • Brand new download of ISO onto new memory stick - same problem
  • Download of 32 bit ISO onto new memory stick - same problem
  • Run Dell diagnostics - passed
  • Run 3rd party memory checker (memtest) - passed.

I’ve asked my friend to burn a CD with the ISO and see if it boots from that.

Is there anything else that you can suggest?

best wishes


Verify that the ISO and the installation media are valid, as per the manual.

I’m curious: will a Windows ISO boot? If not, perhaps there’s a problem with the USB or the USB subsystem.

This isn’t going to be a 20.04 ISO - Lubuntu and Ubuntu at large don’t support 32bit ISOs anymore, so it’s not a valid test.

On your 20.04 system can you get to the GRUB bootloader and get a list of what exactly is booting in the kernel of your system? Press and hold Shift when you start your system (AFTER the Dell logo, but BEFORE you are actually in Lubuntu, go to either “Other Lubuntu Versions” or “Other Linux Versions”, and boot to an Lubuntu / Ubuntu that uses 5.4.0 as the kernel version. See if that gets you back into your machine for now.

If it does, then run sudo dpkg --get-selections | grep 'linux-image-' | grep '5.8.0' and include the output of this command here, so we can see what kernel versions are installed. If you’re on the 5.8.0 kernel (which it usually will now default you to for 20.04 installations because of the global enablement by default of the HWE kernel stack - basically backported kernels from later releases to *buntu 20.04), this is likely a regression caused by this kernel, and we’ll have to work through the process of filing a regression bug with the Ubuntu Kernel Team.


Sorry I meant I’d downloaded the earlier LTS version (18.04) and tried the 64bit and 32bit versions of that, and experienced the same problem.

Thank you very much for the suggestions - will give it a try.

best wishes


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.