Intel 865 GV Graphic Chipset

First time Lubuntu 18.04 install. Can’t get a screen resolution greater than 1024X768. Plz HELP!


Hi @hawghaven and welcome.

Can you please share the terminal output of xrandr and some infos about your hardware?

troy@ubuntu:~$ sudo xrandr
[sudo] password for troy: 
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

You can certainly go through the laborious process of adding a mode and then making sure it gets added every time you startup, but ultimately the likely cause of the issue is your device not sending the correct or complete EDID signals. It’s also possible the kernel driver is responsible. Knowing more about your card and driver might help. Try lspci -nnk | grep -A 2 VGA. And no, just like with xrandr, you don’t need to sudo it.

As I am new to LINUX, the first suggestion sounds exhausting to me.
I maintain 4 WINDOWS server, This LINUX thing is all new to me.

Here is the info you are looking for.
BTW, grep -A 2 VGA do’nt do anything… Just hangs.

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
	Subsystem: Dell 82865G Integrated Graphics Controller [1028:01d5]
	Kernel driver in use: i915
	Kernel modules: i915, intelfb

Hope this helps, and thanks for your time.

First thing you need to know about Linux, though this wouldn’t be too new if you’re familiar with PowerShell: pipes. You can send the output of one command into the other. The whole command I asked you to do is lspci -nnk | grep -A 2 VGA.. The | is a pipe. grep searches its input for a particular string. In this case, it’s VGA, and we’re asking for two lines of additional context after a line matches. grep by itself will just wait for input. No matter. I trimmed your spew down for you.

Regarding the issue itself, I’m thinking you are liking facing an old bug. You should probably file a new bug because it never seemed like that got resolved, either to confirm or deny its existence. The unfortunate fact about old hardware is that it tends to get less and less attention over time.

The workaround is indeed the exhausting suggestion I made, though it’s adequately described here. Basic steps:

  1. Use cvt to make a modeline based on your preferred resolution (1280x1024 here is an example):
    $ cvt 1280 1024 
    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz  Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
  2. Use that to make a new mode:
    $ xrandr --newmode "1280x1024_60.00"  109.00 
    1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsyn
  3. Add the mode to your display:
    $ xrandr --addmode VGA1 1280x1024_60.00 
  4. Finally use the mode:
    $ xrandr --output VGA1 --mode 1280x1024_60.00 
  5. Take all of the commands above except the first one and put them into $HOME/.xprofile and it should be automatic.

Also: don’t sudo unless you need to.

Thank you for your time, I will give this a shot.
About line 5. Is this going to be a config file? That I save to?

That is correct. $HOME is a reference to your home folder, which is also referred to by ~ and should be in /home/$(whoami) where $(whoami) is a reference to the output of the whoami command, which is your username. For me, I’ve got /home/wxl. Hope that makes sense.

I do not have a .XPROFILE only a .PROFILE

You don’t have either, actually. Remember, Linux is case sensitive. That said, create it.

No sir, Nothing. all kinds of problems.
here is a exact copy of my .xprofile

$ xrandr --newmode “1280x1024_60.00” 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsyn
$ xrandr --addmode VGA1 1280x1024_60.00
$ xrandr --output VGA1 --mode 1280x1024_60.00

Check my work, my be on my end. O/S tells me,
xrandr: cannot find mode “1280x1024_60.00”
xrandr: cannot find mode 1280x1024_60.00

Still in old resolution. SUCKS cant see apply buttons at bottoms of critical windows and boxes.

Did you actually include the dollar sign in your script? Because that’s going to be a problem.

I do see you are missing a “c” from the end of the first line.

I did. Sorry will remove. They where in your lines of script, so I just Copy & Paste
I will also add the “c”

PLZ for give me, I cut my teeth on WINDOWS.
This is new to me, but really want to learn.
Thanks for your help.

I’ve got major issues with those settings. Just a black screen after log in. Is there a key on the key board I can hold down to keep that script from running and go in to the old way? I can’t see the desktop anymore.

It’s always good to test things before you make them permanent. You probably picked an unsupported resolution. That said, you can go to a virtual terminal. Usually there are 6 of them which you can get to via CTRL-ALT-Fkey where Fkey is F1-F6. Then log in and you can just rename the file e.g. mv .xprofile ignore-me and restart.

I got the config file right now, It now shows my new resolution setting, but when applied nothing changes. Still no resolve.
Iḿ doing some research on the topic, but nothing is working. Stuck in 1024x768 mode.

If you enter the commands in terminal by themselves, do they work?

I don’t have time to mess with all that. It’s an older intel chipset, it should work out of the box. It does on all other O/S’s.
I will just purchase a new pci card.

I’m sure it would take less time to sort this out, but your choice. Closing.