Intalling LXQT theme, need to enable compositing and disable shadows


I have installed a theme from It has been installed correctly and I have been able to select it in the GUI.
The thing is that in the description of the theme, it says that it is required, in order for the theme to have the intended appearance to:

  • Enable compositing
  • Disable Shadows
    I am new to the linux world, but I am learning quickly. The description said that I would be able to apply this changes in ./config/picom/picom.conf file. I have been exploring the /config directory and I have not yet been able to locate this file nor a *.config file with this settings in order to edit them.
    Could someone point me to where I can change this said settings. Also, I intend to edit this settings by opening the txt file with nano. Is this how you are supposed to do it? It would be the first time for me doing it.

This is the theme that I have been refering, I paste it because I think that it looks pretty clean and it maybe is of some help in order to fix this issue. lxqt theme

Hmm… I don’t think you need to go hacking away at some text files? I could be wrong, but…

In your GUI, in Session Settings > Autostart you can add Picom or enable Compton which is already listed. Window Effects (also found in Preferences > LXQt Settings) has a bunch of options for shadows and should let you turn them off.

1 Like

I played around with this before.
The LXQT session is setup for compton.

Preference>LXQt Settings> Session Settings
	Compton (X Compositor)
	starts compton

Preference>LXQt Settings> Windows Effects
	configs compton via ~/.config/compton.conf

If you want to use picom, you have to delete ~/.config/compton.conf,
(and never click Apply inside Windows Effects). Otherwise picom won’t start.

You also have to untick Compton from Session Settings.
And as KGIII said, add an autostart in
Preference>LXQt Settings> Session Settings>Autostart
(just add it after XScrenSaver).
The command is ‘picom’.

You can put a picom config file in ~/.config/picom.conf
You cannot have any errors in this file, else picom won’t start.
(you won’t need root privilege and you can use Featherpad)

Because you don’t want shadows, you are good to go.
If you want shadows, you may have to replace the autostart command with ‘picom -c’ or something else. (see here)

Personally, I would just stick with compton and play around with the Window Effects.

It begs the question, what are they both doing there?
dpkg-query -s compton
“This package is deprecated and will soon be removed, please switch to picom.”
Apparently, compton seems un-maintained, so picom is a fork, ready to replace it one day.

Screenshot using compton;


This may be like a dumb reply, but I only when I go to session settings I do not have compton listed as an option.

I do have in in my system, and I have found it, but I don’t really know how to add it to the autostart. Should I click add then in name put X compositor and then, write in the command tray~/.config/compton.conf?

Thanks for your answer and I am learning a lot, like what a compositor is.

Sorry, I forgot to add ‘Basic Settings’ (left hand side)

Preference>LXQt Settings> Session Settings > Basic Settings
Compton (X Compositor)

Just tick it and logout, login.
You don’t have to do anything else, except maybe play around with

Preference>LXQt Settings> Windows Effects

everything else is automatically done for you.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.