Installation of Lubuntu 24.04 LTS (Noble Numbat) stuck at 10% for the past 4 hours

Hi Friends,
My installation is stuck at 10%.
I have checked the checksum of the ISO image and it matches.
I have checked the installation media and used two different USB devices just to make sure everything is fine.
I am using Ventoy to create my bootable disk.

When I clicked on the “Toggle Log” button in the installation this is the last line I see
(I am typing it out as I cannot copy paste from the laptop)
2024-06-25 - 09:35:38 [6]: . . Running (“rsync”, “-aHAXSr”, “–filter=-x trusted.overlay.*”, “–exclude”, “/sys/firmware/efi/efivars/”, “–exclude”, “/run/systemd/resolve”, “–progress”, “/tmp/tmpmzbxve0v/filesystem/”, “/tmp/calamares-root-vpwv6yy_”

My hardware details:
HP Laptop
500GB Harddrive
4 Gb RAM
I think the processor is Intel Celeron

Any help on this will be really appreciated.

How did you check the installation media?

Have you tried running the installer a second time?

I checked the installation media by selecting the option when I booted from the usb.
I also checked the downloaded iso by comparing the checksum.
No I did not try it again, will try now if you say so.

Just out of curiosity I tried to install another Linux OS to see if it goes through fine and it did install without any issues (Elementary OS).

Yeah, that casper-md5check thing. I’m not sure that’s 100% infallible, but let’s just give it the benefit of the doubt.

Let’s see how the second install goes.

If you’re still having problems, let us know what specific selections you made for the install options.

What release are you using??

No supported release provides that option, as it’s done differently (background process) in modern and supported releases, and not triggered by user request (older unsupported releases)

Media checks on 23.04 & later are done at terminal, as I describe in this answer - iso - Do I need to check the integrity of a Ubuntu install? - Ask Ubuntu

1 Like

@guiverc Sorry. My bad, I created my USB by Ventoy. And when I boot using Ventoy it gives me the following options

  1. Boot in normal mode
  2. Boot in grub2 mode
  3. File checksum
  4. Return to previous menu
    (let me know if you want me to give you a screenshot)
    So I selected option 3 to make sure the checksum matches.
    When I tried to burn the ISO image using balenaEtcher, it did not give any of these options, but directly the Lubuntu menu. And I couldn’t get past that and installation failed and keeps going back to the main menu.
    I am using the lubuntu 24.04 LTS (Noble Numbat)

@wxl I tried the second time and this time it failed right when I clicked on the install (after selecting Entire Disk in partition). I should not say failed, its stuck, as if the screen is frozen.

Thank you again for trying to help me out.

2 Likes

The untested thing here is Ventoy. Heck, balena kind of is, too. Try mkusb:

https://help.ubuntu.com/community/mkusb

I’ve used ventoy for QA in noble without issue… so I’ll say I trust ventoy (uEFI & legacy MBR)

Ventoy allows me to have oracular, noble & jammy, or more than one ISO on a thumb-drive. I use mkusb and & ventoy.

I hadn’t noticed the

option in Ventoy… and I’ll look for it, but I’ll continue to do the verification of ISO writes as I’ve done it before probably (diff_image_drive for mkusb & simple diff for ventoy already in my script).

Here’s info on the checksum mechanism:

Not sure how infallible it is.

2 Likes

Since you can actually boot into the live image,
why not just try
Startup Disk Creator, aka usb-creator-kde, aka USB-creator(Ubuntu),
which is already installed in 24.04.

It uses dd under the hood, which writes the raw iso image
straight to the disk. It sometimes works when chain boot methods (such as ventoy and unetbootin fail.

I used ventoy, balena and even startup disk creator, but no use. I think there is some issue with the hard drive. I have ordered another hard drive. Let me see if that solves the issue. Will update you when I try with the new HDD.

2 Likes

You did not provide the suffcient details in order to investigate the issue.
I suspect that you

  • did not format your SSD / flash USB correctly,
  • recorded garbage into your flash USB after the use of balena-ETCHER.

The correct steps of formating shall looks as follows generally:

  1. lsblk -a # this command shall list the blokc devices (ssd, usb, …)

abc@abc:/$ lsblk -a
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS
loop0 7:0 0 4K 1 loop /snap/bare/5
loop1 7:1 0 74.2M 1 loop /snap/core22/1380

sda 8:0 0 223.6G 0 disk
└─sda1 8:1 0 223.6G 0 part /home

sdb 8:16 0 59.6G 0 disk
├─sdb1 8:17 0 64M 0 part /boot/efi
├─sdb2 8:18 0 396M 0 part /boot
├─sdb3 8:19 0 12G 0 part /var
├─sdb4 8:20 0 10G 0 part /var/snap/firefox/common/host-hunspell
│ /usr
└─sdb5 8:21 0 10G 0 part /

sdc 8:32 1 28.5G 0 disk
├─sdc1 8:33 1 2.9G 0 part
├─sdc2 8:34 1 4.9M 0 part

You can guess , which device (SSD,USB) is assigned by the name (sda,sdb, sdc) according to the volume in Gb.

  1. Lets assume , you need to format USB drive of 32Gb.
    USB drive of 32Gb is assigned /dev/sdc by the system (above).
    sudo dd if=/dev/zero of=/dev/sdc bs=4K status=progress; sync

  2. You used balena-etcher program for flashing ISO Lubuntu image into the USB drive.
    balena-etcher is a separate package. So, I do not sharpen its use here.

  3. Lets assume , you need to format SSD drive of 224Gb.
    USB drive of 32Gb is assigned /dev/sda by the system (above).
    sudo dd if=/dev/zero of=/dev/sda bs=4K status=progress; sync
    Formatting takes 15-40 minutes depending upon the size and quality of SSD.

  4. Next you need to assign the directories for Lubuntu, at least “/” (root) and “/home” (data).
    You can do so by partitionmanger (easiest way) or by command sudo fdisk /dev/sda
    The volume (Mb and Gb) is an individual decision depending upon the software use.

Lubuntu 22.04/24.04 needs /EFI directory in order to boot the system correctly in UEFI mode:

  1. The settings shall be set in UEFI in section “boot”, corresponding to SSD and to USB.
    This detail is critical to most of the laptops.
  2. all USB/USB3 sections shall be set to ENABLE mode,

The partitions shall be set as follows:-
EFI / bios partition is 64Mb (minimum), FAT32 only
“/” (root)) partition is 20-30Gb
“/home” (data) is the rest of SSD:

sudo mkfs.fat -F32 -n EFI /dev/sda1
sudo mkfs.ext4 -m 0 -b 4K -L root -i 8192 /dev/sda2
sudo mkfs.ext4 -m 0 -b 4K -L home -T huge /dev/sda3

Note, if you used the /home directory from the previous installation, this part will not be deleted/rewrited by OS Lubuntu automatically.

/home/USERNAME directory contains settings of the individual programs.

Prior to the installation I advise to save the important settings of the programs, for example in directoriy ./config and file .asoundrc, if you use alsa settings, and to delete everything in the
/home/USERNAME directry except
/home/USERNAME/Desktop
/home/USERNAME/Downloads
/home/USERNAME/Documents
/home/USERNAME/Templates
/home/USERNAME/Music
/home/USERNAME/Videos

How do you have the partitions made? It seems like it doesn’t start copying