Inspiron 1525, no wi-fi recognition

Greetings all and thanks for your patience,
I’m not sure if this is the right place to ask for help, but here it goes:

I installed a few times some Lubuntu versions on different computers, some installations were tough bones, some were very easy, but I never got stuck like this. I’m not a programmer nor I know Linux language, I’m just a curious using experience as my tool.

I tried to install many different Lubuntu versions on a friend’s computer whose Windows got outdated, but no 100% success.
I can’t put the wireless working, it takes some time starting up and shutting down, and also it takes a few time after hibernation.

I don’t know if I partitioned the hard disk correctly, if 18.04 LTS is the proper Lubuntu version (from all the other versions installed this is the one with most success)

The greatest problem is the wireless. This is my last hope…
I couldn’t upload the integral “hardinfo_report.txt” but here’s some information.

Thanks in advance

Characteristics:

|Processor||: Intel® Pentium® Dual CPU T2390 @ 1.86GHz
|Memory||: 2050MB (264MB used)|
|Machine Type||: Portable|
|Operating System||: Ubuntu 18.04 LTS|

-Mounted File Systems-
udev /dev 0,00 % (976,9 MiB of 976,9 MiB)
tmpfs /run 0,63 % (199,0 MiB of 200,3 MiB)
/dev/sda4 / 12,52 % (32,6 GiB of 37,3 GiB)
tmpfs /dev/shm 0,00 % (1001,3 MiB of 1001,3 MiB)
tmpfs /run/lock 0,08 % (5,0 MiB of 5,0 MiB)
tmpfs /sys/fs/cgroup 0,00 % (1001,3 MiB of 1001,3 MiB)
/dev/sda5 /home 5,18 % (98,5 GiB of 103,8 GiB)
tmpfs /run/user/1000 0,01 % (200,2 MiB of 200,3 MiB)
/dev/sdb1 /media/beta/TERA-PEN 49,56 % (14,5 GiB of 28,8 GiB)

I don’t see the chipset of the wireless controller in the information you have provided (make/model doesn’t narrows it down to 2-5 chipsets with dell/hp/lenovo due to changes during production & options available on purchase), but I note the same question, or a very similar question at https://ubuntuforums.org/showthread.php?t=2426287 where you can the information needed & upload using whatever box you are using now (as long as you can walk between the boxes with a thumb-drive).

As Wild_Man’s script is well used on Ubuntu Forums, Ask Ubuntu, Reddit & other places - I suggest that be your your best choice. If it’s not you, I still suggest you look at that script thread (https://ubuntuforums.org/showthread.php?t=370108) download on existing box, write to thumb-drive, walk to your lubuntu laptop, mount & run it on that box, then walk output back & post.

As for versions/releases of Lubuntu, I’d help more if you you said what you tried. Lubuntu 18.04 LTS means the 2018-April release (18.04 as a yy.mm format is used by Ubuntu releases on all but a specialized few that come out only once per year; eg. Ubuntu Core 18 for IoT appliances). The date is handy as gives a great clue as to what hardware it’ll handle, the LTS tells you it’s a long-term-support release so doesn’t require release-upgrading (bumping to the next release) every 6-9 months; eg. the latest 19.04 (2019-April) will need to bump to 19.10 later this year.

Lubuntu 18.04 LTS was the last with the LXDE user interface, later releases all have the more modern LXQt so you’ll likely have to re-install when you eventually need to move on, but you could remain on 18.04 LTS until it’s EOL (end-of-life) in 2021-April if you wanted. The best for you is your choice; a mixture of do you like release-upgrading every 6-9 months, want the latest software, or want to push off a re-install for a few years when you may not even need the machine anyway.

Thank you very much for your attention. Meanwhile the problem was resolved here. Wireless is working perfectly.

I would like to know if my partitioning is ok, and because the computer still send some errors while shutting down (the battery is damaged), I would like too to see if there’s something more I could do.

How can I send that kind of data for analysis?

Thanks again in advance

Please create a new topic for your other issues.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.