Impress slides do not display properly

I am a long time Lubuntu user (since Lubuntu 10.10) and just recently made the switch to LXQT by installing Lubuntu 20.04.1 on one of my machines. Impressive! However I tried to view the Libre Office Impress slides that I had created on Xubuntu 20.04.1 and Ubuntu 20.04.1 machines for presentations at my local LUG and the words are crammed together. They appear normal when viewed on the two other operating systems. Is this a bug?

When I create slides in Lubuntu 20.04 using LibreOffice Impress they display correctly. This doesn’t make sense. It is the same version of the application, 6.4.6.2

I have no experience with the issue, but the thought that comes to mind is did the Lubuntu system have the same font(s) as the presentation used installed? or was the machine forced to substitute another font?

I created a simple LibreOffice presentation on my primary (hirsute) system, using Star Trek fonts.

I then loaded a QA-test install of Lubuntu groovy (now 20.10) that was untouched beyond minimal validation checks to ensure system was good.

Once the file was transferred there, loaded, and the presentation was attempted to be run, characters were being printed over themselves (as a freshly installed Lubuntu system won’t have the Star Trek fonts I add to my used systems, and a replacement font was thus substituted/used meaning the original effect wasn’t there; no ancient Bajoran characters etc).

I’d check both systems have the same fonts installed (esp. fonts used in the presentation).

Thank you for the response. I have never installed any additional fonts to any of my systems with the exception of Ubuntu (or this case Lubuntu) restricted extras and I have never changed the fonts from the default to create a slide so Liberation Sans is still the default font. However the characters are being printed over the preceding character in the Lubuntu install.

I ran a live boot of Lubuntu 20.04.1 on an other computer and reinstalled with the same result in both instances. Since I never downloaded the previous QT versions (I was content with 18.04 at the time), I have no idea if the same result occurred in them.

2 Likes

Perhaps an example presentation would be useful for us to experiment with.

Also, @hmollercl (being the LibreOffice expert you are), do you have any ideas here?

Hopefully I did that correctly.

I could not attach the presentation to a post here so I put it in dropbox.

Seems like that must not be a proper share since it requires a Dropbox login. My experience with Dropbox is that this should not be required if you did things correctly.

However, you can upload an Impress document no problem, as you can see in the following example. Look for the upload icon between the preformatted text button and the bulleted list.
test.odp (148.1 KB)

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, heic, heif).
This is the same message that I received when I tried to upload a .odp file before. If I try to load the slides one by one they show up as .png on the post. Not sure why you could upload .odp and I cannot, but the system will not allow me to do that.

1 Like

Here it is for you @rex (thanks for emailing me)
CLUGUpcomingEvents.odp (74.5 KB)

2 Likes

This seems to be related to the ever-annoying issue of the SAL_USE_VCLPLUGIN variable, which is set to qt5 in the Session Settings application’s Environment Variables. If you run SAL_USE_VCLPLUGIN="" libreoffice, it behaves just fine.

1 Like

yes, either use gtk3 VCL or use cairo, both solve the issue.
to use gtk3 you can uninstall libreoffice-qt5 (or similar name) or se it in the nev variable. Downside, you get the gtk file picker.
to use cairo+qt5 yous should set the en var SAL_VCL_QT5_USE_CAIRO=true

4 Likes

Neither

or

appear to solve the problem. I have used two separate computers, both with vanilla 20.04.1 installations and the problem refuses to go away. The default font, Liberation Sans was used in both instances.

I am not alone. Just found this on Ask Ubuntu: https://askubuntu.com/questions/1235100/easy-fix-for-libreoffice-impress-font-problems-on-lubutu-20-04
and it is marked as solved.

The solution offered by sudodus installs LibreOffice 7.0.2.2 in a snap and works fine. The bug report is still open (https://bugs.documentfoundation.org/show_bug.cgi?id=132319) but this is a good work around. So this thread probably should be closed. Thank you @guiverc, @wxl, and @hmollercl. There is no bug report opened on Launchpad. Should that be done?

2 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

According to that upstream bug, it sounds like whatever the problem is was fixed in a later version of Impress. There seems to be an even later version available in focal-updates, too.

1 Like