Icons for chrome web apps won't show

Hi everybody!
I’m using lubuntu 20.04 with the latest updates and I make large use of chrome web apps. unlike other distros like kubuntu, all my web apps don’t usually show their custom icon, even though that field is correctly set on the .desktop file.
here’s an example

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Terminal=false
Type=Application
Name=Google Drive
Exec=/opt/google/chrome/google-chrome --profile-directory=Default --app-id=aghbiahbpaijignceidepookljebhfak
Icon=chrome-aghbiahbpaijignceidepookljebhfak-Default
StartupWMClass=crx_aghbiahbpaijignceidepookljebhfak

to make the icon show I had to correct the line with

Icon=/home/USER/.local/share/icons/hicolor/48x48/apps/chrome-aghbiahbpaijignceidepookljebhfak-Default

Is there a way for me to get the same result without having to make such a correction?

already tried with the ~/.icons directory without any result

I’m not familiar with web apps but out of curiosity, does the icon also not show up from file explorer or PCmanfm-qt when viewing your Desktop directory?

Yes, the behaviour from Pcmanfm file explorer is exactly the same!

Here’s what I find investigating further:

The directory where systems mostly look for user icons is ~/.local/share/icons , especially the "hicolor" theme which works as sort of a fallback or default directory.
This seems to work perfectly on my system: if I install a custom icon with the command

xdg-icon-resource install --size 256 prefix-icon.png

everything works smoothly: even if I may need to reboot, the icon file appears on the directory above, just like the correctly named icons for chrome web apps are already in the directories they should be, and using “prefix-icon” in the icon field of a .desktop file will show that specific icon on desktop, in file manager and in the apps menu.

As you may know, icons should be registered with a vendor name prefix, like "numix-monitor"

But I noticed that if I install an icon with the chrome prefix, it won’t show: only the default chrome icon will appear

Installing the icon with the --novendor won’t help, the length or the suffix or the icon name won’t change the result

Any hints? Should I file an issue in the github repository of lxqt ?