How to install battery icon on Lubuntu

Hi,

I have just switched to a Lubuntu computer from Windows - I have never used any Ubuntu or non-Windows platform before and I am having some difficulties. One issue is that there is no battery icon on the panel at the bottom of the screen.

I tried right clicking that panel and adding a plug-in, but there was no battery or power plug-in available in the list; nor is there any option under ‘preferences’ about the power status, battery icon, etc. I tried to download some plug-ins but I don’t really know what I’m doing in this field and I just got error messages.

How can I fix this so I can see how much power I have and if my computer is charging or not?

I am running Ubuntu 18.04.

Thank you.

1 Like

Try this…

Right click on the panel and select Panel Settings.

Click on Panel Applets (it’s a tab).

Click on “Add” (it’s on the right).

Select “Battery Monitor” and then click Add (in the lower right).

That brings you back to the Applets screen.

Highlight the Battery Monitor and use the Up/Down to position it where you’d like it positioned in the panel.

Hi, thanks for the response.

I tried those steps (though the terminology is different on my system - ‘configure panel’ then ‘manage widgets’). There are fifteen or so ‘widgets’ there one can add (‘date and time’, ‘directory menu’, ‘CPU monitor’, etc. etc.), but there is no battery or power monitor listed.

i was therefore trying to download some third-party widget or plug-in to do the job, but without success. any ideas?

When trying to install a third party widget such as ‘fdpowermon’, I get the following error message:

sudo apt-get install fdpowermon
[sudo] password for XXXX:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
acpi
The following NEW packages will be installed:
acpi fdpowermon
0 upgraded, 2 newly installed, 0 to remove and 500 not upgraded.
2 not fully installed or removed.
Need to get 26.9 kB of archives.
After this operation, 90.1 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu bionic/universe amd64 acpi amd64 1.7-1.1 [12.9 kB]
Get:2 Index of /ubuntu bionic/universe amd64 fdpowermon all 1.18 [14.1 kB]
Fetched 26.9 kB in 2s (15.0 kB/s)
Selecting previously unselected package acpi.
(Reading database … 329765 files and directories currently installed.)
Preparing to unpack …/acpi_1.7-1.1_amd64.deb …
Unpacking acpi (1.7-1.1) …
Selecting previously unselected package fdpowermon.
Preparing to unpack …/fdpowermon_1.18_all.deb …
Unpacking fdpowermon (1.18) …
Setting up acpi (1.7-1.1) …
Setting up jitsi-meet-prosody (1.0.3729-1) …
The given hostname does not exist in the config
dpkg: error processing package jitsi-meet-prosody (–configure):
installed jitsi-meet-prosody package post-installation script subprocess returned error exit status 1
Setting up fdpowermon (1.18) …
dpkg: dependency problems prevent configuration of jitsi-meet:
jitsi-meet depends on jitsi-meet-prosody (= 1.0.3729-1); however:
Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for man-db (2.8.3-2ubuntu0.1) …
Errors were encountered while processing:
jitsi-meet-prosody
jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have no idea why your computer doesn’t have it.

It’s the third option down in English, though it may be sorted differently if the language is different.

Maybe someone will explain how your system doesn’t have the applet.

As for your installation, you seem to be having issues with some jitsi-meet. It looks like an unfinished installation. I’d remove it and then see if you can install the ‘acpi fdpowermon’. I’ve never not had the battery indicator, so I’ve never had to try anything else.

First, you should remove jitsi-meet as something is wrong there. The relevant error seems rather strange (The given hostname does not exist in the config). That shouldn’t affect the installation of fdpowermon.

However, I don’t see the point. You already have XFCE Power Manager. Here’s a screenshot to help make things more clear. I’ve arrange some things to make it more obvious:

If you look at the panel settings dialog, you’ll see two things after the “Desktop Pager” (well, and the “Spacer”): “System Tray” (which includes the green battery icon in the panel) and “Battery Monitor” (which is the yellow battery icon in the panel).

If you look at the “Add plugin to panel” dialog, you’ll see that I have selected the second of those two icons, the “Battery Monitor.”

If you look at the little pop up whose bottom right corner is just above the green icon, that is the context menu for that particular icon. If I click on the “Power manager settings…” it opens the “Xfce [sic] Power Manager” dialog that you see to the left.

So everything is there that you need. Heck, there are two options! But XFCE Power Manager is most certainly better.

Hi,

thanks for your pointers - but unfortunately, no, the list of plug-ins i am offered lacks both ‘battery monitor’ and ‘xfce power manager’. (though it does include ‘system tray’, when I add this nothing new appears on the panel at the bottom). Not sure why that is, but they are not present on my computer.

if you wouldn’t mind, perhaps you could let me know how i can uninstall the jitsi program to try again downloading a third-party option?

I think you’re missing something. If you look under “panel applets” in “panel preferences,” it could be completely empty if you set it that way. To add things, click “add” and then the “add plugin to panel” option comes up. In this way, “battery monitor” can be added. XFCE Power Manager would show if and only if you have “system tray” included and XFCE Power Manager itself is set to be running (you can turn it off). If any of that is not true, you have a broken system and should reinstall.

As for your “third party option,” you already did install it (fdpowermon) but the errors you see were from the package management system regarding Jitsi. Any time you install a program, you’re going to get that error until you get rid of it so sudo apt purge jitsi-meet.

Hi,

thanks a lot.

  1. I believe I understand what you’re suggesting, but it’s not working - I’ve selected ‘system tray’, but nonetheless, when I go into the widgets list there is no power/battery option available.

I’ve attached a screenshot so you can see what I mean.

  1. When I run that command to remove Jitsi, I receive the following error:

E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

Any idea how I can get past either of these?

As you can see from my screenshot (and as I mentioned earlier re. the different terminology), my system looks rather different (more basic) and uses different terminology to the system you sent the example from.

I was given this laptop by someone else so I’m not sure on the specs, but I was told it was Lubuntu (which is what comes up when i power on/off) and when I checked the system it said it was ‘ubuntu 18.04’. But perhaps it’s an older version of Lubuntu?

If I can give you more info to help you with this, please let me know how and i’m happy to provide it!

This is just getting weird. Your image isn’t working for me, by the way.

Open your terminal and enter:

 lsb_release -a

And:

echo $XDG_CURRENT_DESKTOP

That’ll tell us what version you’re using and what desktop environment you’re working with. 'Cause you should have a battery monitor exactly where we’ve told you. That shouldn’t just randomly disappear.

As an aside, I don’t think I’d have kept an OS installed by someone else. You can also open Start Menu > System Tools > System Profiler and Benchmark and get your computer’s stats. However, the stats would have absolutely zero bearing on the battery monitor being there or not being there. Still, it’s there if you want it. I much prefer a terminal application called ‘inxi’, but you’re having issues installing software.

Yes, I showed it to some friends who know their way around Ubuntu better than I do and they were also stumped.

The specs are:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

and

LXDE,

if that sheds any light on the matter!

Well, that looks indeed like Lubuntu 18.04. Though you’re a ways behind, as it should say 18.04.5.

If @wxl can’t figure out why it’s not updating, I am not gonna be able to figure it out. I was just confirming that you have Lubuntu.

Your system is saying you have 18.04 but it looks like you’re using LXQt, so I have no idea what you’ve managed to break, especially given your XDG variables are thinking you’re running LXDE. I’d just reinstall. And use 20.04. 18.04 support ends in April.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.