How to disable the lock of mouse pad over typing?

Well, this question is from this guy:

You mean they want the mouse pad to not recognize any activity when typing is happening?

1 Like

Nop, the opposite. (20 characters)

I’m confused, because I thought that was the default.

1 Like

Yes, the default is to lock the mouse while typing … but he wants to type and use the mouse pad.

Unfortunately there is no GUI interface to toggle this. I did some experimentation, here are my results:

First @wxl pointed me at an Arch wiki page. Before you get too deep into that here are the highlights I found.

  • In the terminal do xinput list This should list out all of the devices attached to your computer that can be used as input devices. Search for the device that is a touchpad. Mine is a AlpsPS/2 ALPS GlidePoint id=18 [slave pointer (2)] as reported from the system. Note the device id.
  • List the properties for the device by doing xinput list-props 18 Note 18 was my device id from above, your device may be different. From this listing you want to look for something like this libinput Disable While Typing Enabled (330): 1 Having a value of 1 means that the touchpad is disabled when typing is taking place. The property number in () is needed for the next step.
  • Since the libinput Disable While Typing Enabled (330): was set to 1 above, to flip it you want to set it to 0. xinput set-prop 18 330 0 will change that. The change can be verified by listing the properties again xinput list-props 18 and if you decide to change it back you could do xinput set-prop 18 330 1.

If you find yourself stuck or have issues please let us know and we can try to work through it.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.