How do I troubleshoot Slow performance on x86-64 4gb ram laptop

my performance is terrible. like 10 seconds to open a new window. ive tried all suggestions so far . not sure what else to do… below are my specs …

HP Dm1z-3000 notebook computer with AMD Fusion E-350 64bit dual core at 1.6Ghz GPU is AMD ATI Radeon HD 6310 8GB memory (that i upgraded from 4) , 250GB HD

  • I installed lubuntu-22.04.2-desktop-amd64 from USB Flash
  • Neofetch shows the DE is LXQt 0.17.1
  • no errors during install except 1 message “common interrupt 1.55 No IRQ handler for vector at boot time”
  • i searched online and others say that message is not critical
  • I have enlarged swap size from 1G to 4G
  • I have run the hard disk self test within the HP bios
  • I have run the memory self test within the HP bios
  • I have run the memtest86 from the grub menu at bootup
  • i use the QPS tool to see the cpu usage. its very low

what else can i do to ? e.g. it takes 10 seconds just to open a terminal window!


I’ll give some clues, (alas with a story).

Until somewhat recently my primary PC was a 2009 dell desktop that had issues, esp. when using browsers chromium and firefox. My system would just drop to a crawl & it would often have taken far longer than 10 seconds for a CtrlAltT to open a qterminal… But initially I just had a system that ‘dropped to a crawl’ without a reason so I had to explore.

  • my first step was RAM tests & some disk checks (SMART etc… as if using consumer grade drives (which come with longer warranties the drives get awfully slow when they’re getting old & are experiencing degraded performance on some areas of the disk; esp. spinning rust drives and don’t report errors as that would be a warranty claim) etc.
  • next I looked for patterns, what was in RAM during these ‘seizures’… (for me this was about 8 apps that are always open)
  • when I turned the system on (and it was fast) I’d open a terminal on the display and leave htop running… It’s pretty light on resources so I wasn’t worried about it, qps you mention maybe as good but I have little experience with it sorry. I’d also login to a text terminal session (CtrlAltF4) & have htop running there
  • checked for any clues in .crash files (in /var/crash/) but none were evident to me at the times where the system crawled.
  • I would often switch to text terminal & watch the system, even when running perfectly, so I had something to contrast to when I had issues & could monitor changes
  • explore system logs too for clues (dmesg or journalctl) too

Eventually I worked out either chromium or firefox had to be in memory for the issue to occur, and the issue was a likely a RAM leak where those apps were involved. Watching htop allowed me to find that out.

I removed the extensions I had on both browsers, then used the system normally for about 10 days and not once did I have an issue… Next I explored the extensions (particularly those I valued) and concluded it was either of two extensions.

My choice was to live without those extensions on a fast system, or use them & just recognize the issue before it became a problem & deal with it… I wanted the extensions so just worked around the issue & got pretty good at detecting when I was going to have an issue & corrected it before any slowness appeared… FYI: I’ve written about this before, eg. here and here as the issue I was experiencing is now dealt with differently on jammy (22.04 & later)

There are many tools we have available; top being the basic tool I used in the 1980s; htop a colorized version, iftop for looking at interface issues, iotop for IO, & heaps more… but htop is a good starting point in my view like your qps but I’d choose a terminal based one that you can also use in text terminal to ensure the GUI/desktop isn’t involved… My exploration included testing in other desktops (Xfce/GNOME & MATE) where the issue for me was identical so I could rule out LXQt’s involvement, for you a text terminal will be easiest I bet (ruling out LXQt/graphic/GUI issues).

No answer here sorry, just my 2c thoughts… I’ve ignored swap as you mention creating swap


I’m curious what extensions were causing the problem.

As I recall it was

  • ublock origin
  • privacy badger

I use both of those extensions and no other extensions and so far have never experienced any problems from them.

1 Like

I’m using them (two extensions on firefox/chromium) too on this box without issue, but when used on core2quad or core2duo CPU and leaving the system running (or suspended overnight) for days, the problem I was getting occurred on Debian/Ubuntu/OpenSuSE/Fedora… I also didn’t experience issues if uptime was less than 2 days ; with it expected late day 3 usually & on. If you did the same test (looked for the problem) on a i5 system you perform the exact behavior for 4 days without issue though, whatever it was required a number of factors


One of my Lubuntu 22.04 desktops runs a core 2 duo E7500 an has 4.0 GB of DDR3 memory and Intel integrated graphics.

If there is any slowness I’ve never noticed it.

Oh well I was just curious about the extensions.

I know that some extensions and to many extensions can and do cause problems.

Is that 250 GB HD an SSD or HDD ?
If it is a HDD an SDD will very likely improve your issue as you state the cpu usage is low. The speed increase of the SSD is irrelevant for these old laptop but the HUGE decrease in latency will make a noticeable difference in your desktop experience.

You can get really cheap SSD drives (currently 512GB SSD for $24 at Microcenter). I picked one up for a laptop very similar to your yours except mine is a step down in performance to yours.
I have dual core C-50 AMD CPU (only 1.0 Ghz!) with Radeon HD 6250 8 Gig Memory and a nice new cheapo $24 SSD.

My old C-50 based laptop is not “fast” but the performance is noticeably MUCH better with SDD instead of HDD. A terminal pops up instantly with no noticeable delay. With Chrome installed from google website and hardware acceleration I can watch 1080p videos fullscreen without any lag! Same with Firefox but it still takes a bit long to load Firefox as Lubuntu ships it as a snap. There are messy instructions to remove snap on Lubuntu but I really don’t recommend removing snaps unless you are a savvy Linux user and Ok with future breakage/cleanup when upgrading.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.