How do I change from PAL to NTSC?

Hello, I’ve this old 32-bit computer and Lubuntu has installed NVIDIA drivers correctly (PC has a GeForce 6200) since I run the installer setup online. I used a different screen monitor during this installer. But now that I switched to an old TV that I’ll be using for this computer, connected through S-Video, there’s a problem:

I’ve no colours, it’s all black & white. This happens because the TV is NTSC and Lubuntu it’s in PAL standard. How can I switch to NTSC?

I’ve tried booting into recovery, running X -configure to generate a xorg.conf skeleton that I’ve placed in /etc/X11/ …but I don’t know how to add the needed change.

Also I’ve been fiddling with xrandr --output TV-1 but couldn’t make it.

Thanks in advance. Cheers!

Yiiiiiiiiiiiiiiiikes that’s going to be a tough one to answer as I’m sure few are using similar systems, on Lubuntu or otherwise. That said, you might expand your inquiry to the wider Ubuntu community (try askubuntu.com).

However, a little searching suggests that the solution would be, assuming that your output is indeed named TV-1, is to use xrandr --output TV-1 --set "tv standard" ntsc. xrandr --verbose should give you a list of all the outputs and the different modes and such they support. If that works but fails to produce a reasonable size, you might want to first do xrandr --output TV-1 --set "load detection" 1. If it gives you a BadName error, you might want to use tv_standard instead of "tv standard".

If you get it figured out, just throw the command in your autostart and you’re all set. Alternately, get your display manager (I presume you’re on 18.04, so lightdm) to start it if it supports it. You could always do the Xorg.conf route but I find that to be much more of a pain as you have to add a lot of extra cruft.

BTW, probably better for #offtopic but looking at your avatar: Louis Wain and/or Current 93 fan?

Yeah, xrandr gives me the BadName error in either case.

I’ll give a try in askubuntu. Thanks!

p.s. yes, I like louis wain’s cat paintings and I think this one is my favorite picture.

Could you paste here what xrandr --verbose yields?

Re: Louis, he’s pretty remarkable. My first introduction to his work was the aforementioned apocalyptic folk (yes, not everyone’s cup of tea) group Current 93. Wain’s work has featured prominently in much of their work, including actual songs about cats.

Here’s the output:

Screen 0: minimum 320 x 200, current 640 x 480, maximum 4096 x 4096
VGA-1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x91
	Timestamp:  127024
	Subpixel:   unknown
	Clones:    
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	link-status: Good 
		supported: Good, Bad
	non-desktop: 0 
		range: (0, 1)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x92
	Timestamp:  127024
	Subpixel:   unknown
	Clones:    
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	dithering mode: auto 
		supported: auto, off, on
	scaling mode: None 
		supported: None, Full, Center, Full aspect
	subconnector: Unknown 
		supported: Unknown, DVI-D, DVI-A
	link-status: Good 
		supported: Good, Bad
	non-desktop: 0 
		range: (0, 1)
TV-1 connected primary 640x480+0+0 (0x99) normal (normal left inverted right x axis y axis) 0mm x 0mm
	Identifier: 0x93
	Timestamp:  127024
	Subpixel:   unknown
	Gamma:      1.0:1.0:1.0
	Brightness: 1.0
	Clones:    
	CRTC:       0
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	overscan: 50 
		range: (0, 100)
	hue: 0 
		range: (0, 100)
	saturation: 50 
		range: (0, 100)
	flicker reduction: 50 
		range: (0, 100)
	mode: PAL 
		supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J, hd480i, hd480p, hd576i, hd576p, hd720p, hd1080i
	subconnector: Composite 
		supported: Unknown, Composite, SVIDEO, Component, SCART
	select subconnector: Automatic 
		supported: Automatic, Composite, SVIDEO, Component, SCART
	link-status: Good 
		supported: Good, Bad
	non-desktop: 0 
		range: (0, 1)
  720x576 (0x95) 28.656MHz -HSync -VSync +preferred
        h: width   720 start  776 end  856 total  960 skew    0 clock  29.85KHz
        v: height  576 start  576 end  588 total  597           clock  50.00Hz
  1024x768 (0x96) 54.163MHz -HSync -VSync
        h: width  1024 start 1064 end 1200 total 1344 skew    0 clock  40.30KHz
        v: height  768 start  768 end  777 total  806           clock  50.00Hz
  800x600 (0x97) 32.136MHz +HSync +VSync
        h: width   800 start  840 end  920 total 1040 skew    0 clock  30.90KHz
        v: height  600 start  600 end  604 total  618           clock  50.00Hz
  720x480 (0x98) 25.200MHz -HSync -VSync
        h: width   720 start  752 end  872 total  960 skew    0 clock  26.25KHz
        v: height  480 start  480 end  493 total  525           clock  50.00Hz
  640x480 (0x99) 23.100MHz -HSync -VSync *current
        h: width   640 start  672 end  768 total  880 skew    0 clock  26.25KHz
        v: height  480 start  480 end  492 total  525           clock  50.00Hz
  400x300 (0x9a) 20.096MHz +HSync +VSync DoubleScan
        h: width   400 start  432 end  496 total  640 skew    0 clock  31.40KHz
        v: height  300 start  300 end  303 total  314           clock  50.00Hz
  320x240 (0x9b) 14.728MHz -HSync -VSync DoubleScan
        h: width   320 start  344 end  392 total  560 skew    0 clock  26.30KHz
        v: height  240 start  240 end  246 total  263           clock  50.00Hz
  320x200 (0x9c) 12.320MHz -HSync -VSync DoubleScan
        h: width   320 start  344 end  392 total  560 skew    0 clock  22.00KHz
        v: height  200 start  200 end  202 total  220           clock  50.00Hz

Btw, I’m using nvidia propietary video driver which installed correctly and I’ve read online that I can change from PAL to NTSC at Nvidia GUI. Is there any way to install that GUI?

Try xrandr --output TV-1 --set mode NTSC-M (NTSC-J is non-standard NTSC, right?)

Did you install that driver with the “additional drivers” option? If not, you’re not going to get it out of the box. That should come with what you need.

Yes, I am quite sure that I checked the additional drivers box when installing the OS. Otherwise I would not have the driver installed at all. I think it is installed but with no GUI.

The aforementioned command does not work. It says something similar to: badValue (integer out of range).

Can you provide your /var/log/Xorg.0.log?