How can I disable mouse pointer / cursor?

I’m using LXQt on Lubuntu 20.04.2 LTS, and would like to disable the mouse pointer / cursor. I added the -nocursor option in /etc/X11/xinit/xserverrc, so the exec line is now:

exec /usr/bin/X -nocursor -nolisten tcp "$@"
saved my changes, and rebooted. This made no difference.
I prefer to disable the cursor using X server options and not use unclutter. If you know how to do this, I would appreciate your help!

For other users of the interwebs looking for the same, edit /etc/sddm.conf, add a section as shown below, save and reboot.

$ sudo vim (or nano, etc.) /etc/sddm.conf

new section:

[X11]
ServerArguments=-nocursor -nolisten tcp

Save changes

$ reboot now

I don’t know if ServerArguments options are additive/cumulative to options found in /etc/X11/xinit/xserverrc, or if this replaces the arguments. I initially assumed replacement, and had set ServerArguments to ‘-nocursor -nolisten tcp “$@”.’ After rebooting, the GUI didn’t complete loading. I used the Ctrl+Alt+F2 shortcut to login a text-only environment, modify /etc/sddm.conf, removing “$@” from ServerArguments, and reboot. I’m unsure of the purpose of “$@.”

I found this helpful: SDDM - ArchWiki

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.