Help with zshell issues (as related to nvim)

First off, sorry if this is the incorrect forum. Didn’t really feel like this was related to lubuntu specifically so I didn’t know where to put it.

I’m having some issues when trying to run the nvim.appimage that was downloaded pre-compiled and ready to go from github.

I can run it just fine from my downloads folder but I moved it to /usr/local/bin/nvim
and it is just refusing to work no matter what I do.

 ls -la /usr/local/bin/nvim                                                                                                                    
drwxr-xr-x 2 jw   jw       4096 jul 23 12:15 .
drwxr-xr-x 3 root root     4096 jul 23 12:15 ..
-rwxrwxrwx 1 jw   jw   11109568 jul 22 22:44 nvim.appimage

As you can see I went mad and tried to give every user group the right to do whatever with the file…

in .zshrc i have “alias vim=/usr/local/bin/nvim/nvim.appimage”, however, trying to run it I get:

zsh: no such file or directory: ./usr/local/bin/nvim/nvim.appimage

executing /usr/local/bin/nvim/nvim.appimage works fine.

executing just “nvim” gives

zsh: permission denied: nvim

What the hell is going on?!

There is an extra ‘.’ at the start of
are you sure your alias is correct ?

executing “nvim” (assuming your path has /usr/local/bin) just executes the directory nvim. You should be executing “nvim/nvim.appimage”

1 Like

This worked, which is weird. In bash I know you need the ./ to execute but in zshell it doesn’t want to execute with ./ unless I am in the directory where the executable is located or before it. e.g. I can’t run ./usr/local/… from home. I assumed it would be the same from .zshrc - it wasn’t. I can now run it with the alias.

Interesting, so making “nvim” actually run the executable probably requires it to be installed with ‘apt’ or some other package manager, is that correct?

Thanks for the help <3

1 Like

No, I meant that the extra ‘.’ shouldn’t be there at all. But your zsh seems to think the alias had one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.