Grub menu after Lubuntu 20.04 installation

Hi,

I have just installed lubuntu 20.04 after windows 10 installation in the same hard disk and when I reboot the computer I get a command Grub menu.

This command grub menu is different to the “normal grub menu” where I can choose the operative system to boot with.

How can I get the “normal grub menu”?

I think that I have to try some commands, I have tried “reboot” command and after that the system reboots and I get the same command grub menu.

Any suggestion?

Greetings.

Hi again,

I think that I have solved the problem.
With a livecd (usb) I have tried BOOT REPAIR and It has worked.

I don´t know why I didn´t get the “normal grub menu” after the installation.

Greetings.

Hi,

It hasn’t been solved, the first boot was successful, I was able to boot with Windows10 and Lubuntu 20.04, but the next attempts were unsuccessful.

I can boot with Lubuntu 20.04 but not with Windows (I get a black screen).

There is something strange in my grub menu, there are two entries for windows (I can boot in none):

I think that I’m going to install everything (W10 and Lubuntu) and I will tell you the steps.

Greetings.

Thinking about the problem I remember that after finishing manual partitioning in Lubuntu 20.04 installation, I got an error message saying that /boot/efi partition hasn’t been created.

My desktop computer has got a MBR partition and no UEFI Bios so I skipped the error message.

Am I wrong? Should I have created the /boot/efi partition?

In all the Lubuntu installations that I have installed in my desktop computer I have never created a /boot/efi partition.

Is the grub error due to /boot/efi partition?

Greetings.

If your system is not an UEFI system, it shouldn’t need it and legacy systems likely won’t even work with an ESP or EFI partition. At least, that is my understanding about them.

I am not entirely sure why there are two Windows listings under the Grub menu.

Do you recall how you got Lubuntu installed initially? Based on the Grub image you showed us, I take it you did the “alongside” installation but you also mention manual partitioning.

Did you do the “alongside Windows” installation first and then attempt a manual partition install?

1 Like

First, I have done a Windows 10 installation and then Lubuntu 20.04 installation with manual partitioning, both installations in the same hard disk.

Greetings.

My computer specifications:
64 bits computer.
Intel(R) Core™ i5-4460 CPU @ 3.20GHz 3.20 GHz.
4 gb ram.
MBR partition table.
Bios (not UEFI system).

I have installed windows 10 again and then I have installed Lubuntu 20.04 with manual partitioning.

I have got the grub menu, but when I choose Windows10 sometimes boots w10 and sometimes doesn´t boot so I don´t know what to do.

When I select Windows10 in the grub menu and doesn´t boot I get a black screen where everything I do with the keyboard is useless so I have to power off the computer.

This is my disk with Windows10 before installing Lubuntu 20.04.

Then in the unassigned space (780,95 GB) I have created a logic partition with four partitions inside:
swap: 4gb
/boot: 1gb ext2
/: 30 gb ext4
/home: 745,9 gb ext4

Any idea, why do I get sometimes a black screen when I boot with Windows10?
When I boot with Lubuntu 20.04, It always works perfect.

Could it be that in the grub menu the “/dev/sda1” line for Windows10 should be “dev/sda2”?

(*) Edited 1:
I have discovered two things:
i) when I boot first with Lubuntu and then do a reboot and boot with Windows10, It works.
ii) when I boot first with Windows10, I get a black screen but the system is loading the login screen because if I do this sequence (with the black screen): intro / put my password / alt + f4 / intro / the system switch off, wich is the same sequence I do with windows 10 working properly (without black screen) so I think it could be a problem with the graphics card.

(*) Edited 2
I have found the answer for the problem. It is something that I did one year ago but I had forgotten it.
In Windows 10 I had to disable the fast startup because it affects to grub, so I did that and there is no black screen and W10 boots fine. (Control panel / Power options / what the power buttons do / Change settings that are currently unavailable / turn off fast startup.)

Greetings.

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.