Greeter set to Dvorak keyboard layout, but password field must be typed as QWERTY

Summary: I am using the US Dvorak keyboard layout, but in the GDM greeter, password fails unless I type it as QWERTY keyboard layout.

Details
My user keyboard layout is Dvorak (a USA layout). Once I log in, thatś what is available everywhere.

When I logout though, I realised from several failed password attempts that the keyboard layout is “incorrect”. Itś QWERTY there.

I tried using the following to make sure the system keyboard layout is also Dvorak, but it either didn´t apply or didn´t survive reboot:

sudo dpkg-reconfigure keyboard-configuration

On the greeter, although I must type my password as QWERTY, the “flag” indicates that the US layout is in fact enabled - confused yet?

It could be related to this bug: Bug #1826881 “Greeter uses wrong keyboard layout for password fi...” : Bugs : ubuntu-unity-meta package : Ubuntu

(As a new user, I can only attach one image per post. Apologies for multiple posts).

My locale is set for Ireland:
screen01

And hereś my keyboard layout, as I already mentioned:
screen02

LXQt settings aren’t used until after you’ve logged in and the LXQt session has been started.

If you want to use a different configuration at the greeter, you’ll need the greeter to know what keyboard you’re using, as it won’t be reading your LXQt setup.

Do note however GDM3 uses GNOME features to work (writing to the screen, getting input from keyboard); and isn’t supported by Lubuntu. You didn’t provide release details; but have you looked (Ubuntu – Details of package gdm3 in jammy).

1 Like

Try this

Thanks @guiverc. Yes, I suspected that it was a GDM issue. I´m on 22.04 (Iĺl update the OP).

“but have you looked at … gdm3”
No, I assumed I could fix without installing more Gnome stuff. I can install that package without breakage?

@Roberalz thank you. Following the instructions at that thread I edited

/etc/X11/xorg.conf.d/00-keyboard.conf

and updated that line to be:

Option "XkbLayout" "dvorak-intl"

But after a reboot, the issue persists.

I think that dvorak-intl is not a layout, but a variant. I did not test it, but you should modify the file to something like:

Section "InputClass"
  Identifier "system-keyboard"
  MatchIsKeyboard "on"
  Option "XkbLayout" "ir"  # Please take here the correct layout, I am just guessing
  Option "XkbVariant" "dvorak-intl"
EndSection

For more details please have a look at Xorg/Keyboard configuration - ArchWiki

2 Likes

@apt-ghetto that works! Thank you so much!!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.