Graphic card AMD Radeon HD 4350/4550 and Lubuntu 22.04.3: Screen constantly turns black for some seconds


My PC is about 15 years old, I am using it once in a while as a replacement for my laptop with Debian 12 on it, in case my laptop cannot be used.

My PC contains a cheap graphics card, an AMD Radeon HD 4350/4550 card (as specified in the output of the command inxi -G on this machine). This graphic card causes problems in Lubuntu 22.04.3. But it did not cause problems in Lubuntu 20.04.

Here is some information about this graphic card:

[sudo] Passwort für xxx: 
       description: VGA compatible controller
       product: RV710 [Radeon HD 4350/4550]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=radeon latency=0 resolution=1920,1080
       resources: irq:25 memory:d0000000-dfffffff memory:fdee0000-fdeeffff ioport:ee00(size=256) memory:c0000-dffff

The upgrade process on my PC from Lubuntu 20.04 to 22.04.03 went wrong: after the upgrade the PC created a kernel panic message at every boot. The reason for this could have been a missing dedicated partition with a BIOS-boot flag in the partition table.

Anyway, I decided to completely apply a new installation of Lubuntu 22.04.3 today, adding a partition with the BIOS-boot flag to my machine. Having completed the installation, I downloaded some extra packages for Lubuntu, and I noticed the following behavior before and after my logins into the GUI of Lubuntu 22-04.03:

The screen resolution of the GUI was frequently changing, from 640x480 to 1024*768 ato 1920x1080 pixel (not always in this order) and back. My smart-TV showed me the respective screen resolution on its screen.

Each time the screen changed its resolution, it turned black for some seconds. After that, the Lubuntu GUI was shown again.

I of course checked the screen settings in the Control Settings or how it is called (I am currently writing this text on my laptop), but it either showed 1024x768 or 1920x1080 pixel as the screen resolution.

So I did some research about my graphics card on the Internet and found among other tings that my graphics card does not work in Ubuntu 22.04:

But I also found some helpful information in the following thread here in this forum:

So I applied the steps claypooj21 mentioned in that thread on June 3rd 2021, adapted to my situation, i. e. to my graphic card and display name, and thus I created a /etc/X11/xorg.conf.d/10-monitor.conf file with the command “sudo touch ” and inserted into this file Xorg specific information (commands) for the radeon driver how to deal with my graphics card.

After a reboot I noticed, having logged into Lubuntu 22.04.03, that the screen resolution did not change anymore, it always stayed on 1920x1080 pixel, as specified in the /etc/X11/xorg.conf.d/10-monitor.conf file which I had created.

But the screen still turns dark after a while, and then after a while back to the Lubuntu GUI. And this in a loop.

I tried to find something out about the reasons for this behavior on my machine:

xxx@yyy:~$ dmesg | egrep 'drm|radeon'
dmesg: Lesen des Kernelpuffers ist fehlgeschlagen: Vorgang nicht zulässig

Which means in English: “Reading the kernel buffer has failed: Procedure not permitted”

xxx@yyy:/var/log$ less Xorg.0.log | grep EE
[    36.416] Current Operating System: Linux yyy 6.2.0-26-generic #26~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 13 16:27:29 UTC 2 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.422] (II) Initializing extension MIT-SCREEN-SAVER
xxx@yyy:/var/log$ less Xorg.0.log | grep -i drm
[    36.700] (II) xfree86: Adding drm device (/dev/dri/card0)
[    36.700] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/drm/card0
[    40.229] (II) RADEON(0): glamor X acceleration enabled on AMD RV710 (DRM 2.50.0 / 6.2.0-26-generic, LLVM 15.0.7)

My question is:

Is there any Xorg command that can be used within the /etc/X11/xorg.conf.d/10-monitor.conf file which would prevent my screen from turning black and back to the GUI all the time? If yes, which parameters should that command get?



1 Like

Maybe try turning off the screensaver and power saving in the screensaver.


I’ll also remind you Ubuntu LTS releases have kernel stack options, and did you note what you were using back in 20.04?

The HWE kernel stack for 20.04 on a fully upgraded system (20.04.5) used the same stack as Ubuntu 22.04 LTS if using the GA kernel stack, ie. both use 5.15.

If your system was using the GA stack on 20.04 (5.4), then that’s a huge jump to 6.2 on 22.04.3 (using HWE). Both stacks can co-exist, except if you’re using a few closed-source kernel modules (eg. some Nvidia drivers will prevent it), so I usually opt to install both kernel stacks on the older LTS prior to upgrade, and if I have problems with the newer one, I’d login using the older stack (ie. what I could use & test back on 20.04 in your case).

With Lubuntu, the installation media itself dictates which kernel stack is default; 22.04 & 22.04.1 media defaulted to the GA kernel stack (just as it did with Ubuntu 18.04 LTS & earlier media), yet 22.04.2 & later media defaults to HWE kernel stack. We’re not alone is using this standard (which was default for 18.04 & earlier) but it can be changed post-install too.

My oldest device used in QA is from 2005, my secondary PC is from 2008, thus I’m somewhat familiar with some older hardware.

For more details on kernel stacks please refer Kernel/LTSEnablementStack - Ubuntu Wiki

Did you test it yourself on your hardware? You can boot live media & test without any installation and get a good clue. Currently there is 22.04 media using the GA kernel stack (5.15), updated HWE using 5.19 & the latest media using 6.2, so three different kernel stack media is/was available. Whilst 5.19 isn’t supported any longer, key is GA/5.15 is/was available as is HWE/6.2 and its on your own hardware.

FYI: On some older hardware, I find I have graphic issues first with Ubuntu Desktop (GNOME), or Kubuntu (KDE Plasma) first… then MATE … with Lubuntu (LXQt) and Xubuntu (Xfce) last… and issues with GNOME for 22.04 does not mean you’ll have issues with all flavors (your doesn’t work link). Ubuntu Desktop also defaults to the newer stack for all media; Lubuntu/Xubuntu do not.

On older hardware, I often find the GA or more stable kernel stack option works best (newer hardware benefits instead with the newer HWE stack).

1 Like

Thanks for the hint. I turned the screen saver function off in the GUI of Lubuntu, which had no effect after a reboot.

Power Management is by default disabled on my machine. Just to check the behavior of my machine I turned it on and applied a reboot => no effect.

When I used Lubuntu 20.04 I did not change or add any boot parameters to the file /etc/default/grub. So my graphic card just worked fine with the radeon driver in Lubuntu 20.04.

Thanks for mentioning your workaround proposal with first installing again Lubuntu 20.04 + the HWE and the GA kernel stack on my machine, then upgrading to Lubuntu 22.04, then deciding if I want to continue on 22.04 with the HWE or the GA kernel stack. But this would take too much time, so I will keep the currently installed Lubuntu version 22.04, trying to find a solution for my problem with the Radeon graphic card. And I also would like to keep the (newer) 6.* kernel version on my machine.

By the way, this is the installed kernel version on my machine:

xxx@yyy:~$ uname -a
Linux yyy 6.2.0-26-generic #26~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 13 16:27:29 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

Regarding your question if I had tested Lubuntu 22.04 running its Live image: Yes, I did that yesterday, in order to then install Lubuntu 22.04 on my machine. But already during the installation process (not the “graphic safe” one) of Lubuntu 22.04 I noticed the behavior which is subject to this thread.

I have to make a little correction here:

In my first post here in this thread I inserted a link to another thread here in this forum. The link I posted yesterday was not really incorrected, but it pointed to a certain individual post in that thread, and the content of that external post is now shown in my first post of this thread. This was not my intention. I wanted to link to the other thread itself, so the correct link to that other thread is:

(Sometimes it is not handy if a forum or similar software creates previews of posted links, without showing the link itself.)

(I would have corrected this little error regarding the link I posted yesterday, but editing posts here in this forum unfortunately is not possible.)

Anyway, now back again to the behavior on my machine that is subject this thread.

I tried several things on my machine today to fix the behavior:

  1. I applied the command “ubuntu-drivers list-oem” to find out if there is an OEM kernel installed on my machine. The result of that command was: The prompt was shown again with no other output on the command line. So there is no OEM kernel installed on my machine.

  2. I created and applied an alternative /etc/X11/xorg.conf.d/10-monitor file, defining a lower resolution than in the same file from yesterday. I. e. the alternative file defined a resolution of 1024 x 768 pixels. The result after a reboot: The behavior still exists.

  3. In informed myself about possible kernel boot parameters for the /etc/default/grub file as values for the GRUB_CMDLINE_LINUX_DEFAULT switch. I tried “nomodeset” which resulted in not displaying the Lubuntu login screen after a reboot. On an ArchLinux web site I read later that I should not use “nomodeset” and “vga” (or “vba”?) as kernel boot parameters in connection with my graphic card.

I also informed myself about the kernel module parameters for the radeon driver, which can be retrieved with the command “modinfo -p radeon”. Some of these parameters are explained on a Ubuntu help web site in German, but I could not find a parameter there which, according to me would make sense to be specified as a boot parameter in the /etc/default/grub file.

  1. So at the end I created and applied again a /etc/X11/xorg.conf.d/10-monitor file, this time again reffering to a resolution of 1920 x 1080 pixel, and rebooted the machine, logged into Lubuntu and noticed that now the screen did not turn dark at all, and that the resolution constantly kept to 1920 x 1080 pixel. Only a small black window in the lower right corner of the Lubuntu GUI informed me once in a while that the standard resolution had been applied, and that I can change the resolution in the application lxqt-config-monitor.

So I thought that I more or less had fixed the behaviour which is subject to this thread. Because I had deleted some superflous space characters in the /etc/X11/xorg.conf.d/10-monitor file before I had booted my machine.

But I booted my machine again, and: although the resolution constantly kept to 1920 x 1080 pixel, the screen again turned black for several seconds and then returned back again to displaying the Lubuntu GUI.

I then ran the command “tail -f” on a Xorg log file while the screen switched between displaying the Lubuntu GUI and a dark screen and back to the Lubuntu GUI, and these are the most important last lines of the tails-command, which contains a warning (WW):

xxx@yyy:/var/log$ tail -f Xorg.0.log
[   353.041] (II) RADEON(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
[   353.105] (WW) EDID timing clock 149.56 exceeds claimed max 85MHz, fixing
[   353.105] (II) RADEON(0): EDID vendor "VES", prod id 0
[   353.105] (II) RADEON(0): Using hsync ranges from config file
[   353.105] (II) RADEON(0): Using vrefresh ranges from config file
[   353.106] (II) RADEON(0): Printing DDC gathered Modelines:
[   353.106] (II) RADEON(0): Modeline "1920x1080"x0.0  149.56  1920 2448 2536 2608  1080 1084 1089 1147 -hsync -vsync (57.3 kHz eP)
[   353.106] (II) RADEON(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[   353.106] (II) RADEON(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   353.106] (II) RADEON(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[   353.106] (II) RADEON(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
[   353.106] (II) RADEON(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz e)
[   353.106] (II) RADEON(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz e)
[   353.106] (II) RADEON(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   353.106] (II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[   353.106] (II) RADEON(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
[   353.106] (II) RADEON(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz e)
[   353.106] (II) RADEON(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   353.106] (II) RADEON(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz e)
[   353.106] (II) RADEON(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
[   353.106] (II) RADEON(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz e)
[   353.106] (II) RADEON(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
1 Like


Today I noticed that the screen not always turns dark and then back again to the Lubuntu GUI, then giving me the chance to do something on the Lubuntu GUI for a while, then turning back to darkness and then back to the Lubuntu GUI and so on.

If I then reboot my machine it might be that after a new login to Lubuntu the screen will not show this behavior, i.e. that it will not turn dark once in a while, but keeps displaying the Lubuntu GUI all the time.

Note that I have defined a screen resolution of 1920 x 1080 pixel in my /etc/X11/xorg.conf.d/10-monitor file. If the screen does not turn dark, it continuously is showing a resolution of 1920 x 1080 pixel.

I noticed a reproducible difference between Lubuntu sessions showing the behavior described here in this post, and not showing this behavior:

If the behavior is not shown, the value “59.5339 Hz” for the screen refresh rate is displayed in the Screen Settings Window of the Lubuntu GUI when you open this window. Note that according to xrandr the refresh rate should be 60 Hz for a resolution of 1920 x 1080 pixel if the behavior appears.

If the behavior does not appear, xrandr shows a refresh rate of 59.93 Hz for a resolution of 1920 x 1080 pixel:

xxx@yyy:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1920mm x 1080mm
   1920x1080R    59.93*+
   1920x1080     50.00 +  60.00
   1280x1024     75.02    60.02
   1024x768      75.03    70.07    60.00
   832x624       74.55
   800x600       72.19    75.00    60.32    56.25
   640x480       75.00    72.81    66.67    59.94
DVI-0 disconnected (normal left inverted right x axis y axis)

I tested my machine with the refresh rate of 59.53 Hz having specified this rate in the /etc/X11/xorg.conf.d/10-monitor file, but this made no difference: The behavior was shown again or not, depending on how lucky I was after every reboot.

Regarding the quote of the Xorg.0.log file in my previous post in this thread: I noticed that the line

[ 353.105] (WW) EDID timing clock 149.56 exceeds claimed max 85MHz, fixing

is also part of the Xorg.0.log file if the behavior does not appear. So this line is independent from the behavior appearing or not.

Then I did some “greping” on the output of the command journalctl. I “greped” the terms “radeon” and “drm” in the journalctl output, once when the behavior appeared and once when it dit not appear. I could not find any relevant differences for these two conditions regarding the term “radeon”. For the term “drm” I am not finished yet, I still have to “grep” for “drm” if the behavior does not appear.

1 Like

What I said wasn’t intended to be a workaround, it was what I’d have done… By adding the 22.04 or HWE stack on 20.04 before you actually performed the release-upgrade, you’d have seen on your 20.04 system what you can expect (as the HWE kernel stack is actually the 22.04 GA kernel stack). Then if all tests well, you could have performed the release-upgrade to 22.04 & try using the GA stack (5.15) kernel on upgrade, or use the HWE (6.2) stack you are currently using.

My detail was also to provide the alternate stack option too, as both (GA + HWE) can co-exist except where a few closed-source kernel modules are installed (some NVidia & other drivers or kernel modules prevent this).

If you’re not using closed source kernel modules that prevent dual kernel stacks, I’d consider installing and trying the GA stack OR just boot live media which requires nothing to be installed (again I listed what I’d likely try).

As I tried to explain, I often find the older kernel stack options perform better on older hardware, though in your case I don’t know your graphics card, thus am providing my thoughts on what I’d likely consider exploring.

Given your system is now using HWE (thus the 6.2 kernel), you were likely using the GA stack from Ubuntu 22.04 LTS when using Lubuntu 20.04 LTS (as it was the HWE stack there at 20.04.5 & later).

I’ve not had time to study your provided detail, and this ‘reply’ has sat on this [my] screen for a day+, and I’m sending it even now without anything concrete in it (as for solutions), but I’m somewhat pressed for time, and today I’m working on Ubuntu News (not Lubuntu).

1 Like

Hi guiverc,

Thanks for your response.

I stopped trying to get the Radeon graphic card running properly in 22.04 with the 6.* kernel stack.

Instead, I first tried the 5.15.0-79-generic kernel in my current installation of Lubuntu 22.04 with and without the /etc/X11/xorg.conf.d/10-monitor.conf file - the behavior which is subject to this thread appeared in both cases.

Then I replaced Lubuntu 22.04 with a new installation of Lubuntu 20.04 on my machine:

The behavior did not appear, except from some screen flickering once in a while. Everything was fine with the display. This was the only available kernel that was running in 20.04:

xxx@yyy:~$ uname -a
Linux xxx 5.15.0-79-generic #86~20.04.2-Ubuntu SMP Mon Jul 17 23:27:17 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Installed OS:

xxx@yyy:~$ sudo lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.6 LTS
Release:        20.04
Codename:       focal

Then I applied an upgrade from 20.04 to 22.04 according to the instructions on

Having finished the upgrade I rebooted my machine, and the behavior appeared again: The screen turned black for some seconds, then the desktop got displayed again, but with a lower resolution than before + the windows of the programs I had opened being too big for the screen, so that they were only partly shown, then the screen turned black again for some seconds, then the desktop got displayed again, this time again with the resolution that had been displayed directly after the login. All this was endlessly repeated, with the time to be able to do something on the screen for me as a user being limited to about 30 seconds to a maximum of 1 minute.

This is the only available kernel on my machine after the upgrade:

xxx@yyy:~$ uname -a
Linux yyy 5.15.0-79-generic #86-Ubuntu SMP Mon Jul 10 16:07:21 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

This is the installed OS:

xxx@yyy:~$ sudo lsb_release -a
[sudo] Passwort für xxx:
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04.3 LTS
Release:        22.04
Codename:       jammy

I again created the /etc/X11/xorg.conf.d/10-monitor.conf file and checked if the behavior also appeared with this file - yes, but not always:

I rebooted my machine 4 times, after 3 of these reboots the screen display kept to the screen resolution which I had defined in the /etc/X11/xorg.conf.d/10-monitor.conf file, only that black message box in the lower right corner of the screen showed up once in a while reporting that the standard resolution had been set, referring to lqxt-config-monitor. The screen did not turn black during all these 3 reboots.

After the 4th reboot and login the screen turned seven times black for several seconds within a total time of appr. 15 minutes, and each time after these seconds the desktop got displayed with the resolution I had defined in the /etc/X11/xorg.conf.d/10-monitor.conf file.

As a result of my tests I could say that the AMD Radeon HD 4350/4550 graphics card works fine in Lubuntu 20.04, but not in a tolerable/usable way in Lubuntu 22.04, even not if 22.04 had been upgraded from 20.04 with the 5.15.* kernel.

Anyway, thank you for your support.


An update:

I installed Debian 12/“Bookworm” (currently the stable Debian release) on the affected machine with the following two desktop environments:

  • LxQT

Now this Debian version is installed on my machine:

xxx@yyy:~$ cat /etc/debian_version

Running kernel:

xxx@yyy:~$ uname -a
Linux yyy 6.1.0-11-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.38-4 (2023-08-08) x86_64 GNU/Linux

I created a /etc/X11/xorg.conf file containing Xorg commands and values which I retrieved using the commands “xrandr” and “cvt -r ”.

Note that Debian 12 boots extremely slowly if one uses an xorg.conf or 10-monitor.conf file in the /etc/X11/xorg.conf.d/ directory.

Having installed Debian 12 with these two desktop environments I noticed the following behaviors:

a) Using LxQT in Debian 12:

The behavior as described above in this thread occurs (screen continuously turns black, then returning back to displaying the GUI after some seconds). If there is no /etc/X11/xorg.conf file existing, the behavior consists of the screen continuously turning black + additionally the screen resolution continuously changing to at least 3 three different modes each time the screen is black, before the screen again is showing the GUI.

Installed LxQT version: 1.2.0

b) Using Xfce in Debian 12:

I checked if the behavior occurs during five Xfce sessions which each lasted for at least 10 minutes: The behavior did not occur. Rarely the screen flickered shortly. I finished each of these Xfce sessions with a reboot of the machine.

Installed Xfce version: 4.18
GTK version: 3.24.37

Output of the command xrandr during one of these Xfce sessions:

xxx@yyy:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1920mm x 1080mm
1920x1080R 59.93*+
1920x1080 50.00 + 60.00
1280x1024 75.02 60.02
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 59.94
DVI-0 disconnected (normal left inverted right x axis y axis)


The cause(s) for the behavior described in this thread must be the LxQT version(s) which are part of Debian 12 (currently stable Debian release) and Lubuntu 22.04, maybe in connection with the 6.* kernel versions running in Debian 12 and Lubuntu 22.04.



I just compiled the source code of LxQT in version 1.3.0 on my machine and “installed” the results of the compiled files into the file system on my machine according to the instructions at

Debian 12/“Bookworm” is installed on my machine.

I then checked if the behavior described in this thread also occurs in LxQT 1.3.0 on my machine - yes, it occurs.

But for now I checked this only with an xorg.conf file in /etc/X11 - after a while (1 to x minutes long) the screen turns black for some seconds, then again showing the GUI of LxQT, and this in an endless loop.

I will check in which extend the behavior occurs if there is no xorg.conf file in /etc/X11 later, possibly then additionally the screen resolution will switch every time the screen turns black.

I will report the behavior which I can notice in LxQT 1.3.0 to the makers of LxQT at


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.